summary refs log tree commit diff
path: root/gnu/packages/patches/zlib-correct-crc32-inputs.patch
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-11-14 18:42:41 +0200
committerEfraim Flashner <efraim@flashner.co.il>2022-11-14 18:42:41 +0200
commiteb3362cc8dacb5ef5e5f6c72522898cf30e1541a (patch)
tree702398987da4e9eff68af0800a2601b43f20f887 /gnu/packages/patches/zlib-correct-crc32-inputs.patch
parentbeb418bbf47e9faa6bdfa4af1e582fcb87c55e0d (diff)
downloadguix-eb3362cc8dacb5ef5e5f6c72522898cf30e1541a.tar.gz
gnu: zlib: Update to 1.2.13.
* gnu/packages/compression.scm (zlib): Update to 1.2.13.
[source]: Remove patches.
* gnu/packages/patches/zlib-cc.patch,
gnu/packages/patches/zlib-correct-crc32-inputs.patch: Remove files.
* gnu/local.mk (dist_patch_DATA): Remove them.
Diffstat (limited to 'gnu/packages/patches/zlib-correct-crc32-inputs.patch')
-rw-r--r--gnu/packages/patches/zlib-correct-crc32-inputs.patch44
1 files changed, 0 insertions, 44 deletions
diff --git a/gnu/packages/patches/zlib-correct-crc32-inputs.patch b/gnu/packages/patches/zlib-correct-crc32-inputs.patch
deleted file mode 100644
index 8b09436e2b..0000000000
--- a/gnu/packages/patches/zlib-correct-crc32-inputs.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-Correct incorrect inputs provided to the CRC functions.
-
-Taken from upstream:
-
-  https://github.com/madler/zlib/commit/ec3df00224d4b396e2ac6586ab5d25f673caa4c2
-
-diff --git a/crc32.c b/crc32.c
-index a1bdce5c2..451887bc7 100644
---- a/crc32.c
-+++ b/crc32.c
-@@ -630,7 +630,7 @@ unsigned long ZEXPORT crc32_z(crc, buf, len)
- #endif /* DYNAMIC_CRC_TABLE */
- 
-     /* Pre-condition the CRC */
--    crc ^= 0xffffffff;
-+    crc = (~crc) & 0xffffffff;
- 
-     /* Compute the CRC up to a word boundary. */
-     while (len && ((z_size_t)buf & 7) != 0) {
-@@ -749,7 +749,7 @@ unsigned long ZEXPORT crc32_z(crc, buf, len)
- #endif /* DYNAMIC_CRC_TABLE */
- 
-     /* Pre-condition the CRC */
--    crc ^= 0xffffffff;
-+    crc = (~crc) & 0xffffffff;
- 
- #ifdef W
- 
-@@ -1077,7 +1077,7 @@ uLong ZEXPORT crc32_combine64(crc1, crc2, len2)
- #ifdef DYNAMIC_CRC_TABLE
-     once(&made, make_crc_table);
- #endif /* DYNAMIC_CRC_TABLE */
--    return multmodp(x2nmodp(len2, 3), crc1) ^ crc2;
-+    return multmodp(x2nmodp(len2, 3), crc1) ^ (crc2 & 0xffffffff);
- }
- 
- /* ========================================================================= */
-@@ -1112,5 +1112,5 @@ uLong crc32_combine_op(crc1, crc2, op)
-     uLong crc2;
-     uLong op;
- {
--    return multmodp(op, crc1) ^ crc2;
-+    return multmodp(op, crc1) ^ (crc2 & 0xffffffff);
- }