summary refs log tree commit diff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-12-28 16:06:37 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-12-28 17:05:40 +0200
commit73ff9d6e0eedae5c365c784906c55918a2ed7507 (patch)
treec52afd3de7054f7b0fa417005590a32d98cddebf /gnu/packages/patches
parent49cf2a40d21fc54f387fa5979a5c0979059e9420 (diff)
downloadguix-73ff9d6e0eedae5c365c784906c55918a2ed7507.tar.gz
gnu: enlightenment: Update to 0.25.0.
* gnu/packages/enlightenment.scm (enlightenment): Update to 0.25.0.
[arguments]: Remove unneeded configure-flags. Don't remove phase which
isn't part of the build system. Remove trailing #t from phases.
[inputs]: Add libexif.
* gnu/packages/patches/enlightenment-fix-setuid-path.patch: Refresh patch.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/enlightenment-fix-setuid-path.patch33
1 files changed, 18 insertions, 15 deletions
diff --git a/gnu/packages/patches/enlightenment-fix-setuid-path.patch b/gnu/packages/patches/enlightenment-fix-setuid-path.patch
index a0efb29857..e4f98de7c8 100644
--- a/gnu/packages/patches/enlightenment-fix-setuid-path.patch
+++ b/gnu/packages/patches/enlightenment-fix-setuid-path.patch
@@ -1,9 +1,11 @@
+This diff was generated against enlightenment-0.25.0, targeting all the occurances of 'suid_exes'.
+
 diff --git a/src/bin/e_auth.c b/src/bin/e_auth.c
-index 8b0aa6641..3dff0ad84 100644
+index 6d07a0ac3..31e0e728f 100644
 --- a/src/bin/e_auth.c
 +++ b/src/bin/e_auth.c
-@@ -12,8 +12,7 @@ e_auth_begin(char *passwd)
-    if (pwlen == 0) goto out;
+@@ -38,8 +38,7 @@ e_auth_begin(char *passwd)
+    pwlen = strlen(passwd);
  
     snprintf(buf, sizeof(buf),
 -            "%s/enlightenment/utils/enlightenment_ckpasswd pw",
@@ -11,9 +13,9 @@ index 8b0aa6641..3dff0ad84 100644
 +            "/run/setuid-programs/enlightenment_ckpasswd pw");
     exe = ecore_exe_pipe_run(buf, ECORE_EXE_PIPE_WRITE, NULL);
     if (!exe) goto out;
-    if (ecore_exe_send(exe, passwd, pwlen) != EINA_TRUE) goto out;
-@@ -47,8 +46,7 @@ e_auth_polkit_begin(char *passwd, const char *cookie, unsigned int uid)
-    if (pwlen == 0) goto out;
+    snprintf(buf, sizeof(buf), "pw %s", passwd);
+@@ -75,8 +74,7 @@ e_auth_polkit_begin(char *passwd, const char *cookie, unsigned int uid)
+    pwlen = strlen(passwd);
  
     snprintf(buf, sizeof(buf),
 -            "%s/enlightenment/utils/enlightenment_ckpasswd pk",
@@ -54,23 +56,24 @@ index 9b10b3117..74e6b72ad 100644
       }
     v->guard = ecore_timer_loop_add(E_FM_MOUNT_TIMEOUT, (Ecore_Task_Cb)_e_fm_main_eeze_vol_mount_timeout, v);
 diff --git a/src/bin/e_start_main.c b/src/bin/e_start_main.c
-index b2c439455..cb16c7bd4 100644
+index 722063339..2da2d5a23 100644
 --- a/src/bin/e_start_main.c
 +++ b/src/bin/e_start_main.c
-@@ -710,7 +710,7 @@ main(int argc, char **argv)
-             "E_ALERT_FONT_DIR=%s/data/fonts", eina_prefix_data_get(pfx));
+@@ -596,8 +596,7 @@ main(int argc, char **argv)
+               eina_prefix_data_get(pfx));
     putenv(buf2);
-    snprintf(buf3, sizeof(buf3),
--            "E_ALERT_SYSTEM_BIN=%s/enlightenment/utils/enlightenment_system", eina_prefix_lib_get(pfx));
-+            "E_ALERT_SYSTEM_BIN=/run/setuid-programs/enlightenment_system");
+    myasprintf(&buf3,
+-              "E_ALERT_SYSTEM_BIN=%s/enlightenment/utils/enlightenment_system",
+-              eina_prefix_lib_get(pfx));
++              "E_ALERT_SYSTEM_BIN=/run/setuid-programs/enlightenment_system");
     putenv(buf3);
  
-    if ((valgrind_mode || valgrind_tool) &&
+    home = getenv("HOME");
 diff --git a/src/bin/e_system.c b/src/bin/e_system.c
-index 1e7aabb64..dc0173219 100644
+index bfd43e7e2..45d78b7ed 100644
 --- a/src/bin/e_system.c
 +++ b/src/bin/e_system.c
-@@ -132,7 +132,7 @@ _system_spawn(void)
+@@ -133,7 +133,7 @@ _system_spawn(void)
     else _respawn_count = 0;
     if (_respawn_count > 5) return;
     snprintf(buf, sizeof(buf),