summary refs log tree commit diff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-04-28 17:59:07 +0200
committerMarius Bakke <marius@gnu.org>2021-04-28 17:59:32 +0200
commit8dcbd8a374f21f478f0059d4d62e364897e6e667 (patch)
tree142303840dbf37e58b698007b60cb23bd09af07e /gnu/packages/patches
parentcc036035146263e6544bc94f941771912bfe3c1d (diff)
downloadguix-8dcbd8a374f21f478f0059d4d62e364897e6e667.tar.gz
gnu: ungoogled-chromium: Update to 90.0.4430.93.
* gnu/packages/patches/ungoogled-chromium-system-nspr.patch,
gnu/packages/patches/ungoogled-chromium-system-opus.patch: Delete files.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/chromium.scm (%preserved-third-party-files): Adjust for 90.
(debian-patch): Make REVISION optional, default to %DEBIAN-REVISION.
(%chromium-version): New variable.
(%ungoogled-revision): Set to 90.0.4430.85-1-11-g3184907.
(%debian-revision): Set to debian/90.0.4430.85-1.
(%debian-patches): Add more patches; update hashes.
(%ungoogled-origin): Update hash.
(%guix-patches): Remove obsolete patches.
(libvpx/chromium): Update to 1.9.0-147-g61edec1ef.
(ungoogled-chromium)[version]: Base on %CHROMIUM-REVISION and the last
component of %UNGOOGLED-REVISION, a 'git describe --long' style ID.
[arguments]: Add build_with_flite_lib in #:configure-flags.  Add openjpeg
substitution in #:phases.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/ungoogled-chromium-system-nspr.patch120
-rw-r--r--gnu/packages/patches/ungoogled-chromium-system-opus.patch27
2 files changed, 0 insertions, 147 deletions
diff --git a/gnu/packages/patches/ungoogled-chromium-system-nspr.patch b/gnu/packages/patches/ungoogled-chromium-system-nspr.patch
deleted file mode 100644
index 988296b143..0000000000
--- a/gnu/packages/patches/ungoogled-chromium-system-nspr.patch
+++ /dev/null
@@ -1,120 +0,0 @@
-Build with the system nspr library.
-
-Originally based on a Debian patch:
-https://salsa.debian.org/chromium-team/chromium/-/blob/master/debian/patches/system/nspr.patch
-
---- a/base/time/pr_time_unittest.cc
-+++ b/base/time/pr_time_unittest.cc
-@@ -7,7 +7,7 @@
- 
- #include "base/compiler_specific.h"
- #include "base/stl_util.h"
--#include "base/third_party/nspr/prtime.h"
-+#include <nspr/prtime.h>
- #include "base/time/time.h"
- #include "build/build_config.h"
- #include "testing/gtest/include/gtest/gtest.h"
---- a/base/time/time.cc
-+++ b/base/time/time.cc
-@@ -14,7 +14,7 @@
- #include "base/optional.h"
- #include "base/strings/string_util.h"
- #include "base/strings/stringprintf.h"
--#include "base/third_party/nspr/prtime.h"
-+#include <nspr/prtime.h>
- #include "base/time/time_override.h"
- #include "build/build_config.h"
- 
---- a/base/BUILD.gn
-+++ b/base/BUILD.gn
-@@ -102,6 +102,9 @@
-       "-Wglobal-constructors",
-     ]
-   }
-+  ldflags = [
-+    "-lnspr4",
-+  ]
- }
- 
- config("base_implementation") {
-@@ -720,8 +723,6 @@
-     "third_party/cityhash_v103/src/city_v103.h",
-     "third_party/icu/icu_utf.cc",
-     "third_party/icu/icu_utf.h",
--    "third_party/nspr/prtime.cc",
--    "third_party/nspr/prtime.h",
-     "third_party/superfasthash/superfasthash.c",
-     "thread_annotations.h",
-     "threading/hang_watcher.cc",
---- a/tools/gn/build/gen.py
-+++ b/tools/gn/build/gen.py
-@@ -380,6 +380,9 @@
-       if not options.no_static_libstdcpp:
-         ldflags.append('-static-libstdc++')
- 
-+      # Additional system libraries that are used.
-+      libs.append('-lnspr4')
-+
-       if platform.is_mingw() or platform.is_msys():
-         cflags.remove('-std=c++17')
-         cflags.extend([
---- a/third_party/blink/renderer/platform/BUILD.gn
-+++ b/third_party/blink/renderer/platform/BUILD.gn
-@@ -110,6 +110,9 @@
-     "//build/win:default_exe_manifest",
-     "//third_party/icu",
-   ]
-+  ldflags = [
-+    "-lnspr4"
-+  ]
- }
- 
- # This isn't strictly necessary since we can just add the deps to "platform",
---- a/third_party/crashpad/crashpad/handler/BUILD.gn
-+++ b/third_party/crashpad/crashpad/handler/BUILD.gn
-@@ -144,6 +144,9 @@
-       "../third_party/mini_chromium:base",
-       "../tools:tool_support",
-     ]
-+    ldflags = [
-+      "-lnspr4"
-+    ]
- 
-     if (crashpad_is_win) {
-       if (crashpad_is_in_chromium || crashpad_is_in_dart) {
---- a/chrome/common/search/BUILD.gn
-+++ b/chrome/common/search/BUILD.gn
-@@ -20,6 +20,9 @@
-     "//chrome/common/themes:autogenerated_theme_util",
-     "//skia",
-   ]
-+  ldflags = [
-+    "-lnspr4"
-+  ]
- }
- 
- compiled_action("generate_chrome_colors_info") {
---- a/components/url_formatter/spoof_checks/top_domains/BUILD.gn
-+++ b/components/url_formatter/spoof_checks/top_domains/BUILD.gn
-@@ -31,6 +31,9 @@
-     "//net/tools/huffman_trie:huffman_trie_generator_sources",
-     "//url:url",
-   ]
-+  ldflags = [
-+    "-lnspr4",
-+  ]
-   if (is_ios) {
-     frameworks = [ "UIKit.framework" ]
-   }
---- a/components/schema_org/BUILD.gn
-+++ b/components/schema_org/BUILD.gn
-@@ -33,6 +33,9 @@
-     "//base",
-     "//url",
-   ]
-+  ldflags = [
-+    "-lnspr4",
-+  ]
- }
- 
- compiled_action("schema_org_name_data") {
diff --git a/gnu/packages/patches/ungoogled-chromium-system-opus.patch b/gnu/packages/patches/ungoogled-chromium-system-opus.patch
deleted file mode 100644
index 6f887a31a4..0000000000
--- a/gnu/packages/patches/ungoogled-chromium-system-opus.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-Add missing build dependency on Opus so that system headers are found.
-
-Taken from upstream:
-https://chromium-review.googlesource.com/c/chromium/src/+/2644623
-
-diff --git a/third_party/blink/renderer/modules/webcodecs/BUILD.gn b/third_party/blink/renderer/modules/webcodecs/BUILD.gn
---- a/third_party/blink/renderer/modules/webcodecs/BUILD.gn
-+++ b/third_party/blink/renderer/modules/webcodecs/BUILD.gn
-@@ -65,6 +65,7 @@ blink_modules_sources("webcodecs") {
-     "//media/mojo/clients",
-     "//media/mojo/mojom",
-     "//third_party/libyuv:libyuv",
-+    "//third_party/opus",
-   ]
-   if (media_use_openh264) {
-     deps += [ "//third_party/openh264:encoder" ]
-diff --git a/third_party/blink/renderer/modules/webcodecs/DEPS b/third_party/blink/renderer/modules/webcodecs/DEPS
---- a/third_party/blink/renderer/modules/webcodecs/DEPS
-+++ b/third_party/blink/renderer/modules/webcodecs/DEPS
-@@ -19,6 +19,7 @@ include_rules = [
- 
-     "+third_party/libyuv",
-     "+third_party/openh264",
-+    "+third_party/opus",
- 
-     "+ui/gfx/color_space.h",
-     "+ui/gfx/geometry/rect.h",