summary refs log tree commit diff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-12-24 10:13:32 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-02-20 13:56:39 +0200
commit04b2a8d2a798169b10004c34fa74631a1a94062f (patch)
tree30764493b20c78320faa2a3dc368462aaf2517d0 /gnu/packages/patches
parent3f1c8dd7e2d36eda6bac10043646f5d730ebaeb7 (diff)
downloadguix-04b2a8d2a798169b10004c34fa74631a1a94062f.tar.gz
gnu: maturin: Update to 1.4.0.
* gnu/packages/rust-apps.scm (maturin): Update to 1.4.0.
[source]: Add snippet to fix compilation.
[cargo-inputs]: Add rust-path-slash-0.2.  Replace rust-cargo-options-0.6
with 0.7, rust-cargo-metadata-0.16 with 0.18, rust-cbindgen-0.24 with
0.26, rust-dialoguer-0.10 with 0.11, rust-goblin-0.6 with 0.7,
rust-indexmap-1 with 2, rust-itertools-0.10 with 0.12,
rust-minijinja-0.34 with 1, rust-pyproject-toml-0.6 with 0.8,
rust-python-pkginfo-0.5 with 0.6, rust-rustls-0.20 with 0.21,
rust-rustls-pemfile-1 with 2, rust-toml-0.7 with 0.8,
rust-toml-edit-0.19 with 0.21.
Remove rust-same-file-1.
[cargo-development-inputs]: Add rust-expect-test-1.  Replace
rust-which-4 with 5.
* gnu/packages/patches/maturin-no-cross-compile.patch: Refresh patch.

Change-Id: I1c943ad1a9a3cb315e5baa287f7ba5bc7bc15413
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/maturin-no-cross-compile.patch20
1 files changed, 10 insertions, 10 deletions
diff --git a/gnu/packages/patches/maturin-no-cross-compile.patch b/gnu/packages/patches/maturin-no-cross-compile.patch
index 7394d0854e..98af33d3c7 100644
--- a/gnu/packages/patches/maturin-no-cross-compile.patch
+++ b/gnu/packages/patches/maturin-no-cross-compile.patch
@@ -2,27 +2,27 @@ Remove dependencies on xwin and zig.  We're not offering cross-compilation
 options using these crates.
 
 diff --git a/Cargo.toml b/Cargo.toml
-index 6cbdca3..22ea5ef 100644
+index 6704e46..ff126a9 100644
 --- a/Cargo.toml
 +++ b/Cargo.toml
-@@ -76,16 +76,6 @@ version = "0.1.4"
+@@ -83,16 +83,6 @@ version = "0.1.16"
  [dependencies.cargo-options]
- version = "0.6.0"
+ version = "0.7.2"
  
 -[dependencies.cargo-xwin]
--version = "0.14.3"
+-version = "0.16.2"
 -optional = true
 -default-features = false
 -
 -[dependencies.cargo-zigbuild]
--version = "0.16.10"
+-version = "0.18.0"
 -optional = true
 -default-features = false
 -
  [dependencies.cargo_metadata]
- version = "0.15.3"
+ version = "0.18.0"
  
-@@ -310,8 +300,6 @@ version = "4.3.0"
+@@ -321,8 +311,6 @@ version = "5.0.0"
  [features]
  cli-completion = ["dep:clap_complete_command"]
  cross-compile = [
@@ -31,7 +31,7 @@ index 6cbdca3..22ea5ef 100644
  ]
  default = [
      "full",
-@@ -330,7 +318,6 @@ log = ["tracing-subscriber"]
+@@ -341,7 +329,6 @@ log = ["tracing-subscriber"]
  native-tls = [
      "dep:native-tls",
      "ureq?/native-tls",
@@ -39,7 +39,7 @@ index 6cbdca3..22ea5ef 100644
      "dep:rustls-pemfile",
  ]
  password-storage = [
-@@ -340,7 +327,6 @@ password-storage = [
+@@ -351,7 +338,6 @@ password-storage = [
  rustls = [
      "dep:rustls",
      "ureq?/tls",
@@ -47,7 +47,7 @@ index 6cbdca3..22ea5ef 100644
      "dep:rustls-pemfile",
  ]
  scaffolding = [
-@@ -358,5 +344,3 @@ upload = [
+@@ -369,5 +355,3 @@ upload = [
      "wild",
      "dep:dirs",
  ]