summary refs log tree commit diff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorSergey Trofimov <sarg@sarg.org.ru>2024-08-04 07:34:20 +0200
committerChristopher Baines <mail@cbaines.net>2024-08-22 12:20:25 +0100
commit2e884407c4c23fe2b19fa0ba4661680a0b59bc50 (patch)
tree7dadb74e0311e538750fcc9d9e215726a102ff02 /gnu/packages/patches
parente936d8a1d8b16ec19228072de27e9c4dac254598 (diff)
downloadguix-2e884407c4c23fe2b19fa0ba4661680a0b59bc50.tar.gz
gnu: gpsbabel: Update to 1.9.0.
* gnu/packages/gps.scm (gpsbabel): Update to 1.9.0.
[build-system]: Use cmake-build-system.
[arguments]: Adjust for the new build system.
* gnu/packages/patches/gpsbabel-fix-i686-test.patch: Delete no longer
needed patch.
* gnu/local.mk: Delete patch line.

Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/gpsbabel-fix-i686-test.patch46
1 files changed, 0 insertions, 46 deletions
diff --git a/gnu/packages/patches/gpsbabel-fix-i686-test.patch b/gnu/packages/patches/gpsbabel-fix-i686-test.patch
deleted file mode 100644
index 5ba0305113..0000000000
--- a/gnu/packages/patches/gpsbabel-fix-i686-test.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-https://github.com/gpsbabel/gpsbabel/commit/465a74194d53acea5c8d74c5cf3cb2940546ec92.patch
-Can be removed next release
-
-From 465a74194d53acea5c8d74c5cf3cb2940546ec92 Mon Sep 17 00:00:00 2001
-From: tsteven4 <13596209+tsteven4@users.noreply.github.com>
-Date: Fri, 7 Aug 2020 11:29:22 -0600
-Subject: [PATCH] fix i386 regression error with engima. (#620)
-
-this was motivated by the test failure seen at
-https://buildd.debian.org/status/fetch.php?pkg=gpsbabel&arch=i386&ver=1.7.0%2Bds-4&stamp=1596794554&raw=0
----
- enigma.cc | 13 ++++++++++---
- 1 file changed, 10 insertions(+), 3 deletions(-)
-
-diff --git a/enigma.cc b/enigma.cc
-index 850f27b4e..32fea92d6 100644
---- a/enigma.cc
-+++ b/enigma.cc
-@@ -21,9 +21,16 @@
- 
-  */
- 
-+#include <cmath>           // for fabs, lround
-+#include <cstdint>         // for int32_t, uint8_t, uint32_t
-+#include <cstdlib>         // for abs
-+#include <cstring>         // for strlen, memcpy, memset
-+
-+#include <QtCore/QString>  // for QString
-+
- #include "defs.h"
--#include <cmath>
--#include <cstdlib>
-+#include "gbfile.h"        // for gbfclose, gbfopen_le, gbfread, gbfwrite, gbfile
-+
- 
- #define MYNAME "Enigma binary route and waypoint file format"
- 
-@@ -177,7 +184,7 @@ enigma_waypt_disp(const Waypoint* wpt)
-   le_write32(&ewpt.longitude, decToEnigmaPosition(wpt->longitude));
-   ewpt.waypoint_type = WTYPE_WAYPOINT;
-   if (wpt->altitude != unknown_alt) {
--    le_write32(&ewpt.data.wp_altitude, METERS_TO_FEET(wpt->altitude) + 1000);
-+    le_write32(&ewpt.data.wp_altitude, lround(METERS_TO_FEET(wpt->altitude)) + 1000);
-   }
-   if (wpt->shortname != nullptr) {
-     ewpt.shortname_len = (uint8_t) min(6, strlen(CSTRc(wpt->shortname)));