summary refs log tree commit diff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-08 10:57:17 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-09 12:55:46 -0400
commit311255adc0d1c3b3aa0f6bed5af58e718f0607b2 (patch)
treefed2e1a7203a012f15a9d6ebb991e73e95d43af7 /gnu/packages/patches
parent22491ed9c5cc5135db819b80a7ec2ba7dceaa1ee (diff)
downloadguix-311255adc0d1c3b3aa0f6bed5af58e718f0607b2.tar.gz
gnu: meson: Update to 1.0.1.
* gnu/packages/build-tools.scm (meson-0.63): Update to 1.0.1.
(meson-0.63): Rename to...
(meson): ... this.
[arguments]: Update explanatory comment about why tests are
disabled.  Use gexps and search-input-file in wrap phase override.  Also use
site-packages to simplify the phase.
[inputs]: Replace python-wrapper with python.
(meson-0.60, meson-0.59): Delete variables.
* gnu/packages/patches/meson-allow-dirs-outside-of-prefix.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): De-register it.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/meson-allow-dirs-outside-of-prefix.patch20
1 files changed, 0 insertions, 20 deletions
diff --git a/gnu/packages/patches/meson-allow-dirs-outside-of-prefix.patch b/gnu/packages/patches/meson-allow-dirs-outside-of-prefix.patch
deleted file mode 100644
index f16daa8009..0000000000
--- a/gnu/packages/patches/meson-allow-dirs-outside-of-prefix.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-Source: https://raw.githubusercontent.com/NixOS/nixpkgs/master/pkgs/development/tools/build-managers/meson/allow-dirs-outside-of-prefix.patch
---- a/mesonbuild/coredata.py
-+++ b/mesonbuild/coredata.py
-@@ -506,7 +506,6 @@ class CoreData:
-             return value
-         if option.name.endswith('dir') and value.is_absolute() and \
-            option not in BULITIN_DIR_NOPREFIX_OPTIONS:
--            # Value must be a subdir of the prefix
-             # commonpath will always return a path in the native format, so we
-             # must use pathlib.PurePath to do the same conversion before
-             # comparing.
-@@ -518,7 +517,7 @@ class CoreData:
-             try:
-                 value = value.relative_to(prefix)
-             except ValueError:
--                raise MesonException(msg.format(option, value, prefix))
-+                pass
-             if '..' in str(value):
-                 raise MesonException(msg.format(option, value, prefix))
-         return value.as_posix()