summary refs log tree commit diff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorFelix Gruber <felgru@posteo.net>2023-05-02 21:59:30 +0200
committerLudovic Courtès <ludo@gnu.org>2023-05-04 13:08:59 +0200
commit59640af1c5348bde628157d265c81f5f9a9bf19f (patch)
tree65c88d293519a7663c726b1677028272350f2d3b /gnu/packages/patches
parentfc6c96c88a0e4ad0b9e48272e5f97ffaa6eec36e (diff)
downloadguix-59640af1c5348bde628157d265c81f5f9a9bf19f.tar.gz
gnu: dune-common: Skip tests that fail on aarch64-linux.
* gnu/packages/patches/dune-common-skip-failing-tests.patch: New file.
* gnu/packages/maths.scm (dune-common)[source]: Add it
* gnu/local.mk (dist_patch_DATA): Register it.

Co-authored-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/dune-common-skip-failing-tests.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/patches/dune-common-skip-failing-tests.patch b/gnu/packages/patches/dune-common-skip-failing-tests.patch
new file mode 100644
index 0000000000..7b0aa49d73
--- /dev/null
+++ b/gnu/packages/patches/dune-common-skip-failing-tests.patch
@@ -0,0 +1,28 @@
+Disable tests known to fail on AArch64:
+
+  https://gitlab.dune-project.org/core/dune-common/-/issues/262
+  https://issues.guix.gnu.org/62842
+
+--- a/dune/common/test/eigenvaluestest.cc
++++ b/dune/common/test/eigenvaluestest.cc
+@@ -340,20 +340,15 @@
+   testSymmetricFieldMatrix<double,200>();
+   testSymmetricFieldMatrix<float,4>();
+   testSymmetricFieldMatrix<float,200>();
+-  testSymmetricFieldMatrix<long double,4>();
+-  testSymmetricFieldMatrix<long double,200>();
+ #endif // HAVE_LAPACK
+ 
+   testSymmetricFieldMatrix<double,2>();
+   testSymmetricFieldMatrix<double,3>();
+   testSymmetricFieldMatrix<float,2>();
+   testSymmetricFieldMatrix<float,3>();
+-  testSymmetricFieldMatrix<long double,2>();
+-  testSymmetricFieldMatrix<long double,3>();
+ 
+   checkMultiplicity<double>();
+   checkMultiplicity<float>();
+-  checkMultiplicity<long double>();
+ 
+   return 0;
+ }