summary refs log tree commit diff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorEric Bavier <bavier@posteo.net>2024-02-26 10:28:16 -0600
committerEric Bavier <bavier@posteo.net>2024-03-08 22:32:17 -0600
commita10cce5246e333be52acd7d334f59228895db89a (patch)
treeacc03d68e883ed9a18746f39c9a09ad7ef5fe438 /gnu/packages/patches
parente51c26ef2daf7742eb1617ecb2c7f1594b73fb0c (diff)
downloadguix-a10cce5246e333be52acd7d334f59228895db89a.tar.gz
gnu: netsurf: Update to 3.11.
* gnu/packages/web.scm (netsurf): Update to 3.11.
[arguments]: Adjust to new source.  Netsurf's JS engine cannot handle
DuckDuckGo's redirect urls, so replace websearch form with post to DuckDuckGo
Lite.
(netsurf-buildsystem): Update to 1.10
(libparserutils): Update to 0.2.5.
(hubbub): Update to 0.3.8.
[source]: Remove hubbub-maybe-uninitialized.patch.
(libcss): Update to 0.9.2.
[source]: Remove snippet. Add patch for tests.
(libdom): Update to 0.4.2.
(libsvgtiny): Update to 0.1.8.
(libnsbmp): Update to 0.1.7.
(libnsgif): Update to 1.0.0.
(libnsutils): Update to 0.1.1.
(libnspsl): Update to 0.1.7.
(nsgenbind): Update to 0.9.
* gnu/packages/patches/netsurf-message-timestamp.patch: Adjust to latest
source.
* gnu/packages/patches/hubbub-maybe-uninitialized.patch: Delete patch.
* gnu/packages/patches/libcss-check-format.patch: New patch.
* gnu/local.mk (dist_patch_DATA): Adjust.

Change-Id: I5834b0418270309aa30b6cd0a5a307e20c00fd4a
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/hubbub-maybe-uninitialized.patch40
-rw-r--r--gnu/packages/patches/libcss-check-format.patch13
-rw-r--r--gnu/packages/patches/netsurf-message-timestamp.patch4
3 files changed, 15 insertions, 42 deletions
diff --git a/gnu/packages/patches/hubbub-maybe-uninitialized.patch b/gnu/packages/patches/hubbub-maybe-uninitialized.patch
deleted file mode 100644
index 6f289a770e..0000000000
--- a/gnu/packages/patches/hubbub-maybe-uninitialized.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-From 69d81a8a4d4c223aad67cde0fdf64d64351b9802 Mon Sep 17 00:00:00 2001
-From: Andy Tai <atai@atai.org>
-Date: Sat, 27 May 2023 00:01:34 -0700
-Subject: [PATCH] prevent -Werror=maybe-uninitialized build failure with gcc 11
- when building tests tokeniser2 and tokeniser3
-
----
- test/tokeniser2.c | 2 +-
- test/tokeniser3.c | 2 +-
- 2 files changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/test/tokeniser2.c b/test/tokeniser2.c
-index c8ab9c0..4caae38 100644
---- a/test/tokeniser2.c
-+++ b/test/tokeniser2.c
-@@ -438,7 +438,7 @@ hubbub_error token_handler(const hubbub_token *token, void *pw)
- 			/* Expected token only contained part of the data
- 			 * Calculate how much is left, then try again with
- 			 * the next expected token */
--			hubbub_token t;
-+			hubbub_token t = { 0 };
- 
- 			t.type = HUBBUB_TOKEN_CHARACTER;
- 			t.data.character.ptr += len;
-diff --git a/test/tokeniser3.c b/test/tokeniser3.c
-index e33d018..b3be901 100644
---- a/test/tokeniser3.c
-+++ b/test/tokeniser3.c
-@@ -447,7 +447,7 @@ hubbub_error token_handler(const hubbub_token *token, void *pw)
- 			/* Expected token only contained part of the data
- 			 * Calculate how much is left, then try again with
- 			 * the next expected token */
--			hubbub_token t;
-+			hubbub_token t = { 0 };
- 
- 			t.type = HUBBUB_TOKEN_CHARACTER;
- 			t.data.character.ptr += len;
--- 
-2.40.1
-
diff --git a/gnu/packages/patches/libcss-check-format.patch b/gnu/packages/patches/libcss-check-format.patch
new file mode 100644
index 0000000000..b297ac1c92
--- /dev/null
+++ b/gnu/packages/patches/libcss-check-format.patch
@@ -0,0 +1,13 @@
+Submitted upstream at https://bugs.netsurf-browser.org/mantis/view.php?id=2870
+
+--- libcss-0.9.2/test/dump.h.orig
++++ libcss-0.9.2/test/dump.h
+@@ -131,7 +131,7 @@ void dump_rule_media(css_rule_media *s, char **buf, size_t *buflen)
+ 	char *ptr = *buf;
+ 	css_rule *rule;
+ 
+-	ptr += sprintf(ptr, "| @media %s%03lx",
++	ptr += sprintf(ptr, "| @media %s%03" PRIx64,
+ 			s->media->negate_type ? "not " : "",
+ 			s->media->type);
+ 
diff --git a/gnu/packages/patches/netsurf-message-timestamp.patch b/gnu/packages/patches/netsurf-message-timestamp.patch
index 8df9dbf8f7..03bfdfde3f 100644
--- a/gnu/packages/patches/netsurf-message-timestamp.patch
+++ b/gnu/packages/patches/netsurf-message-timestamp.patch
@@ -1,5 +1,5 @@
---- netsurf-3.8/utils/split-messages.pl.orig	1969-12-31 18:00:00.000000000 -0600
-+++ netsurf-3.8/utils/split-messages.pl	2018-08-30 00:18:58.158367530 -0500
+--- netsurf-3.11/tools/split-messages.pl.orig
++++ netsurf-3.11/tools/split-messages.pl
 @@ -238,7 +238,7 @@
  
      if( $opt{gzip} )