summary refs log tree commit diff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-08 11:34:16 +0800
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-18 10:45:24 +0800
commite2c0a0bdd7e24a07524e9c4d830ff307ecc98abf (patch)
tree83a3e25d7a5e62764189bebb19fef809f1f8b164 /gnu/packages/patches
parent1fd0cc75b0e1cd30695adf27f711cca3b7f137cc (diff)
downloadguix-e2c0a0bdd7e24a07524e9c4d830ff307ecc98abf.tar.gz
gnu: ark: Update to 24.05.2.
* gnu/packages/kde-utils.scm (ark): Update to 24.05.2.
[inputs]: Remove khtml and qtbase-5; add kfilemetadata.
[arguments]: Set #:qtbase to qtbase; Use Gexps.

* gnu/packages/patches/ark-skip-xar-test.patch: Adjust it.

Change-Id: I225a2e0c6487001160cb7d81032b6dcd1fef12dd
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/ark-skip-xar-test.patch54
1 files changed, 23 insertions, 31 deletions
diff --git a/gnu/packages/patches/ark-skip-xar-test.patch b/gnu/packages/patches/ark-skip-xar-test.patch
index 525201997b..be891ad139 100644
--- a/gnu/packages/patches/ark-skip-xar-test.patch
+++ b/gnu/packages/patches/ark-skip-xar-test.patch
@@ -1,44 +1,36 @@
 Guix libarchive no support xar.
 
---- ark-20.04.1.orig/autotests/kerfuffle/loadtest.cpp	2020-12-23 08:46:15.780782601 +0800
-+++ ark-20.04.1/autotests/kerfuffle/loadtest.cpp	2020-12-23 11:13:17.101724042 +0800
-@@ -181,13 +181,6 @@
+--- ark-24.05.2.orig/autotests/kerfuffle/loadtest.cpp	2024-07-08 11:19:30.347366493 +0800
++++ ark-24.05.2/autotests/kerfuffle/loadtest.cpp	2024-07-08 11:19:47.495641516 +0800
+@@ -125,8 +125,6 @@
          qDebug() << "lz4 executable not found in path. Skipping lz4 test.";
      }
  
--    QTest::newRow("xar archive")
--            << QFINDTESTDATA("data/simplearchive.xar")
--            << QStringLiteral("simplearchive")
--            << true << false << false << false << false << 0 << Archive::Unencrypted
--            << QStringLiteral("simplearchive")
--            << QString();
--
-     QTest::newRow("mimetype child of application/zip")
-             << QFINDTESTDATA("data/test.odt")
-             << QStringLiteral("test")
---- ark-20.04.1.orig/autotests/kerfuffle/extracttest.cpp	2020-12-23 08:46:15.780782601 +0800
-+++ ark-20.04.1/autotests/kerfuffle/extracttest.cpp	2020-12-23 11:14:02.801809620 +0800
-@@ -350,23 +350,6 @@
+-    QTest::newRow("xar archive") << QFINDTESTDATA("data/simplearchive.xar") << QStringLiteral("simplearchive") << true << false << false << false << false << 0
+-                                 << Archive::Unencrypted << 6 << QStringLiteral("simplearchive") << QString();
+ 
+     QTest::newRow("mimetype child of application/zip") << QFINDTESTDATA("data/test.odt") << QStringLiteral("test") << false << true << false << false << false
+                                                        << 0 << Archive::Unencrypted << 17 << QStringLiteral("test") << QString();
+
+
+--- ark-24.05.2.orig/autotests/kerfuffle/extracttest.cpp	2024-07-08 11:21:25.849219202 +0800
++++ ark-24.05.2/autotests/kerfuffle/extracttest.cpp	2024-07-08 11:22:01.413789814 +0800
+@@ -329,18 +329,5 @@
          qDebug() << "lz4 executable not found in path. Skipping lz4 test.";
      }
  
 -    archivePath = QFINDTESTDATA("data/simplearchive.xar");
--    QTest::newRow("extract selected entries from a xar archive without path")
--            << archivePath
--            << QVector<Archive::Entry*> {
--                   new Archive::Entry(this, QStringLiteral("dir1/file11.txt"), QString()),
--                   new Archive::Entry(this, QStringLiteral("file4.txt"), QString())
--               }
--            << optionsNoPaths
--            << 2;
+-    setupRow("extract selected entries from a xar archive without path",
+-             archivePath,
+-             QList<Archive::Entry *>{
+-                 new Archive::Entry(this, QStringLiteral("dir1/file11.txt"), QString()),
+-                 new Archive::Entry(this, QStringLiteral("file4.txt"), QString()),
+-             },
+-             optionsNoPaths,
+-             2);
 -
 -    archivePath = QFINDTESTDATA("data/simplearchive.xar");
--    QTest::newRow("extract all entries from a xar archive with path")
--            << archivePath
--            << QVector<Archive::Entry*>()
--            << optionsPreservePaths
--            << 6;
+-    setupRow("extract all entries from a xar archive with path", archivePath, QList<Archive::Entry *>(), optionsPreservePaths, 6);
 -
      archivePath = QFINDTESTDATA("data/hello-1.0-x86_64.AppImage");
-     QTest::newRow("extract all entries from an AppImage with path")
-             << archivePath
+     setupRow("extract all entries from an AppImage with path", archivePath, QList<Archive::Entry *>(), optionsPreservePaths, 7);