summary refs log tree commit diff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-07-09 22:30:15 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-07-09 22:51:08 -0400
commit65c77f608916f0c206d0d821db1afa2558c5a74f (patch)
treec2517794018d50a67c03c3dbb5bb7087d1d9e03e /gnu/packages/patches
parent2687f7d2c2d18ba4fd0b9dadc6afa658530cd643 (diff)
downloadguix-65c77f608916f0c206d0d821db1afa2558c5a74f.tar.gz
gnu: lightdm: Apply patch to fix VNC server address binding ordering.
* gnu/packages/patches/lightdm-vnc-ipv6.patch: New patch file.
* gnu/local.mk (dist_patch_DATA): Register it.
* gnu/packages/display-managers.scm (lightdm): Apply it.
* gnu/tests/lightdm.scm (run-lightdm-test): Remove comment and expected fail
directive for the "can connect to TCP port 5900 on IPv6" test.

Suggested-by: Bruno Victal <mirai@makinata.eu>
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/lightdm-vnc-ipv6.patch48
1 files changed, 48 insertions, 0 deletions
diff --git a/gnu/packages/patches/lightdm-vnc-ipv6.patch b/gnu/packages/patches/lightdm-vnc-ipv6.patch
new file mode 100644
index 0000000000..68e4363d3e
--- /dev/null
+++ b/gnu/packages/patches/lightdm-vnc-ipv6.patch
@@ -0,0 +1,48 @@
+Submitted upstream: https://github.com/canonical/lightdm/pull/312
+
+diff --git a/src/vnc-server.c b/src/vnc-server.c
+index d3500764..00a2fc02 100644
+--- a/src/vnc-server.c
++++ b/src/vnc-server.c
+@@ -126,18 +126,10 @@ vnc_server_start (VNCServer *server)
+ 
+     g_return_val_if_fail (server != NULL, FALSE);
+ 
+-    g_autoptr(GError) ipv4_error = NULL;
+-    priv->socket = open_tcp_socket (G_SOCKET_FAMILY_IPV4, priv->port, priv->listen_address, &ipv4_error);
+-    if (ipv4_error)
+-        g_warning ("Failed to create IPv4 VNC socket: %s", ipv4_error->message);
+-
+-    if (priv->socket)
+-    {
+-        GSource *source = g_socket_create_source (priv->socket, G_IO_IN, NULL);
+-        g_source_set_callback (source, (GSourceFunc) read_cb, server, NULL);
+-        g_source_attach (source, NULL);
+-    }
+-
++    // Bind to IPv6 first, as this implies binding to 0.0.0.0 in the
++    // Linux kernel default configuration, which would otherwise cause
++    // IPv6 clients to fail with "Error binding to address [::]:5900:
++    // Address already in use" (#266).
+     g_autoptr(GError) ipv6_error = NULL;
+     priv->socket6 = open_tcp_socket (G_SOCKET_FAMILY_IPV6, priv->port, priv->listen_address, &ipv6_error);
+     if (ipv6_error)
+@@ -150,6 +142,18 @@ vnc_server_start (VNCServer *server)
+         g_source_attach (source, NULL);
+     }
+ 
++    g_autoptr(GError) ipv4_error = NULL;
++    priv->socket = open_tcp_socket (G_SOCKET_FAMILY_IPV4, priv->port, priv->listen_address, &ipv4_error);
++    if (ipv4_error)
++        g_warning ("Failed to create IPv4 VNC socket: %s", ipv4_error->message);
++
++    if (priv->socket)
++    {
++        GSource *source = g_socket_create_source (priv->socket, G_IO_IN, NULL);
++        g_source_set_callback (source, (GSourceFunc) read_cb, server, NULL);
++        g_source_attach (source, NULL);
++    }
++
+     if (!priv->socket && !priv->socket6)
+         return FALSE;
+