summary refs log tree commit diff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorAndy Wingo <wingo@pobox.com>2015-04-07 09:42:36 +0200
committerLudovic Courtès <ludo@gnu.org>2015-04-08 14:42:27 +0200
commit7b2abd0055fc88ac95a5ad10df7f150181564b7a (patch)
tree41ddb38152d492411a06b2b89ff5b7d68d2c1867 /gnu/packages/patches
parent7ce597ff9e7232f91016d5e4945cd24ec691223c (diff)
downloadguix-7b2abd0055fc88ac95a5ad10df7f150181564b7a.tar.gz
gnu: Add geoclue.
* gnu/packages/gnome.scm (geoclue): New variable.
* gnu/packages/patches/geoclue-config.patch: New file.
* gnu-system.am (dist_patch_DATA): Add it.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/geoclue-config.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/patches/geoclue-config.patch b/gnu/packages/patches/geoclue-config.patch
new file mode 100644
index 0000000000..dd35b90be5
--- /dev/null
+++ b/gnu/packages/patches/geoclue-config.patch
@@ -0,0 +1,25 @@
+Allow the configuration file to be specified via an environment variable.
+
+--- geoclue-2.1.10/src/gclue-config.c	2015-04-07 09:50:07.721074380 +0200
++++ geoclue-2.1.10/src/gclue-config.c	2015-04-07 10:27:26.613171960 +0200
+@@ -235,6 +235,11 @@
+ gclue_config_init (GClueConfig *config)
+ {
+         GError *error = NULL;
++	const char *config_file_path;
++
++	config_file_path = g_getenv ("GEOCLUE_CONFIG_FILE");
++	if (config_file_path == NULL)
++	  config_file_path = CONFIG_FILE_PATH;
+ 
+         config->priv =
+                 G_TYPE_INSTANCE_GET_PRIVATE (config,
+@@ -242,7 +247,7 @@
+                                             GClueConfigPrivate);
+         config->priv->key_file = g_key_file_new ();
+         g_key_file_load_from_file (config->priv->key_file,
+-                                   CONFIG_FILE_PATH,
++                                   config_file_path,
+                                    0,
+                                    &error);
+         if (error != NULL) {