summary refs log tree commit diff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-03-15 14:23:51 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-03-15 15:09:07 +0100
commit745041b59ff90195c5d5aad98310f5ad1a34a693 (patch)
treeb52f8b6ab500e4f4920e86a8c1ec6025aafc6eb7 /gnu/packages/patches
parentab6e4ab8c3412e28cf75f758da757da843ace902 (diff)
downloadguix-745041b59ff90195c5d5aad98310f5ad1a34a693.tar.gz
gnu: python-jedi: Update to 0.16.
* gnu/packages/patches/python-jedi-deleted-variables.patch: New file.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/python-xyz.scm (python-jedi): Update to 0.16.
[source](patches): New field.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/python-jedi-deleted-variables.patch38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/patches/python-jedi-deleted-variables.patch b/gnu/packages/patches/python-jedi-deleted-variables.patch
new file mode 100644
index 0000000000..53bdc05cde
--- /dev/null
+++ b/gnu/packages/patches/python-jedi-deleted-variables.patch
@@ -0,0 +1,38 @@
+Fix test failure in some environments, including Guix.
+
+Taken from upstream:
+https://github.com/davidhalter/jedi/commit/bec87f7ff82b0731713c6520a14c213341b4cecf
+
+diff --git a/test/completion/basic.py b/test/completion/basic.py
+index b40068179..3ff919ca6 100644
+--- a/test/completion/basic.py
++++ b/test/completion/basic.py
+@@ -209,11 +209,11 @@ def global_as_import():
+ 
+ deleted_var = 3
+ del deleted_var
+-#? int()
++#?
+ deleted_var
+-#? ['deleted_var']
++#? []
+ deleted_var
+-#! ['deleted_var = 3']
++#! []
+ deleted_var
+ 
+ # -----------------
+diff --git a/test/test_api/test_full_name.py b/test/test_api/test_full_name.py
+index 4fdb861b0..6858b6ca8 100644
+--- a/test/test_api/test_full_name.py
++++ b/test/test_api/test_full_name.py
+@@ -112,7 +112,8 @@ def test_os_path(Script):
+ 
+ def test_os_issues(Script):
+     """Issue #873"""
+-    assert [c.name for c in Script('import os\nos.nt''').complete()] == ['nt']
++    # nt is not found, because it's deleted
++    assert [c.name for c in Script('import os\nos.nt''').complete()] == []
+ 
+ 
+ def test_param_name(Script):