summary refs log tree commit diff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-03-04 20:59:48 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-03-15 08:47:21 +0200
commitb5ffcbe1af01544cac31f056a700f5382f3e6b14 (patch)
tree115e2e55c23ac8f8203e416c68e4436920922dc2 /gnu/packages/patches
parent90beb0ed457a1b2a1724ff03371b8a3ddcf59929 (diff)
downloadguix-b5ffcbe1af01544cac31f056a700f5382f3e6b14.tar.gz
gnu: Add bidiv.
* gnu/packages/fribidi.scm (bidiv): New variable.
* gnu/packages/patches/bidiv-update-fribidi.patch: New file.
* gnu/local.mk (dist_patch_DATA): Register it.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/bidiv-update-fribidi.patch50
1 files changed, 50 insertions, 0 deletions
diff --git a/gnu/packages/patches/bidiv-update-fribidi.patch b/gnu/packages/patches/bidiv-update-fribidi.patch
new file mode 100644
index 0000000000..d000cfeda4
--- /dev/null
+++ b/gnu/packages/patches/bidiv-update-fribidi.patch
@@ -0,0 +1,50 @@
+https://sources.debian.org/data/main/b/bidiv/1.5-6/debian/patches/fribidi_019
+
+Description: Fix building with fribidi 1.9
+Author: أحمد المحمودي <aelmahmoudy@users.sourceforge.net>
+Bug-Debian: http://bugs.debian.org/568130
+
+--- a/bidiv.c
++++ b/bidiv.c
+@@ -141,8 +141,9 @@ bidiv(FILE *fp)
+ 				*/
+ 				if(c1<0x80||c1>0xbf){
+ 					ungetc(c1, fp);
+-					unicode_in[len]=
+-						fribidi_iso8859_8_to_unicode_c(c);
++					fribidi_charset_to_unicode(
++						FRIBIDI_CHAR_SET_ISO8859_8,
++						&c, 1, &unicode_in[len]);
+ 				} else
+ 				unicode_in[len]=((c & 037) << 6) + (c1 & 077);
+ 				newline=0;
+@@ -153,8 +154,9 @@ bidiv(FILE *fp)
+ 				   In the future we will have a language
+ 				   option, which will control this (as well
+ 				   as the output encoding). */
+-				unicode_in[len]=
+-					fribidi_iso8859_8_to_unicode_c(c);
++				fribidi_charset_to_unicode(
++					FRIBIDI_CHAR_SET_ISO8859_8,
++					&c, 1, &unicode_in[len]);
+ #else
+ 				in[len]=c;
+ #endif
+@@ -206,11 +208,11 @@ bidiv(FILE *fp)
+ 			rtl_line=0;
+ 
+ 		if(out_utf8)
+-			fribidi_unicode_to_utf8(unicode_out, len,
+-					     out);
++			fribidi_unicode_to_charset(FRIBIDI_CHAR_SET_UTF8,
++					unicode_out, len, out);
+ 		else
+-			fribidi_unicode_to_iso8859_8(unicode_out, len,
+-						     out);
++			fribidi_unicode_to_charset(FRIBIDI_CHAR_SET_ISO8859_8,
++				unicode_out, len, out);
+ 		/* if rtl_line (i.e., base_dir is RL), and we didn't fill the
+ 		   entire width, we need to pad with spaces. Maybe in the
+ 		   future this should be an option.
+--
+