summary refs log tree commit diff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2020-03-26 12:16:45 +0100
committerLudovic Courtès <ludo@gnu.org>2020-03-26 13:07:19 +0100
commitc7af9d0b5ebaa1fdb08ff5d8a56004998bcd8103 (patch)
tree12d0c4677691c287fb784e1f65a08d35672a04fe /gnu/packages/patches
parent315b98b9eb71e1a56de6a49ffbfed0af3c92be7e (diff)
downloadguix-c7af9d0b5ebaa1fdb08ff5d8a56004998bcd8103.tar.gz
gnu: gnupg: Use ~/.guix-profile/bin/pinentry by default.
Fixes <https://bugs.gnu.org/24076>.
Reported by Danny Milosavljevic <dannym@scratchpost.org>.

* gnu/packages/patches/gnupg-default-pinentry.patch: New file.
* gnu/packages/gnupg.scm (gnupg)[source]: Use it.
* gnu/local.mk (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/gnupg-default-pinentry.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/gnu/packages/patches/gnupg-default-pinentry.patch b/gnu/packages/patches/gnupg-default-pinentry.patch
new file mode 100644
index 0000000000..272f4b53dc
--- /dev/null
+++ b/gnu/packages/patches/gnupg-default-pinentry.patch
@@ -0,0 +1,15 @@
+Default to the pinentry program installed in ~/.guix-profile.
+
+diff --git a/common/homedir.c b/common/homedir.c
+index e9e75d0..74e0aaf 100644
+--- a/common/homedir.c
++++ b/common/homedir.c
+@@ -968,7 +968,7 @@ get_default_pinentry_name (int reset)
+   } names[] = {
+     /* The first entry is what we return in case we found no
+        other pinentry.  */
+-    { gnupg_bindir, DIRSEP_S "pinentry" EXEEXT_S },
++    { gnupg_homedir, "/.guix-profile/bin/pinentry" },
+ #ifdef HAVE_W32_SYSTEM
+     /* Try Gpg4win directory (with bin and without.) */
+     { w32_rootdir, "\\..\\Gpg4win\\bin\\pinentry.exe" },