summary refs log tree commit diff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorMuriithi Frederick Muriuki <fredmanglis@gmail.com>2017-06-15 18:39:05 +0300
committerEfraim Flashner <efraim@flashner.co.il>2017-08-01 15:21:52 +0300
commit269504a797a3e950725e406edf550a03946900ad (patch)
treed22915816fbed369f9533ffce85db694dc76b9c9 /gnu/packages/patches
parent3d0fbd3c2f92cee74fd443eb5c252b8dd9b75b43 (diff)
downloadguix-269504a797a3e950725e406edf550a03946900ad.tar.gz
gnu: python-pbr-minimal: Update to 3.0.1
* gnu/packages/python.scm (python-pbr-minimal): Update to 3.0.1
[source]: Update hash and remove patch.
* gnu/packages/patches/python-pbr-fix-man-page-support.patch: Remove file.
* gnu/local.mk (dist_patch_DATA): Remove it.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/python-pbr-fix-man-page-support.patch28
1 files changed, 0 insertions, 28 deletions
diff --git a/gnu/packages/patches/python-pbr-fix-man-page-support.patch b/gnu/packages/patches/python-pbr-fix-man-page-support.patch
deleted file mode 100644
index b9036f5b01..0000000000
--- a/gnu/packages/patches/python-pbr-fix-man-page-support.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-See: https://bugs.launchpad.net/oslosphinx/+bug/1661861
-diff -ur orig/pbr-1.10.0/pbr/builddoc.py pbr-1.10.0/pbr/builddoc.py
---- orig/pbr-1.10.0/pbr/builddoc.py	2016-05-23 21:38:18.000000000 +0200
-+++ pbr-1.10.0/pbr/builddoc.py	2017-02-18 14:01:37.424434317 +0100
-@@ -138,7 +138,8 @@
-             sphinx_config.init_values(warnings.warn)
-         else:
-             sphinx_config.init_values()
--        if self.builder == 'man' and len(sphinx_config.man_pages) == 0:
-+        if self.builder == 'man' and len(
-+                getattr(sphinx_config, 'man_pages', '')) == 0:
-             return
-         app = application.Sphinx(
-             self.source_dir, self.config_dir,
-diff -ur orig/pbr-1.10.0/pbr/util.py pbr-1.10.0/pbr/util.py
---- orig/pbr-1.10.0/pbr/util.py	2016-05-23 21:38:18.000000000 +0200
-+++ pbr-1.10.0/pbr/util.py	2017-02-18 15:36:32.951196795 +0100
-@@ -211,7 +211,9 @@
-     parser.read(path)
-     config = {}
-     for section in parser.sections():
--        config[section] = dict(parser.items(section))
-+        config[section] = dict()
-+        for k, value in parser.items(section):
-+            config[section][k.replace('-', '_')] = value
- 
-     # Run setup_hooks, if configured
-     setup_hooks = has_get_option(config, 'global', 'setup_hooks')