summary refs log tree commit diff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorPetr Hodina <phodina@protonmail.com>2022-09-22 21:31:26 +0200
committerMarius Bakke <marius@gnu.org>2022-11-21 22:01:06 +0100
commit430df96a9cb7927705d3d3d774d6fa9d3e568e55 (patch)
treeb11dc747834b47cfcb2100ae2a18fec4a70378b9 /gnu/packages/patches
parent2ecb9af51c601287523b11c5f3c85d23d1d8fe9a (diff)
downloadguix-430df96a9cb7927705d3d3d774d6fa9d3e568e55.tar.gz
gnu: KDE Framework: Update 5.98.0.
* gnu/packages/kde-frameworks.scm(extra-cmake-modules, attica, bluez-qt,
breeze-icons, kapidox, karchive, kcalendarcore, kcodecs, kconfig,
kcoreaddons, kdbusaddons, kdnssd, kguiaddons, kholidays, ki18n, kidletime,
kirigami, kitemmodels, kitemviews, kplotting,
ksyntaxhighlighting, kwayland, kwidgetsaddons, kwindowsystem, modemmanager-qt,
networkmanager-qt, oxygen-icons, prison, qqc2-desktop-style, solid, sonnet,
threadweaver, kactivities, kauth, kcompletion, kcontacts, kcrash, kdoctools,
kfilemetadata, kimageformats, kjobwidgets, knotifications, kpackage, kpty,
kunitconversion, syndication, baloo, kactivities-stats, kbookmarks,
kcmutils, kconfigwidgets,
kdeclarative, kded, kdesignerplugin, kdesu, kdewebkit, kemoticons,
kglobalaccel, kiconthemes, kinit, kio, knewstuff, knotifyconfig,
kparts, kpeople, krunner, kservice, ktexteditor, ktextwidgets,kwallet,
kxmlgui, kxmlrpcclient, plasma-framework, purpose,
kde-frameworkintegration, kdelibs4support, khtml, kjs, kjsembed,
kmediaplayer, kross, kdav): Update to 5.96.0.
(kwayland)[inputs]: Add libxkbcommon.
(kcontacts)[arguments]: Enable old test, disable new failing tests.
(kiconthemes)[inputs]: Add qtdeclarative-5.
(kwallet)[inputs]: Add qca.
[arguments]: Disable failing test.
(kcontacts)[arguments]: Enable tests.
[source](patches): Add patch.
* gnu/packages/patches/kcontacts-incorrect-country-name.patch: New file.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly

Signed-off-by: Marius Bakke <marius@gnu.org>
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/kcontacts-incorrect-country-name.patch85
1 files changed, 85 insertions, 0 deletions
diff --git a/gnu/packages/patches/kcontacts-incorrect-country-name.patch b/gnu/packages/patches/kcontacts-incorrect-country-name.patch
new file mode 100644
index 0000000000..7e15f9f5eb
--- /dev/null
+++ b/gnu/packages/patches/kcontacts-incorrect-country-name.patch
@@ -0,0 +1,85 @@
+From 5fc2ce8b9f34ea3218a030aeede01b70bedb2546 Mon Sep 17 00:00:00 2001
+From: Petr Hodina <phodina@protonmail.com>
+Date: Wed, 28 Sep 2022 20:58:43 +0200
+Subject: [PATCH] autotests: Fix incorrect name of country in comparison.
+
+
+diff --git a/autotests/addresstest.cpp b/autotests/addresstest.cpp
+index fc6a9bc7..01e474b6 100644
+--- a/autotests/addresstest.cpp
++++ b/autotests/addresstest.cpp
+@@ -157,7 +157,7 @@ void AddressTest::formatTest()
+ 
+         const QString result(
+             QStringLiteral("Jim Knopf\nLummerlandstr. 1\n"
+-                           "12345 Lummerstadt\n\nGERMANIA"));
++                           "12345 Lummerstadt\n\nGERMANY"));
+ 
+         QCOMPARE(address.formatted(KContacts::AddressFormatStyle::Postal, QStringLiteral("Jim Knopf")), result);
+ #if KCONTACTS_BUILD_DEPRECATED_SINCE(5, 92)
+@@ -175,7 +175,7 @@ void AddressTest::formatTest()
+ 
+         const QString result(
+             QStringLiteral("Huck Finn\n457 Foobar Ave\nNERVOUSBREAKTOWN,"
+-                           " DC 1A2B3C\n\nSTATI UNITI"));
++                           " DC 1A2B3C\n\nUNITED STATES"));
+         QCOMPARE(address.formatted(KContacts::AddressFormatStyle::Postal, QStringLiteral("Huck Finn")), result);
+     }
+ 
+@@ -188,7 +188,7 @@ void AddressTest::formatTest()
+ 
+         const QString result(
+             QStringLiteral("Jim Knopf\nLummerlandstr. 1\n"
+-                           "12345 Lummerstadt\n\nGERMANIA"));
++                           "12345 Lummerstadt\n\nGERMANY"));
+ 
+         QCOMPARE(address.formatted(KContacts::AddressFormatStyle::Postal, QStringLiteral("Jim Knopf")), result);
+     }
+@@ -214,7 +214,7 @@ void AddressTest::formatTest()
+         address.setCountry(QStringLiteral("Schweiz"));
+ 
+         // we want the Italian variant of the Swiss format for it_CH
+-        const QString result(QStringLiteral("Dr. Konqui\nCasella postale 5678\nHaus Randa\n1234 Randa\n\nSVIZZERA"));
++        const QString result(QStringLiteral("Dr. Konqui\nCasella postale 5678\nHaus Randa\n1234 Randa\n\nSWITZERLAND"));
+ 
+         QCOMPARE(address.formatted(KContacts::AddressFormatStyle::Postal, QStringLiteral("Dr. Konqui")), result);
+     }
+@@ -228,14 +228,14 @@ void AddressTest::formatTest()
+         address.setCountry(QStringLiteral("CH"));
+ 
+         // we want the Italian variant of the Swiss format for it_CH
+-        const QString result(QStringLiteral("Dr. Konqui\nCasella postale 5678\nHaus Randa\n1234 Randa\n\nSVIZZERA"));
++        const QString result(QStringLiteral("Dr. Konqui\nCasella postale 5678\nHaus Randa\n1234 Randa\n\nSWITZERLAND"));
+         QCOMPARE(address.formatted(KContacts::AddressFormatStyle::Postal, QStringLiteral("Dr. Konqui")), result);
+     }
+ 
+     {
+         KContacts::Address address;
+         address.setCountry(QStringLiteral("CH"));
+-        QCOMPARE(address.formatted(KContacts::AddressFormatStyle::Postal, QString()), QLatin1String("SVIZZERA"));
++        QCOMPARE(address.formatted(KContacts::AddressFormatStyle::Postal, QString()), QLatin1String("SWITZERLAND"));
+     }
+ 
+     {
+@@ -257,14 +257,14 @@ void AddressTest::formatTest()
+         address.setLocality(QStringLiteral("Minato-ku"));
+         address.setPostalCode(QStringLiteral("106-0047"));
+         address.setStreet(QStringLiteral("4-6-28 Minami-Azabu"));
+-        auto result = QString::fromUtf8("4-6-28 Minami-Azabu, Minato-ku\nTOKYO 106-0047\n\nGIAPPONE");
++        auto result = QString::fromUtf8("4-6-28 Minami-Azabu, Minato-ku\nTOKYO 106-0047\n\nJAPAN");
+         QCOMPARE(address.formatted(KContacts::AddressFormatStyle::Postal), result);
+ 
+         address.setRegion(QStringLiteral("東京"));
+         address.setLocality(QStringLiteral("都港区"));
+         address.setPostalCode(QStringLiteral("106-0047"));
+         address.setStreet(QStringLiteral("南麻布 4-6-28"));
+-        result = QString::fromUtf8("〒106-0047\n東京都港区南麻布 4-6-28\n\nGIAPPONE");
++        result = QString::fromUtf8("〒106-0047\n東京都港区南麻布 4-6-28\n\nJAPAN");
+         QCOMPARE(address.formatted(KContacts::AddressFormatStyle::Postal), result);
+     }
+ }
+
+base-commit: 1d757eba019718cab5d3b33a231d19daf31eb8ba
+-- 
+2.37.2
+