summary refs log tree commit diff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2021-11-26 00:35:54 +0100
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-27 01:22:32 -0500
commit941f776fce7d1edef8a7c8c98022c4187400fc51 (patch)
tree4f410e5af52a0d2886aa80090856b014a0cbeda4 /gnu/packages/patches
parentd508c5baab16f99818e6514351ed0ab7ad9e8116 (diff)
downloadguix-941f776fce7d1edef8a7c8c98022c4187400fc51.tar.gz
gnu: julia: Correctly test using '#:parallel-tests?'.
* gnu/packages/julia.scm (julia)[phases]{enable-parallel-tests}: Use
PARALLEL-TESTS?, not PARALLEL-BUILD?.  Remove comment.
* gnu/packages/patches/julia-allow-parallel-build.patch: Move explanatory
comment to the top of the patch.

Modified-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/julia-allow-parallel-build.patch10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/patches/julia-allow-parallel-build.patch b/gnu/packages/patches/julia-allow-parallel-build.patch
index 5a382e7c89..cc1d42fee4 100644
--- a/gnu/packages/patches/julia-allow-parallel-build.patch
+++ b/gnu/packages/patches/julia-allow-parallel-build.patch
@@ -1,3 +1,8 @@
+Allow parallel tests with isolated environment.
+
+See https://github.com/JuliaLang/julia/issues/43205 and
+https://github.com/JuliaLang/julia/pull/43211.
+
 diff --git a/test/runtests.jl b/test/runtests.jl
 index 2f9cd058bb..150395e78c 100644
 --- a/test/runtests.jl
@@ -11,14 +16,11 @@ index 2f9cd058bb..150395e78c 100644
  using Base: Experimental
  
  include("choosetests.jl")
-@@ -83,11 +83,15 @@ prepend!(tests, linalg_tests)
+@@ -83,11 +83,12 @@ prepend!(tests, linalg_tests)
  import LinearAlgebra
  cd(@__DIR__) do
      n = 1
 -    if net_on
-+    # Allow parallel tests with isolated environment
-+    # https://github.com/JuliaLang/julia/issues/43205
-+    # https://github.com/JuliaLang/julia/pull/43211
 +    if net_on || haskey(ENV, "JULIA_CPU_THREADS")
          n = min(Sys.CPU_THREADS, length(tests))
          n > 1 && addprocs_with_testenv(n)