summary refs log tree commit diff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-01-17 08:03:29 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-01-24 20:44:35 +0100
commit41fdad9f8c48a674d758c9835ab8640a9192a1a6 (patch)
tree87b8ff2e2218e47bfb9525b917865b8f3b935e1b /gnu/packages/patches
parent96af5dcf917853e40c6b17a2969fb44c161e096c (diff)
downloadguix-41fdad9f8c48a674d758c9835ab8640a9192a1a6.tar.gz
gnu: python-cffi: Update to 1.13.2.
* gnu/packages/patches/python-cffi-x87-stack-clean.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/libffi.scm (python-cffi): Update to 1.13.2.
[arguments]: Adjust substitution.  Remove obsolete phase.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/python-cffi-x87-stack-clean.patch29
1 files changed, 0 insertions, 29 deletions
diff --git a/gnu/packages/patches/python-cffi-x87-stack-clean.patch b/gnu/packages/patches/python-cffi-x87-stack-clean.patch
deleted file mode 100644
index 50243505ee..0000000000
--- a/gnu/packages/patches/python-cffi-x87-stack-clean.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-Fix test that fails on i686:
-
-https://bitbucket.org/cffi/cffi/issues/382
-
-This is a squashed version of these commits:
-https://bitbucket.org/cffi/cffi/commits/ef09637b2314
-https://bitbucket.org/cffi/cffi/commits/7a76a3815340
-
-diff -r 99940f1f5402 testing/cffi0/test_function.py
---- a/testing/cffi0/test_function.py	Tue Feb 27 21:18:33 2018 +0100
-+++ b/testing/cffi0/test_function.py	Sun Nov 11 16:26:23 2018 +0100
-@@ -45,14 +45,14 @@
-         assert x != math.sin(1.23)    # rounding effects
-         assert abs(x - math.sin(1.23)) < 1E-6
- 
--    def test_sin_no_return_value(self):
-+    def test_lround_no_return_value(self):
-         # check that 'void'-returning functions work too
-         ffi = FFI(backend=self.Backend())
-         ffi.cdef("""
--            void sin(double x);
-+            void lround(double x);
-         """)
-         m = ffi.dlopen(lib_m)
--        x = m.sin(1.23)
-+        x = m.lround(1.23)
-         assert x is None
- 
-     def test_dlopen_filename(self):