summary refs log tree commit diff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-11-19 00:04:32 +0100
committerMarius Bakke <marius@gnu.org>2020-11-19 00:04:32 +0100
commit35ed83beae51c05069ed6754dd26cf0f549808ab (patch)
treefe09aa72524081aa54c74e6d5f99f1a1c006c06b /gnu/packages/patches
parent38f4c54d7e212fd26e6899fad29c2e604abb32f5 (diff)
parent0305bc91762f9d5e01abd3d55e8dd9d3d1ecbdad (diff)
downloadguix-35ed83beae51c05069ed6754dd26cf0f549808ab.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/bitcoin-core-python-compat.patch28
-rw-r--r--gnu/packages/patches/gcc-6-fix-buffer-size.patch15
-rw-r--r--gnu/packages/patches/gcc-6-fix-isl-includes.patch16
-rw-r--r--gnu/packages/patches/glib-appinfo-watch.patch92
-rw-r--r--gnu/packages/patches/icecat-makeicecat.patch4
-rw-r--r--gnu/packages/patches/scribus-1.5.5-poppler-0.86-build-fix.patch642
-rw-r--r--gnu/packages/patches/tomb-fix-errors-on-open.patch25
7 files changed, 125 insertions, 697 deletions
diff --git a/gnu/packages/patches/bitcoin-core-python-compat.patch b/gnu/packages/patches/bitcoin-core-python-compat.patch
deleted file mode 100644
index 6bf744124d..0000000000
--- a/gnu/packages/patches/bitcoin-core-python-compat.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-Get rid of deprecation warning emitted by Python 3.8, which causes a test failure(!).
-
-https://github.com/bitcoin/bitcoin/pull/17931
-
-Taken from upstream:
-
-https://github.com/bitcoin/bitcoin/commit/f117fb00da747147cddfb071c1427a2754c278cd
-
-diff --git a/test/functional/p2p_invalid_messages.py b/test/functional/p2p_invalid_messages.py
-index 20864881c165..07eacf410d88 100755
---- a/test/functional/p2p_invalid_messages.py
-+++ b/test/functional/p2p_invalid_messages.py
-@@ -145,13 +145,13 @@ def run_test(self):
-     def test_magic_bytes(self):
-         conn = self.nodes[0].add_p2p_connection(P2PDataStore())
- 
--        def swap_magic_bytes():
-+        async def swap_magic_bytes():
-             conn._on_data = lambda: None  # Need to ignore all incoming messages from now, since they come with "invalid" magic bytes
-             conn.magic_bytes = b'\x00\x11\x22\x32'
- 
-         # Call .result() to block until the atomic swap is complete, otherwise
-         # we might run into races later on
--        asyncio.run_coroutine_threadsafe(asyncio.coroutine(swap_magic_bytes)(), NetworkThread.network_event_loop).result()
-+        asyncio.run_coroutine_threadsafe(swap_magic_bytes(), NetworkThread.network_event_loop).result()
- 
-         with self.nodes[0].assert_debug_log(['PROCESSMESSAGE: INVALID MESSAGESTART ping']):
-             conn.send_message(messages.msg_ping(nonce=0xff))
diff --git a/gnu/packages/patches/gcc-6-fix-buffer-size.patch b/gnu/packages/patches/gcc-6-fix-buffer-size.patch
new file mode 100644
index 0000000000..5fcd769d45
--- /dev/null
+++ b/gnu/packages/patches/gcc-6-fix-buffer-size.patch
@@ -0,0 +1,15 @@
+Fixes a possible buffer overflow.  (There are others)
+Author: Danny Milosavljevic <dannym@scratchpost.org>
+Date: 2020-11-16
+
+--- a/gcc/gimplify.c.orig	2020-10-29 08:45:11.532479774 +0100
++++ b/gcc/gimplify.c	2020-10-29 08:45:49.584637018 +0100
+@@ -5229,7 +5229,7 @@
+ 	     flexibility, split it into separate input and output
+  	     operands.  */
+ 	  tree input;
+-	  char buf[10];
++	  char buf[12];
+ 
+ 	  /* Turn the in/out constraint into an output constraint.  */
+ 	  char *p = xstrdup (constraint);
diff --git a/gnu/packages/patches/gcc-6-fix-isl-includes.patch b/gnu/packages/patches/gcc-6-fix-isl-includes.patch
new file mode 100644
index 0000000000..ab3c5634ea
--- /dev/null
+++ b/gnu/packages/patches/gcc-6-fix-isl-includes.patch
@@ -0,0 +1,16 @@
+See https://gcc.gnu.org/bugzilla/show_bug.cgi?id=86724
+Author: Rainer Jung
+Date: 2018-07-29
+
+isl 0.20 stopped including other unused header files in their header files.
+Therefore,now it's necessary to include the stuff ourselves.
+--- .../gcc/graphite.h 2018-01-03 11:03:58.000000000 +0000
++++ .../gcc/graphite.h 2018-07-29 17:42:55.836121000 +0000
+@@ -37,6 +37,8 @@
+ #include <isl/schedule.h>
+ #include <isl/ast_build.h>
+ #include <isl/schedule_node.h>
++#include <isl/id.h>
++#include <isl/space.h>
+
+ typedef struct poly_dr *poly_dr_p;
diff --git a/gnu/packages/patches/glib-appinfo-watch.patch b/gnu/packages/patches/glib-appinfo-watch.patch
new file mode 100644
index 0000000000..638a5e0949
--- /dev/null
+++ b/gnu/packages/patches/glib-appinfo-watch.patch
@@ -0,0 +1,92 @@
+This patch lets GLib's GDesktopAppInfo API watch and notice changes
+to the Guix user and system profiles.  That way, the list of available
+applications shown by the desktop environment is immediately updated
+when the user runs "guix install", "guix remove", or "guix system
+reconfigure" (see <https://issues.guix.gnu.org/35594>).
+
+It does so by monitoring /var/guix/profiles (for changes to the system
+profile) and /var/guix/profiles/per-user/USER (for changes to the user
+profile) and crawling their share/applications sub-directory when
+changes happen.
+
+diff --git a/gio/gdesktopappinfo.c b/gio/gdesktopappinfo.c
+index f1e2fdd..095c110 100644
+--- a/gio/gdesktopappinfo.c
++++ b/gio/gdesktopappinfo.c
+@@ -148,6 +148,7 @@ typedef struct
+   gchar                      *alternatively_watching;
+   gboolean                    is_config;
+   gboolean                    is_setup;
++  gchar                      *guix_profile_watch_dir;
+   GFileMonitor               *monitor;
+   GHashTable                 *app_names;
+   GHashTable                 *mime_tweaks;
+@@ -180,6 +181,7 @@ desktop_file_dir_unref (DesktopFileDir *dir)
+     {
+       desktop_file_dir_reset (dir);
+       g_free (dir->path);
++      g_free (dir->guix_profile_watch_dir);
+       g_free (dir);
+     }
+ }
+@@ -204,6 +206,13 @@ desktop_file_dir_get_alternative_dir (DesktopFileDir *dir)
+ {
+   gchar *parent;
+ 
++  /* If DIR is a profile, watch the specified directory--e.g.,
++   * /var/guix/profiles/per-user/$USER/ for the user profile.  Do not watch
++   * ~/.guix-profile or /run/current-system/profile because GFileMonitor does
++   * not pass IN_DONT_FOLLOW and thus cannot notice any change.  */
++  if (dir->guix_profile_watch_dir != NULL)
++    return g_strdup (dir->guix_profile_watch_dir);
++
+   /* If the directory itself exists then we need no alternative. */
+   if (g_access (dir->path, R_OK | X_OK) == 0)
+     return NULL;
+@@ -249,11 +258,11 @@ desktop_file_dir_changed (GFileMonitor      *monitor,
+    *
+    * If this is a notification for a parent directory (because the
+    * desktop directory didn't exist) then we shouldn't fire the signal
+-   * unless something actually changed.
++   * unless something actually changed or it's in /var/guix/profiles.
+    */
+   g_mutex_lock (&desktop_file_dir_lock);
+ 
+-  if (dir->alternatively_watching)
++  if (dir->alternatively_watching && dir->guix_profile_watch_dir == NULL)
+     {
+       gchar *alternative_dir;
+ 
+@@ -1555,6 +1564,32 @@ desktop_file_dirs_lock (void)
+       for (i = 0; dirs[i]; i++)
+         g_ptr_array_add (desktop_file_dirs, desktop_file_dir_new (dirs[i]));
+ 
++      {
++        /* Monitor the system and user profile under /var/guix/profiles and
++         * treat modifications to them as if they were modifications to their
++         * /share sub-directory.  */
++        const gchar *user;
++        DesktopFileDir *system_profile_dir, *user_profile_dir;
++
++        system_profile_dir =
++          desktop_file_dir_new ("/var/guix/profiles/system/profile/share");
++        system_profile_dir->guix_profile_watch_dir = g_strdup ("/var/guix/profiles");
++        g_ptr_array_add (desktop_file_dirs, desktop_file_dir_ref (system_profile_dir));
++
++        user = g_get_user_name ();
++        if (user != NULL)
++          {
++            gchar *profile_dir, *user_data_dir;
++
++            profile_dir = g_build_filename ("/var/guix/profiles/per-user", user, NULL);
++            user_data_dir = g_build_filename (profile_dir, "guix-profile", "share", NULL);
++            user_profile_dir = desktop_file_dir_new (user_data_dir);
++            user_profile_dir->guix_profile_watch_dir = profile_dir;
++            g_ptr_array_add (desktop_file_dirs, desktop_file_dir_ref (user_profile_dir));
++            g_free (user_data_dir);
++          }
++      }
++
+       /* The list of directories will never change after this, unless
+        * g_get_user_config_dir() changes due to %G_TEST_OPTION_ISOLATE_DIRS. */
+       desktop_file_dirs_config_dir = user_config_dir;
diff --git a/gnu/packages/patches/icecat-makeicecat.patch b/gnu/packages/patches/icecat-makeicecat.patch
index f82df9f68e..9a6e40df4b 100644
--- a/gnu/packages/patches/icecat-makeicecat.patch
+++ b/gnu/packages/patches/icecat-makeicecat.patch
@@ -25,7 +25,7 @@ index 8be2362..48716f2 100755
 -wget -N https://ftp.mozilla.org/pub/mozilla.org/firefox/releases/${FFVERSION}esr/source/firefox-${FFVERSION}esr.source.tar.xz.asc
 -gpg --recv-keys --keyserver keyserver.ubuntu.com 14F26682D0916CDD81E37B6D61B7B526D98F0353
 -gpg --verify firefox-${FFVERSION}esr.source.tar.xz.asc
--echo -n 1978eedd975b1cf95bd4a04b2381560d1ad9a4223032717f23fac26e3458a760 firefox-${FFVERSION}esr.source.tar.xz |sha256sum -c -
+-echo -n 51f54ff608aa09de07b304307581ae89112781597322b8999b3099cfabf48290 firefox-${FFVERSION}esr.source.tar.xz |sha256sum -c -
 -
 -echo Extracting Firefox tarball
 -tar -xf firefox-${FFVERSION}esr.source.tar.xz
@@ -37,7 +37,7 @@ index 8be2362..48716f2 100755
 +# wget -N https://ftp.mozilla.org/pub/mozilla.org/firefox/releases/${FFVERSION}esr/source/firefox-${FFVERSION}esr.source.tar.xz.asc
 +# gpg --recv-keys --keyserver keyserver.ubuntu.com 14F26682D0916CDD81E37B6D61B7B526D98F0353
 +# gpg --verify firefox-${FFVERSION}esr.source.tar.xz.asc
-+# echo -n 1978eedd975b1cf95bd4a04b2381560d1ad9a4223032717f23fac26e3458a760 firefox-${FFVERSION}esr.source.tar.xz |sha256sum -c -
++# echo -n 51f54ff608aa09de07b304307581ae89112781597322b8999b3099cfabf48290 firefox-${FFVERSION}esr.source.tar.xz |sha256sum -c -
 +# 
 +# echo Extracting Firefox tarball
 +# tar -xf firefox-${FFVERSION}esr.source.tar.xz
diff --git a/gnu/packages/patches/scribus-1.5.5-poppler-0.86-build-fix.patch b/gnu/packages/patches/scribus-1.5.5-poppler-0.86-build-fix.patch
deleted file mode 100644
index 39008cba5c..0000000000
--- a/gnu/packages/patches/scribus-1.5.5-poppler-0.86-build-fix.patch
+++ /dev/null
@@ -1,642 +0,0 @@
-Fix build with Poppler 0.86.
-
-The original series of patches authored by Craig Bradney <mrb@scribus.info>
-and Jean Ghali <jghali@libertysurf.fr>, taken from
-https://gitweb.gentoo.org/repo/gentoo.git/tree/app-office/scribus/files
-
-diff --git a/scribus/plugins/import/pdf/importpdf.cpp b/scribus/plugins/import/pdf/importpdf.cpp
---- a/scribus/plugins/import/pdf/importpdf.cpp
-+++ b/scribus/plugins/import/pdf/importpdf.cpp
-@@ -75,7 +75,11 @@ PdfPlug::PdfPlug(ScribusDoc* doc, int flags)
- QImage PdfPlug::readThumbnail(const QString& fName)

- {

- 	QString pdfFile = QDir::toNativeSeparators(fName);

-+#if POPPLER_ENCODED_VERSION >= POPPLER_VERSION_ENCODE(0, 83, 0)

-+	globalParams.reset(new GlobalParams());

-+#else

- 	globalParams = new GlobalParams();

-+#endif

- 	if (globalParams)

- 	{

- #if defined(Q_OS_WIN32) && POPPLER_ENCODED_VERSION >= POPPLER_VERSION_ENCODE(0, 62, 0)

-@@ -90,7 +94,9 @@ QImage PdfPlug::readThumbnail(const QString& fName)
- 			if (pdfDoc->getErrorCode() == errEncrypted)

- 			{

- 				delete pdfDoc;

-+#if POPPLER_ENCODED_VERSION < POPPLER_VERSION_ENCODE(0, 83, 0)

- 				delete globalParams;

-+#endif

- 				return QImage();

- 			}

- 			if (pdfDoc->isOk())

-@@ -134,11 +140,15 @@ QImage PdfPlug::readThumbnail(const QString& fName)
- 				image.setText("YSize", QString("%1").arg(h));

- 				delete dev;

- 				delete pdfDoc;

-+#if POPPLER_ENCODED_VERSION < POPPLER_VERSION_ENCODE(0, 83, 0)

- 				delete globalParams;

-+#endif

- 				return image;

- 			}

- 			delete pdfDoc;

-+#if POPPLER_ENCODED_VERSION < POPPLER_VERSION_ENCODE(0, 83, 0)

- 			delete globalParams;

-+#endif

- 		}

- 	}

- 	return QImage();

-@@ -387,7 +397,11 @@ bool PdfPlug::convert(const QString& fn)
- 		qApp->processEvents();

- 	}

- 

-+#if POPPLER_ENCODED_VERSION >= POPPLER_VERSION_ENCODE(0, 83, 0)

-+	globalParams.reset(new GlobalParams());

-+#else

- 	globalParams = new GlobalParams();

-+#endif

- 	GooString *userPW = nullptr;

- 	if (globalParams)

- 	{

-@@ -429,7 +443,9 @@ bool PdfPlug::convert(const QString& fn)
- 					if (progressDialog)

- 						progressDialog->close();

- 					delete pdfDoc;

-+#if POPPLER_ENCODED_VERSION < POPPLER_VERSION_ENCODE(0, 83, 0)

- 					delete globalParams;

-+#endif

- 					return false;

- 				}

- 				if (progressDialog)

-@@ -474,7 +490,9 @@ bool PdfPlug::convert(const QString& fn)
- 							progressDialog->close();

- 						delete optImp;

- 						delete pdfDoc;

-+#if POPPLER_ENCODED_VERSION < POPPLER_VERSION_ENCODE(0, 83, 0)

- 						delete globalParams;

-+#endif

- 						return false;

- 					}

- 					pageString = optImp->getPagesString();

-@@ -838,11 +856,20 @@ bool PdfPlug::convert(const QString& fn)
- 								names = catDict.dictLookup("OpenAction");

- 								if (names.isDict())

- 								{

-+#if POPPLER_ENCODED_VERSION >= POPPLER_VERSION_ENCODE(0, 86, 0)

-+									std::unique_ptr<LinkAction> linkAction;

-+									linkAction = LinkAction::parseAction(&names, pdfDoc->getCatalog()->getBaseURI());

-+#else

- 									LinkAction *linkAction = nullptr;

- 									linkAction = LinkAction::parseAction(&names, pdfDoc->getCatalog()->getBaseURI());

-+#endif

- 									if (linkAction)

- 									{

--										LinkJavaScript *jsa = (LinkJavaScript*)linkAction;

-+#if POPPLER_ENCODED_VERSION >= POPPLER_VERSION_ENCODE(0, 86, 0)

-+										LinkJavaScript *jsa = (LinkJavaScript*) linkAction.get();

-+#else

-+										LinkJavaScript *jsa = (LinkJavaScript*) linkAction;

-+#endif

- 										if (jsa->isOk())

- 										{

- 											QString script = UnicodeParsedString(jsa->getScript());

-@@ -908,8 +935,12 @@ bool PdfPlug::convert(const QString& fn)
- 		}

- 		delete pdfDoc;

- 	}

-+#if POPPLER_ENCODED_VERSION >= POPPLER_VERSION_ENCODE(0, 83, 0)

-+	globalParams.release();

-+#else

- 	delete globalParams;

- 	globalParams = nullptr;

-+#endif

- 

- //	qDebug() << "converting finished";

- //	qDebug() << "Imported" << Elements.count() << "Elements";

-@@ -1046,3 +1077,43 @@ QString PdfPlug::UnicodeParsedString(POPPLER_CONST GooString *s1)
- 	}

- 	return result;

- }

-+

-+QString PdfPlug::UnicodeParsedString(const std::string& s1)

-+{

-+	if (s1.length() == 0)

-+		return QString();

-+	GBool isUnicode;

-+	int i;

-+	Unicode u;

-+	QString result;

-+	if ((s1.at(0) & 0xff) == 0xfe && (s1.length() > 1 && (s1.at(1) & 0xff) == 0xff))

-+	{

-+		isUnicode = gTrue;

-+		i = 2;

-+		result.reserve((s1.length() - 2) / 2);

-+	}

-+	else

-+	{

-+		isUnicode = gFalse;

-+		i = 0;

-+		result.reserve(s1.length());

-+	}

-+	while (i < s1.length())

-+	{

-+		if (isUnicode)

-+		{

-+			u = ((s1.at(i) & 0xff) << 8) | (s1.at(i+1) & 0xff);

-+			i += 2;

-+		}

-+		else

-+		{

-+			u = s1.at(i) & 0xff;

-+			++i;

-+		}

-+		// #15616: imagemagick may write unicode strings incorrectly in PDF

-+		if (u == 0)

-+			continue;

-+		result += QChar( u );

-+	}

-+	return result;

-+}

-diff --git a/scribus/plugins/import/pdf/importpdf.h b/scribus/plugins/import/pdf/importpdf.h
---- a/scribus/plugins/import/pdf/importpdf.h
-+++ b/scribus/plugins/import/pdf/importpdf.h
-@@ -82,6 +82,7 @@ private:
- 	bool convert(const QString& fn);
- 	QRectF getCBox(int box, int pgNum);
- 	QString UnicodeParsedString(POPPLER_CONST GooString *s1);
-+	QString UnicodeParsedString(const std::string& s1);
- 	
- 	QList<PageItem*> Elements;
- 	double baseX, baseY;
-diff --git a/scribus/plugins/import/pdf/importpdfconfig.h b/scribus/plugins/import/pdf/importpdfconfig.h
---- a/scribus/plugins/import/pdf/importpdfconfig.h
-+++ b/scribus/plugins/import/pdf/importpdfconfig.h
-@@ -52,4 +52,16 @@ for which a new license (GPL+exception) is in place.
- #define POPPLER_REF

- #endif

- 

-+#if POPPLER_ENCODED_VERSION >= POPPLER_VERSION_ENCODE(0, 82, 0)

-+#define POPPLER_CONST_082 const

-+#else

-+#define POPPLER_CONST_082

-+#endif

-+

-+#if POPPLER_ENCODED_VERSION >= POPPLER_VERSION_ENCODE(0, 83, 0)

-+#define POPPLER_CONST_083 const

-+#else

-+#define POPPLER_CONST_083

-+#endif

-+

- #endif

-diff --git a/scribus/plugins/import/pdf/slaoutput.cpp b/scribus/plugins/import/pdf/slaoutput.cpp
---- a/scribus/plugins/import/pdf/slaoutput.cpp
-+++ b/scribus/plugins/import/pdf/slaoutput.cpp
-@@ -308,9 +308,15 @@ LinkAction* SlaOutputDev::SC_getAction(AnnotWidget *ano)
- }

- 

- /* Replacement for the crippled Poppler function LinkAction* AnnotWidget::getAdditionalAction(AdditionalActionsType type) */

-+#if POPPLER_ENCODED_VERSION >= POPPLER_VERSION_ENCODE(0, 86, 0)

-+std::unique_ptr<LinkAction> SlaOutputDev::SC_getAdditionalAction(const char *key, AnnotWidget *ano)

-+{

-+	std::unique_ptr<LinkAction> linkAction;

-+#else

- LinkAction* SlaOutputDev::SC_getAdditionalAction(const char *key, AnnotWidget *ano)

- {

- 	LinkAction *linkAction = nullptr;

-+#endif

- 	Object obj;

- 	Ref refa = ano->getRef();

- 

-@@ -455,7 +461,11 @@ bool SlaOutputDev::handleLinkAnnot(Annot* annota, double xCoor, double yCoor, do
- 			POPPLER_CONST GooString *ndst = gto->getNamedDest();

- 			if (ndst)

- 			{

-+#if POPPLER_ENCODED_VERSION >= POPPLER_VERSION_ENCODE(0, 86, 0)

-+				std::unique_ptr<LinkDest> dstn = pdfDoc->findDest(ndst);

-+#else

- 				LinkDest *dstn = pdfDoc->findDest(ndst);

-+#endif

- 				if (dstn)

- 				{

- 					if (dstn->getKind() == destXYZ)

-@@ -499,7 +509,11 @@ bool SlaOutputDev::handleLinkAnnot(Annot* annota, double xCoor, double yCoor, do
- 			POPPLER_CONST GooString *ndst = gto->getNamedDest();

- 			if (ndst)

- 			{

-+#if POPPLER_ENCODED_VERSION >= POPPLER_VERSION_ENCODE(0, 86, 0)

-+				std::unique_ptr<LinkDest> dstn = pdfDoc->findDest(ndst);

-+#else

- 				LinkDest *dstn = pdfDoc->findDest(ndst);

-+#endif

- 				if (dstn)

- 				{

- 					if (dstn->getKind() == destXYZ)

-@@ -967,7 +981,11 @@ void SlaOutputDev::handleActions(PageItem* ite, AnnotWidget *ano)
- 				POPPLER_CONST GooString *ndst = gto->getNamedDest();

- 				if (ndst)

- 				{

-+#if POPPLER_ENCODED_VERSION >= POPPLER_VERSION_ENCODE(0, 86, 0)

-+					std::unique_ptr<LinkDest> dstn = pdfDoc->findDest(ndst);

-+#else

- 					LinkDest *dstn = pdfDoc->findDest(ndst);

-+#endif

- 					if (dstn)

- 					{

- 						if (dstn->getKind() == destXYZ)

-@@ -1019,7 +1037,11 @@ void SlaOutputDev::handleActions(PageItem* ite, AnnotWidget *ano)
- 				POPPLER_CONST GooString *ndst = gto->getNamedDest();

- 				if (ndst)

- 				{

-+#if POPPLER_ENCODED_VERSION >= POPPLER_VERSION_ENCODE(0, 86, 0)

-+					std::unique_ptr<LinkDest> dstn = pdfDoc->findDest(ndst);

-+#else

- 					LinkDest *dstn = pdfDoc->findDest(ndst);

-+#endif

- 					if (dstn)

- 					{

- 						if (dstn->getKind() == destXYZ)

-@@ -1088,96 +1110,148 @@ void SlaOutputDev::handleActions(PageItem* ite, AnnotWidget *ano)
- 		else

- 			qDebug() << "Found unsupported Action of type" << Lact->getKind();

- 	}

--	LinkAction *Aact = SC_getAdditionalAction("D", ano);

-+	auto Aact = SC_getAdditionalAction("D", ano);

- 	if (Aact)

- 	{

- 		if (Aact->getKind() == actionJavaScript)

- 		{

--			LinkJavaScript *jsa = (LinkJavaScript*)Aact;

-+#if POPPLER_ENCODED_VERSION >= POPPLER_VERSION_ENCODE(0, 86, 0)

-+			LinkJavaScript *jsa = (LinkJavaScript*) Aact.get();

-+#else

-+			LinkJavaScript *jsa = (LinkJavaScript*) Aact;

-+#endif

- 			if (jsa->isOk())

- 			{

- 				ite->annotation().setD_act(UnicodeParsedString(jsa->getScript()));

- 				ite->annotation().setAAact(true);

- 			}

- 		}

-+#if POPPLER_ENCODED_VERSION >= POPPLER_VERSION_ENCODE(0, 86, 0)

-+		Aact.reset();

-+#else

- 		Aact = nullptr;

-+#endif

- 	}

- 	Aact = SC_getAdditionalAction("E", ano);

- 	if (Aact)

- 	{

- 		if (Aact->getKind() == actionJavaScript)

- 		{

--			LinkJavaScript *jsa = (LinkJavaScript*)Aact;

-+#if POPPLER_ENCODED_VERSION >= POPPLER_VERSION_ENCODE(0, 86, 0)

-+			LinkJavaScript *jsa = (LinkJavaScript*) Aact.get();

-+#else

-+			LinkJavaScript *jsa = (LinkJavaScript*) Aact;

-+#endif

- 			if (jsa->isOk())

- 			{

- 				ite->annotation().setE_act(UnicodeParsedString(jsa->getScript()));

- 				ite->annotation().setAAact(true);

- 			}

- 		}

-+#if POPPLER_ENCODED_VERSION >= POPPLER_VERSION_ENCODE(0, 86, 0)

-+		Aact.reset();

-+#else

- 		Aact = nullptr;

-+#endif

- 	}

- 	Aact = SC_getAdditionalAction("X", ano);

- 	if (Aact)

- 	{

- 		if (Aact->getKind() == actionJavaScript)

- 		{

--			LinkJavaScript *jsa = (LinkJavaScript*)Aact;

-+#if POPPLER_ENCODED_VERSION >= POPPLER_VERSION_ENCODE(0, 86, 0)

-+			LinkJavaScript *jsa = (LinkJavaScript*) Aact.get();

-+#else

-+			LinkJavaScript *jsa = (LinkJavaScript*) Aact;

-+#endif

- 			if (jsa->isOk())

- 			{

- 				ite->annotation().setX_act(UnicodeParsedString(jsa->getScript()));

- 				ite->annotation().setAAact(true);

- 			}

- 		}

-+#if POPPLER_ENCODED_VERSION >= POPPLER_VERSION_ENCODE(0, 86, 0)

-+		Aact.reset();

-+#else

- 		Aact = nullptr;

-+#endif

- 	}

- 	Aact = SC_getAdditionalAction("Fo", ano);

- 	if (Aact)

- 	{

- 		if (Aact->getKind() == actionJavaScript)

- 		{

--			LinkJavaScript *jsa = (LinkJavaScript*)Aact;

-+#if POPPLER_ENCODED_VERSION >= POPPLER_VERSION_ENCODE(0, 86, 0)

-+			LinkJavaScript *jsa = (LinkJavaScript*) Aact.get();

-+#else

-+			LinkJavaScript *jsa = (LinkJavaScript*) Aact;

-+#endif

- 			if (jsa->isOk())

- 			{

- 				ite->annotation().setFo_act(UnicodeParsedString(jsa->getScript()));

- 				ite->annotation().setAAact(true);

- 			}

- 		}

-+#if POPPLER_ENCODED_VERSION >= POPPLER_VERSION_ENCODE(0, 86, 0)

-+		Aact.reset();

-+#else

- 		Aact = nullptr;

-+#endif

- 	}

- 	Aact = SC_getAdditionalAction("Bl", ano);

- 	if (Aact)

- 	{

- 		if (Aact->getKind() == actionJavaScript)

- 		{

--			LinkJavaScript *jsa = (LinkJavaScript*)Aact;

-+#if POPPLER_ENCODED_VERSION >= POPPLER_VERSION_ENCODE(0, 86, 0)

-+			LinkJavaScript *jsa = (LinkJavaScript*) Aact.get();

-+#else

-+			LinkJavaScript *jsa = (LinkJavaScript*) Aact;

-+#endif

- 			if (jsa->isOk())

- 			{

- 				ite->annotation().setBl_act(UnicodeParsedString(jsa->getScript()));

- 				ite->annotation().setAAact(true);

- 			}

- 		}

-+#if POPPLER_ENCODED_VERSION >= POPPLER_VERSION_ENCODE(0, 86, 0)

-+		Aact.reset();

-+#else

- 		Aact = nullptr;

-+#endif

- 	}

- 	Aact = SC_getAdditionalAction("C", ano);

- 	if (Aact)

- 	{

- 		if (Aact->getKind() == actionJavaScript)

- 		{

--			LinkJavaScript *jsa = (LinkJavaScript*)Aact;

-+#if POPPLER_ENCODED_VERSION >= POPPLER_VERSION_ENCODE(0, 86, 0)

-+			LinkJavaScript *jsa = (LinkJavaScript*) Aact.get();

-+#else

-+			LinkJavaScript *jsa = (LinkJavaScript*) Aact;

-+#endif

- 			if (jsa->isOk())

- 			{

- 				ite->annotation().setC_act(UnicodeParsedString(jsa->getScript()));

- 				ite->annotation().setAAact(true);

- 			}

- 		}

-+#if POPPLER_ENCODED_VERSION >= POPPLER_VERSION_ENCODE(0, 86, 0)

-+		Aact.reset();

-+#else

- 		Aact = nullptr;

-+#endif

- 	}

- 	Aact = SC_getAdditionalAction("F", ano);

- 	if (Aact)

- 	{

- 		if (Aact->getKind() == actionJavaScript)

- 		{

--			LinkJavaScript *jsa = (LinkJavaScript*)Aact;

-+#if POPPLER_ENCODED_VERSION >= POPPLER_VERSION_ENCODE(0, 86, 0)

-+			LinkJavaScript *jsa = (LinkJavaScript*) Aact.get();

-+#else

-+			LinkJavaScript *jsa = (LinkJavaScript*) Aact;

-+#endif

- 			if (jsa->isOk())

- 			{

- 				ite->annotation().setF_act(UnicodeParsedString(jsa->getScript()));

-@@ -1185,14 +1259,22 @@ void SlaOutputDev::handleActions(PageItem* ite, AnnotWidget *ano)
- 				ite->annotation().setFormat(5);

- 			}

- 		}

-+#if POPPLER_ENCODED_VERSION >= POPPLER_VERSION_ENCODE(0, 86, 0)

-+		Aact.reset();

-+#else

- 		Aact = nullptr;

-+#endif

- 	}

- 	Aact = SC_getAdditionalAction("K", ano);

- 	if (Aact)

- 	{

- 		if (Aact->getKind() == actionJavaScript)

- 		{

--			LinkJavaScript *jsa = (LinkJavaScript*)Aact;

-+#if POPPLER_ENCODED_VERSION >= POPPLER_VERSION_ENCODE(0, 86, 0)

-+			LinkJavaScript *jsa = (LinkJavaScript*) Aact.get();

-+#else

-+			LinkJavaScript *jsa = (LinkJavaScript*) Aact;

-+#endif

- 			if (jsa->isOk())

- 			{

- 				ite->annotation().setK_act(UnicodeParsedString(jsa->getScript()));

-@@ -1200,21 +1282,33 @@ void SlaOutputDev::handleActions(PageItem* ite, AnnotWidget *ano)
- 				ite->annotation().setFormat(5);

- 			}

- 		}

-+#if POPPLER_ENCODED_VERSION >= POPPLER_VERSION_ENCODE(0, 86, 0)

-+		Aact.reset();

-+#else

- 		Aact = nullptr;

-+#endif

- 	}

- 	Aact = SC_getAdditionalAction("V", ano);

- 	if (Aact)

- 	{

- 		if (Aact->getKind() == actionJavaScript)

- 		{

--			LinkJavaScript *jsa = (LinkJavaScript*)Aact;

-+#if POPPLER_ENCODED_VERSION >= POPPLER_VERSION_ENCODE(0, 86, 0)

-+			LinkJavaScript *jsa = (LinkJavaScript*) Aact.get();

-+#else

-+			LinkJavaScript *jsa = (LinkJavaScript*) Aact;

-+#endif

- 			if (jsa->isOk())

- 			{

- 				ite->annotation().setV_act(UnicodeParsedString(jsa->getScript()));

- 				ite->annotation().setAAact(true);

- 			}

- 		}

-+#if POPPLER_ENCODED_VERSION >= POPPLER_VERSION_ENCODE(0, 86, 0)

-+		Aact.reset();

-+#else

- 		Aact = nullptr;

-+#endif

- 	}

- }

- 

-@@ -1224,6 +1318,11 @@ void SlaOutputDev::startDoc(PDFDoc *doc, XRef *xrefA, Catalog *catA)
- 	catalog = catA;

- 	pdfDoc = doc;

- 	updateGUICounter = 0;

-+#if POPPLER_ENCODED_VERSION >= POPPLER_VERSION_ENCODE(0, 84, 0)

-+	m_fontEngine = new SplashFontEngine(true, true, true, true);

-+#elif POPPLER_ENCODED_VERSION >= POPPLER_VERSION_ENCODE(0, 61, 0)

-+	m_fontEngine = new SplashFontEngine(globalParams->getEnableFreeType(), true, true, true);

-+#else

- 	m_fontEngine = new SplashFontEngine(

- #if HAVE_T1LIB_H

- 	globalParams->getEnableT1lib(),

-@@ -1234,6 +1333,7 @@ void SlaOutputDev::startDoc(PDFDoc *doc, XRef *xrefA, Catalog *catA)
- 	true,

- #endif

- 	true);

-+#endif

- }

- 

- void SlaOutputDev::startPage(int pageNum, GfxState *, XRef *)

-@@ -2784,7 +2884,7 @@ void SlaOutputDev::drawMaskedImage(GfxState *state, Object *ref, Stream *str,  i
- 	delete[] mbuffer;

- }

- 

--void SlaOutputDev::drawImage(GfxState *state, Object *ref, Stream *str, int width, int height, GfxImageColorMap *colorMap, GBool interpolate, int *maskColors, GBool inlineImg)

-+void SlaOutputDev::drawImage(GfxState *state, Object *ref, Stream *str, int width, int height, GfxImageColorMap *colorMap, GBool interpolate, POPPLER_CONST_082 int* maskColors, GBool inlineImg)

- {

- 	ImageStream * imgStr = new ImageStream(str, width, colorMap->getNumPixelComps(), colorMap->getBits());

- //	qDebug() << "Image Components" << colorMap->getNumPixelComps() << "Mask" << maskColors;

-@@ -3365,7 +3465,7 @@ err1:
- 		fontsrc->unref();

- }

- 

--void SlaOutputDev::drawChar(GfxState *state, double x, double y, double dx, double dy, double originX, double originY, CharCode code, int nBytes, Unicode *u, int uLen)

-+void SlaOutputDev::drawChar(GfxState *state, double x, double y, double dx, double dy, double originX, double originY, CharCode code, int nBytes, POPPLER_CONST_082 Unicode *u, int uLen)

- {

- 	double x1, y1, x2, y2;

- 	int render;

-@@ -3452,7 +3552,7 @@ void SlaOutputDev::drawChar(GfxState *state, double x, double y, double dx, doub
- 	}

- }

- 

--GBool SlaOutputDev::beginType3Char(GfxState *state, double x, double y, double dx, double dy, CharCode code, Unicode *u, int uLen)

-+GBool SlaOutputDev::beginType3Char(GfxState *state, double x, double y, double dx, double dy, CharCode code, POPPLER_CONST_082 Unicode *u, int uLen)

- {

- //	qDebug() << "beginType3Char";

- 	GfxFont *gfxFont;

-@@ -3705,7 +3805,7 @@ QString SlaOutputDev::getAnnotationColor(const AnnotColor *color)
- 	return fNam;

- }

- 

--QString SlaOutputDev::convertPath(GfxPath *path)

-+QString SlaOutputDev::convertPath(POPPLER_CONST_083 GfxPath *path)

- {

- 	if (! path)

- 		return QString();

-@@ -3715,7 +3815,7 @@ QString SlaOutputDev::convertPath(GfxPath *path)
- 

- 	for (int i = 0; i < path->getNumSubpaths(); ++i)

- 	{

--		GfxSubpath * subpath = path->getSubpath(i);

-+		POPPLER_CONST_083 GfxSubpath * subpath = path->getSubpath(i);

- 		if (subpath->getNumPoints() > 0)

- 		{

- 			output += QString("M %1 %2").arg(subpath->getX(0)).arg(subpath->getY(0));

-@@ -3922,6 +4022,46 @@ QString SlaOutputDev::UnicodeParsedString(POPPLER_CONST GooString *s1)
- 	return result;

- }

- 

-+QString SlaOutputDev::UnicodeParsedString(const std::string& s1)

-+{

-+	if (s1.length() == 0)

-+		return QString();

-+	GBool isUnicode;

-+	int i;

-+	Unicode u;

-+	QString result;

-+	if ((s1.at(0) & 0xff) == 0xfe && (s1.length() > 1 && (s1.at(1) & 0xff) == 0xff))

-+	{

-+		isUnicode = gTrue;

-+		i = 2;

-+		result.reserve((s1.length() - 2) / 2);

-+	}

-+	else

-+	{

-+		isUnicode = gFalse;

-+		i = 0;

-+		result.reserve(s1.length());

-+	}

-+	while (i < s1.length())

-+	{

-+		if (isUnicode)

-+		{

-+			u = ((s1.at(i) & 0xff) << 8) | (s1.at(i+1) & 0xff);

-+			i += 2;

-+		}

-+		else

-+		{

-+			u = s1.at(i) & 0xff;

-+			++i;

-+		}

-+		// #15616: imagemagick may write unicode strings incorrectly in PDF

-+		if (u == 0)

-+			continue;

-+		result += QChar( u );

-+	}

-+	return result;

-+}

-+

- bool SlaOutputDev::checkClip()

- {

- 	bool ret = false;

-diff --git a/scribus/plugins/import/pdf/slaoutput.h b/scribus/plugins/import/pdf/slaoutput.h
---- a/scribus/plugins/import/pdf/slaoutput.h
-+++ b/scribus/plugins/import/pdf/slaoutput.h
-@@ -20,6 +20,8 @@ for which a new license (GPL+exception) is in place.
- #include <QTextStream>

- #include <QTransform>

- 

-+#include <memory>

-+

- #include "fpointarray.h"

- #include "importpdfconfig.h"

- #include "pageitem.h"

-@@ -159,7 +161,11 @@ public:
- 	virtual ~SlaOutputDev();

- 

- 	LinkAction* SC_getAction(AnnotWidget *ano);

-+#if POPPLER_ENCODED_VERSION >= POPPLER_VERSION_ENCODE(0, 86, 0)

-+	std::unique_ptr<LinkAction> SC_getAdditionalAction(const char *key, AnnotWidget *ano);

-+#else

- 	LinkAction* SC_getAdditionalAction(const char *key, AnnotWidget *ano);

-+#endif

- 	static GBool annotations_callback(Annot *annota, void *user_data);

- 	bool handleTextAnnot(Annot* annota, double xCoor, double yCoor, double width, double height);

- 	bool handleLinkAnnot(Annot* annota, double xCoor, double yCoor, double width, double height);

-@@ -229,7 +235,7 @@ public:
- 

- 	//----- image drawing

- 	void drawImageMask(GfxState *state, Object *ref, Stream *str, int width, int height, GBool invert, GBool interpolate, GBool inlineImg) override;

--	void drawImage(GfxState *state, Object *ref, Stream *str, int width, int height, GfxImageColorMap *colorMap, GBool interpolate, int *maskColors, GBool inlineImg) override;

-+	void drawImage(GfxState *state, Object *ref, Stream *str, int width, int height, GfxImageColorMap *colorMap, GBool interpolate, POPPLER_CONST_082 int *maskColors, GBool inlineImg) override;

- 	void drawSoftMaskedImage(GfxState *state, Object *ref, Stream *str,

- 				   int width, int height,

- 				   GfxImageColorMap *colorMap,

-@@ -261,8 +267,8 @@ public:
- 	//----- text drawing

- 	void  beginTextObject(GfxState *state) override;

- 	void  endTextObject(GfxState *state) override;

--	void  drawChar(GfxState *state, double /*x*/, double /*y*/, double /*dx*/, double /*dy*/, double /*originX*/, double /*originY*/, CharCode /*code*/, int /*nBytes*/, Unicode * /*u*/, int /*uLen*/) override;

--	GBool beginType3Char(GfxState * /*state*/, double /*x*/, double /*y*/, double /*dx*/, double /*dy*/, CharCode /*code*/, Unicode * /*u*/, int /*uLen*/) override;

-+	void  drawChar(GfxState *state, double /*x*/, double /*y*/, double /*dx*/, double /*dy*/, double /*originX*/, double /*originY*/, CharCode /*code*/, int /*nBytes*/, POPPLER_CONST_082 Unicode * /*u*/, int /*uLen*/) override;

-+	GBool beginType3Char(GfxState * /*state*/, double /*x*/, double /*y*/, double /*dx*/, double /*dy*/, CharCode /*code*/, POPPLER_CONST_082 Unicode * /*u*/, int /*uLen*/) override;

- 	void  endType3Char(GfxState * /*state*/) override;

- 	void  type3D0(GfxState * /*state*/, double /*wx*/, double /*wy*/) override;

- 	void  type3D1(GfxState * /*state*/, double /*wx*/, double /*wy*/, double /*llx*/, double /*lly*/, double /*urx*/, double /*ury*/) override;

-@@ -282,11 +288,12 @@ private:
- 	void getPenState(GfxState *state);

- 	QString getColor(GfxColorSpace *color_space, POPPLER_CONST_070 GfxColor *color, int *shade);

- 	QString getAnnotationColor(const AnnotColor *color);

--	QString convertPath(GfxPath *path);

-+	QString convertPath(POPPLER_CONST_083 GfxPath *path);

- 	int getBlendMode(GfxState *state);

- 	void applyMask(PageItem *ite);

- 	void pushGroup(const QString& maskName = "", GBool forSoftMask = gFalse, GBool alpha = gFalse, bool inverted = false);

- 	QString UnicodeParsedString(POPPLER_CONST GooString *s1);

-+	QString UnicodeParsedString(const std::string& s1);

- 	bool checkClip();

- 	bool pathIsClosed;

- 	QString CurrColorFill;

diff --git a/gnu/packages/patches/tomb-fix-errors-on-open.patch b/gnu/packages/patches/tomb-fix-errors-on-open.patch
deleted file mode 100644
index 5f41c9ee8f..0000000000
--- a/gnu/packages/patches/tomb-fix-errors-on-open.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-Description: Avoid error messages when opening a new tomb
- Make sure control file exists and has user ownership before user writes to it.
-Author: Sven Geuer <debmaint@g-e-u-e-r.de>
-Bug: https://github.com/dyne/Tomb/issues/369
-Last-Update: 2019-11-04
---- a/tomb
-+++ b/tomb
-@@ -2197,14 +2197,15 @@
- # {{{ Open
- 
- _update_control_file() {
--	# replaces a control file with new contents and gives it user ownership
-+	# make sure a control file exists, gives it user ownership
-+	# and replaces it with new contents
- 	# stdin = contents
- 	# $1 = path to control file
- 	# $2 = contents
- 	[[ "$2" = "" ]] && return 1
- 	_sudo touch "$1"
--	print "$2" > "$1"
- 	_sudo chown ${_UID}:${_GID} "$1"
-+	print "$2" > "$1"
- 	_verbose "updated control file $1 = $2"
- }
-