summary refs log tree commit diff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2016-06-03 15:55:36 +1000
committerBen Woodcroft <donttrustben@gmail.com>2016-06-08 21:36:02 +1000
commitdae620b8fe83bada3e83579c1a02e2bac45adfef (patch)
treeda5e785ee77ebf6969eaeee244422d60bf935d27 /gnu/packages/patches
parent3cc78097457413e503e7ba004a01edc4847ae927 (diff)
downloadguix-dae620b8fe83bada3e83579c1a02e2bac45adfef.tar.gz
gnu: Add ruby-concurrent.
* gnu/packages/ruby.scm (ruby-concurrent): New variable.
* gnu/packages/patches/ruby-concurrent-ignore-broken-test.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/ruby-concurrent-ignore-broken-test.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/patches/ruby-concurrent-ignore-broken-test.patch b/gnu/packages/patches/ruby-concurrent-ignore-broken-test.patch
new file mode 100644
index 0000000000..4e801c3225
--- /dev/null
+++ b/gnu/packages/patches/ruby-concurrent-ignore-broken-test.patch
@@ -0,0 +1,16 @@
+This test appears to fail in GNU Guix and elsewhere.  It has been reported
+upstream at https://github.com/puma/puma/issues/995
+
+diff --git a/spec/concurrent/channel_spec.rb b/spec/concurrent/channel_spec.rb
+index d70fba8..4f29a8b 100644
+--- a/spec/concurrent/channel_spec.rb
++++ b/spec/concurrent/channel_spec.rb
+@@ -598,7 +598,7 @@ module Concurrent
+           }.to raise_error(ArgumentError)
+         end
+ 
+-        it 'loops until the block returns false' do
++        xit 'loops until the block returns false' do
+           actual = 0
+           expected = 3
+           latch = Concurrent::CountDownLatch.new(expected)