summary refs log tree commit diff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-05 02:30:14 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-13 02:04:34 -0400
commit3c2a70604706363668d9a4b04fbfe5105ae70381 (patch)
tree7db00761bd74f9264ec1900bff351e98fee93ab4 /gnu/packages/patches
parent0e5d6934e5bec5397b57161c368e90850ecc2101 (diff)
downloadguix-3c2a70604706363668d9a4b04fbfe5105ae70381.tar.gz
gnu: eog: Update to 42.2.
* gnu/packages/gnome.scm (eog): Update to 42.2.
[source]: Delete patches.
[configure-flags]: Use gexps.
[phases]: Likewise.
{skip-gtk-update-icon-cache}: New phase.
{wrap-eog}: Use search-input-file.
[native-inputs]: Replace intltool with gettext-minimal.
[inputs]: Add libhandy and gtk.
* gnu/packages/patches/eog-update-libportal-usage.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): De-register it.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/eog-update-libportal-usage.patch40
1 files changed, 0 insertions, 40 deletions
diff --git a/gnu/packages/patches/eog-update-libportal-usage.patch b/gnu/packages/patches/eog-update-libportal-usage.patch
deleted file mode 100644
index 220a16ddc4..0000000000
--- a/gnu/packages/patches/eog-update-libportal-usage.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-Fix eog to work with libportal-0.5
-
-This patch is extracted from upstream, see here
-https://gitlab.gnome.org/GNOME/eog/-/commit/a06e6325907e136678b0bbe7058c25d688034afd
-
-diff --git a/meson.build b/meson.build
-index 9a32e4bb..9d49aa45 100644
---- a/meson.build
-+++ b/meson.build
-@@ -165,10 +165,14 @@ config_h.set('HAVE_EXEMPI', enable_xmp)
- # xdg-desktop-portal support with libportal (optional)
- enable_libportal = get_option('libportal')
- if enable_libportal
--  libportal_dep = dependency('libportal', version: '>= 0.3', required: false)
-+  libportal_dep = dependency('libportal', version: '>= 0.5', required: false)
-   assert(libportal_dep.found() and cc.has_header('libportal/portal.h', dependencies: libportal_dep),
-          'xdg-desktop-portal support requested but library not found. Please use -Dlibportal=false')
- 
--  common_deps += libportal_dep
-+  libportal_gtk3_dep = dependency('libportal-gtk3', version: '>= 0.5', required: false)
-+  assert(libportal_gtk3_dep.found() and cc.has_header('libportal-gtk3/portal-gtk3.h', dependencies: libportal_gtk3_dep),
-+         'xdg-desktop-portal support requested but library not found. Please use -Dlibportal=false')
-+
-+  common_deps += [libportal_dep, libportal_gtk3_dep]
- endif
- config_h.set('HAVE_LIBPORTAL', enable_libportal)
-
-diff --git a/src/eog-util.c b/src/eog-util.c
-index 90b9768e..56d23472 100644
---- a/src/eog-util.c
-+++ b/src/eog-util.c
-@@ -45,7 +45,7 @@
- #include <glib/gi18n.h>
- #ifdef HAVE_LIBPORTAL
- #include <libportal/portal.h>
--#include <libportal/portal-gtk3.h>
-+#include <libportal-gtk3/portal-gtk3.h>
- #endif
- 
- void