summary refs log tree commit diff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2016-11-06 03:29:06 -0500
committerMark H Weaver <mhw@netris.org>2016-11-06 03:29:06 -0500
commit8b6ad165d1fa479e5da2938d099dba356186e07c (patch)
treec30c024fd79497031c21c68d6c5688334d900467 /gnu/packages/patches
parent9422c98a0a2bf2c48d8e10e59d838ab23870eb10 (diff)
parent7f4658983a742072be4e28b227d6349461e9a68b (diff)
downloadguix-8b6ad165d1fa479e5da2938d099dba356186e07c.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/libjxr-fix-function-signature.patch16
-rw-r--r--gnu/packages/patches/libjxr-fix-typos.patch29
-rw-r--r--gnu/packages/patches/python-ipython-inputhook-ctype.patch41
-rw-r--r--gnu/packages/patches/w3m-disable-sslv2-and-sslv3.patch24
-rw-r--r--gnu/packages/patches/w3m-disable-weak-ciphers.patch24
-rw-r--r--gnu/packages/patches/w3m-force-ssl_verify_server-on.patch24
-rw-r--r--gnu/packages/patches/w3m-libgc.patch28
-rw-r--r--gnu/packages/patches/weex-vacopy.patch13
8 files changed, 45 insertions, 154 deletions
diff --git a/gnu/packages/patches/libjxr-fix-function-signature.patch b/gnu/packages/patches/libjxr-fix-function-signature.patch
new file mode 100644
index 0000000000..32f5f64512
--- /dev/null
+++ b/gnu/packages/patches/libjxr-fix-function-signature.patch
@@ -0,0 +1,16 @@
+Description: Fix function signature

+Author: Mathieu Malaterre <malat@debian.org>

+Origin: upstream, https://jxrlib.codeplex.com/SourceControl/changeset/04cf339385b8196f98025b43a366a0790deac994

+Bug-Debian: http://bugs.debian.org/748590

+

+--- jxrlib-1.1.orig/image/decode/JXRTranscode.c

++++ jxrlib-1.1/image/decode/JXRTranscode.c

+@@ -47,7 +47,7 @@ EXTERN_C Void FreeCodingContextDec(CWMIm

+ EXTERN_C Int StrEncInit(CWMImageStrCodec *);

+ EXTERN_C Void StrIOEncTerm(CWMImageStrCodec *);

+ EXTERN_C Void FreeCodingContextEnc(CWMImageStrCodec *);

+-EXTERN_C Void encodeMB(CWMImageStrCodec *, Int, Int);

++EXTERN_C Int encodeMB(CWMImageStrCodec *, Int, Int);

+ EXTERN_C Int  writeIndexTableNull(CWMImageStrCodec *);

+ EXTERN_C Void writePacketHeader(BitIOInfo *, U8, U8);

+ 

diff --git a/gnu/packages/patches/libjxr-fix-typos.patch b/gnu/packages/patches/libjxr-fix-typos.patch
new file mode 100644
index 0000000000..819db34900
--- /dev/null
+++ b/gnu/packages/patches/libjxr-fix-typos.patch
@@ -0,0 +1,29 @@
+Description: Fix typos and remove some warnings

+Author: Mathieu Malaterre <malat@debian.org>

+

+Index: jxrlib-1.1/jxrencoderdecoder/JxrEncApp.c

+===================================================================

+--- jxrlib-1.1.orig/jxrencoderdecoder/JxrEncApp.c

++++ jxrlib-1.1/jxrencoderdecoder/JxrEncApp.c

+@@ -578,7 +578,7 @@ main(int argc, char* argv[])

+ 

+     //================================

+     Call(PKCreateCodecFactory(&pCodecFactory, WMP_SDK_VERSION));

+-    Call(pCodecFactory->CreateCodec(&IID_PKImageWmpEncode, &pEncoder));

++    Call(pCodecFactory->CreateCodec(&IID_PKImageWmpEncode, (void**)&pEncoder));

+ 

+     //----------------------------------------------------------------

+     Call(PKCreateTestFactory(&pTestFactory, WMP_SDK_VERSION));

+Index: jxrlib-1.1/jxrgluelib/JXRMeta.h

+===================================================================

+--- jxrlib-1.1.orig/jxrgluelib/JXRMeta.h

++++ jxrlib-1.1/jxrgluelib/JXRMeta.h

+@@ -34,7 +34,7 @@

+ 

+ #ifndef UNREFERENCED_PARAMETER

+ #define UNREFERENCED_PARAMETER(P) { (P) = (P); }

+-#endif UNREFERENCED_PARAMETER

++#endif /*UNREFERENCED_PARAMETER*/

+ 

+ //================================================================

+ // Container

diff --git a/gnu/packages/patches/python-ipython-inputhook-ctype.patch b/gnu/packages/patches/python-ipython-inputhook-ctype.patch
deleted file mode 100644
index c77e310542..0000000000
--- a/gnu/packages/patches/python-ipython-inputhook-ctype.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-From 04c5d358c7ab74d3ddab4f7662e539393d8604c6 Mon Sep 17 00:00:00 2001
-From: Lucretiel <Lucretiel@users.noreply.github.com>
-Date: Wed, 13 May 2015 13:12:43 -0400
-Subject: [PATCH] register now checks for missing ctypes
-
-If ctypes is None, then no input hooks may be registered; `InputHookManager.register` skips registration of input hook classes. Also updated `__init__` to no longer skip creating the instance attributes, to prevent AttributeError exceptions at load time.
----
- IPython/lib/inputhook.py | 13 +++++++------
- 1 file changed, 7 insertions(+), 6 deletions(-)
-
-diff --git a/IPython/lib/inputhook.py b/IPython/lib/inputhook.py
-index 4ae2cb3..6578365 100644
---- a/IPython/lib/inputhook.py
-+++ b/IPython/lib/inputhook.py
-@@ -107,8 +107,8 @@ class InputHookManager(object):
-     def __init__(self):
-         if ctypes is None:
-             warn("IPython GUI event loop requires ctypes, %gui will not be available")
--            return
--        self.PYFUNC = ctypes.PYFUNCTYPE(ctypes.c_int)
-+        else:
-+            self.PYFUNC = ctypes.PYFUNCTYPE(ctypes.c_int)
-         self.guihooks = {}
-         self.aliases = {}
-         self.apps = {}
-@@ -197,10 +197,11 @@ def enable(self, app=None):
-                     ...
-         """
-         def decorator(cls):
--            inst = cls(self)
--            self.guihooks[toolkitname] = inst
--            for a in aliases:
--                self.aliases[a] = toolkitname
-+            if ctypes is not None:
-+                inst = cls(self)
-+                self.guihooks[toolkitname] = inst
-+                for a in aliases:
-+                    self.aliases[a] = toolkitname
-             return cls
-         return decorator
- 
diff --git a/gnu/packages/patches/w3m-disable-sslv2-and-sslv3.patch b/gnu/packages/patches/w3m-disable-sslv2-and-sslv3.patch
deleted file mode 100644
index 5b78f2d909..0000000000
--- a/gnu/packages/patches/w3m-disable-sslv2-and-sslv3.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-Subject: Disable SSLv2 and SSLv3.
-
-The only remaining methods are TLSv1.* (the code never distinguishes
-between TLSv1.0, TLSv1.1, and TLSv1.2).
----
- fm.h | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/fm.h b/fm.h
-index 320906c..ddcd4fc 100644
---- a/fm.h
-+++ b/fm.h
-@@ -1144,7 +1144,7 @@ global int ssl_path_modified init(FALSE);
- #endif				/* defined(USE_SSL) &&
- 				 * defined(USE_SSL_VERIFY) */
- #ifdef USE_SSL
--global char *ssl_forbid_method init(NULL);
-+global char *ssl_forbid_method init("2, 3");
- #endif
- 
- global int is_redisplay init(FALSE);
--- 
-2.6.4
-
diff --git a/gnu/packages/patches/w3m-disable-weak-ciphers.patch b/gnu/packages/patches/w3m-disable-weak-ciphers.patch
deleted file mode 100644
index 4780d54cb6..0000000000
--- a/gnu/packages/patches/w3m-disable-weak-ciphers.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-Subject: Disable weak ciphers
-
-Disable RC4, "export ciphers", and all keys < 128 bits.
-
-Bug-Ubuntu: https://bugs.launchpad.net/ubuntu/+source/w3m/+bug/1325674
----
- url.c | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/url.c b/url.c
-index ed6062e..e86b1f3 100644
---- a/url.c
-+++ b/url.c
-@@ -326,6 +326,7 @@ openSSLHandle(int sock, char *hostname, char **p_cert)
- 	SSL_load_error_strings();
- 	if (!(ssl_ctx = SSL_CTX_new(SSLv23_client_method())))
- 	    goto eend;
-+	SSL_CTX_set_cipher_list(ssl_ctx, "DEFAULT:!LOW:!RC4:!EXP");
- 	option = SSL_OP_ALL;
- 	if (ssl_forbid_method) {
- 	    if (strchr(ssl_forbid_method, '2'))
--- 
-2.6.4
-
diff --git a/gnu/packages/patches/w3m-force-ssl_verify_server-on.patch b/gnu/packages/patches/w3m-force-ssl_verify_server-on.patch
deleted file mode 100644
index dc9f117f9d..0000000000
--- a/gnu/packages/patches/w3m-force-ssl_verify_server-on.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-Subject: Force ssl_verify_server on.
-
-By default, SSL/TLS certificates are not verified. This enables the
-verification.
----
- fm.h | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/fm.h b/fm.h
-index 8378939..320906c 100644
---- a/fm.h
-+++ b/fm.h
-@@ -1135,7 +1135,7 @@ global int view_unseenobject init(TRUE);
- #endif
- 
- #if defined(USE_SSL) && defined(USE_SSL_VERIFY)
--global int ssl_verify_server init(FALSE);
-+global int ssl_verify_server init(TRUE);
- global char *ssl_cert_file init(NULL);
- global char *ssl_key_file init(NULL);
- global char *ssl_ca_path init(NULL);
--- 
-2.6.4
-
diff --git a/gnu/packages/patches/w3m-libgc.patch b/gnu/packages/patches/w3m-libgc.patch
deleted file mode 100644
index 0dc6a4027c..0000000000
--- a/gnu/packages/patches/w3m-libgc.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-This patch fixes w3m compilation with libgc > 7.2.
-
-Reported:
-https://bugs.archlinux.org/task/33397
-
-Patch with explanation:
-http://anonscm.debian.org/cgit/collab-maint/w3m.git/commit/?id=770eec8304bdbe458
----
- main.c | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/main.c b/main.c
-index b421943..249eb1a 100644
---- a/main.c
-+++ b/main.c
-@@ -833,7 +833,8 @@ main(int argc, char **argv, char **envp)
-     mySignal(SIGPIPE, SigPipe);
- #endif
- 
--    orig_GC_warn_proc = GC_set_warn_proc(wrap_GC_warn_proc);
-+    orig_GC_warn_proc = GC_get_warn_proc();
-+    GC_set_warn_proc(wrap_GC_warn_proc);
-     err_msg = Strnew();
-     if (load_argc == 0) {
- 	/* no URL specified */
--- 
-2.6.4
-
diff --git a/gnu/packages/patches/weex-vacopy.patch b/gnu/packages/patches/weex-vacopy.patch
deleted file mode 100644
index f593e86c08..0000000000
--- a/gnu/packages/patches/weex-vacopy.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Taken from the Debian 2.8.0 package.
-
---- weex-2.6.1.5/src/strlib.c	2003-08-18 11:52:38.000000000 +0200
-+++ weex-2.8.0/src/strlib.c	2007-12-04 14:22:02.000000000 +0100
-@@ -42,6 +42,8 @@
- #  define G_VA_COPY(ap1, ap2)     (*(ap1) = *(ap2))
- #  elif defined (G_VA_COPY_AS_ARRAY)
- #  define G_VA_COPY(ap1, ap2)     g_memmove ((ap1), (ap2), sizeof (va_list))
-+#  elif defined (__x86_64__)
-+#  define G_VA_COPY(ap1, ap2)     memmove ((ap1), (ap2), sizeof (va_list))
- #  else /* va_list is a pointer */
- #  define G_VA_COPY(ap1, ap2)     ((ap1) = (ap2))
- #  endif /* va_list is a pointer */