summary refs log tree commit diff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-02-07 10:08:06 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-02-07 10:23:25 -0500
commitb5e300f9c15640090c82225ca13c25bd54eb0ed4 (patch)
tree2b0fd5389132dfc5355740f91e0d127a4fa93d48 /gnu/packages/patches
parenta083a9b512b695f5a5c7bca7d5a19dda97bd33b9 (diff)
downloadguix-b5e300f9c15640090c82225ca13c25bd54eb0ed4.tar.gz
gnu: jami: Update to 20230206.0.
* gnu/packages/jami.scm (jami): Update to 20230206.0.
(%jami-version): Update version.
(%jami-sources): Adjust URI.  Streamline snippet.
(jami-apply-custom-patches): Use a wildcard to match the top-level directory,
which now includes the version.
(%ffmpeg-default-configure-flags): Adjust URL in top comment.
* gnu/packages/patches/jami-libjami-headers-search.patch: Adjust file names
for new tarball layout.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/jami-libjami-headers-search.patch18
1 files changed, 9 insertions, 9 deletions
diff --git a/gnu/packages/patches/jami-libjami-headers-search.patch b/gnu/packages/patches/jami-libjami-headers-search.patch
index 44e099a610..b3384ba563 100644
--- a/gnu/packages/patches/jami-libjami-headers-search.patch
+++ b/gnu/packages/patches/jami-libjami-headers-search.patch
@@ -20,9 +20,9 @@ Upstream status: https://review.jami.net/c/jami-client-qt/+/22973
  src/libclient/qtwrapper/CMakeLists.txt       |  2 +-
  4 files changed, 9 insertions(+), 18 deletions(-)
 
-diff --git a/client-qt/CMakeLists.txt b/CMakeLists.txt
+diff --git a/CMakeLists.txt b/CMakeLists.txt
 index d0a8fd70..94ac6074 100644
---- a/client-qt/CMakeLists.txt
+--- a/CMakeLists.txt
 +++ b/CMakeLists.txt
 @@ -118,7 +118,7 @@ set(CMAKE_MODULE_PATH
    ${CMAKE_MODULE_PATH} "${EXTRAS_DIR}/build/cmake/modules")
@@ -33,9 +33,9 @@ index d0a8fd70..94ac6074 100644
  endif()
  
  include(FindPython3)
-diff --git a/client-qt/extras/build/cmake/modules/FindLibJami.cmake b/extras/build/cmake/modules/FindLibJami.cmake
+diff --git a/extras/build/cmake/modules/FindLibJami.cmake b/extras/build/cmake/modules/FindLibJami.cmake
 index ddb05319..9ad20d2b 100644
---- a/client-qt/extras/build/cmake/modules/FindLibJami.cmake
+--- a/extras/build/cmake/modules/FindLibJami.cmake
 +++ b/extras/build/cmake/modules/FindLibJami.cmake
 @@ -20,28 +20,19 @@
  
@@ -78,9 +78,9 @@ index ddb05319..9ad20d2b 100644
 -message(STATUS "Jami daemon headers are in " ${LIBJAMI_INCLUDE_DIRS})
 +message(STATUS "Jami daemon headers are in " ${LIBJAMI_INCLUDE_DIR})
  message(STATUS "Jami daemon library is at " ${LIBJAMI_LIB})
-diff --git a/client-qt/src/libclient/CMakeLists.txt b/src/libclient/CMakeLists.txt
+diff --git a/src/libclient/CMakeLists.txt b/src/libclient/CMakeLists.txt
 index 2676c9c4..ac58ea2b 100644
---- a/client-qt/src/libclient/CMakeLists.txt
+--- a/src/libclient/CMakeLists.txt
 +++ b/src/libclient/CMakeLists.txt
 @@ -62,7 +62,7 @@ set(CMAKE_MODULE_PATH
    ${CMAKE_MODULE_PATH} "${EXTRAS_DIR}/build/cmake/modules")
@@ -91,10 +91,10 @@ index 2676c9c4..ac58ea2b 100644
  endif()
  
  string(SUBSTRING ${CMAKE_GENERATOR} 0 14 CMAKE_GENERATOR_SHORT)
-diff --git a/client-qt/src/libclient/qtwrapper/CMakeLists.txt b/src/libclient/qtwrapper/CMakeLists.txt
+diff --git a/src/libclient/qtwrapper/CMakeLists.txt b/src/libclient/qtwrapper/CMakeLists.txt
 index acee0d0c..ba68aac4 100644
---- a/client-qt/src/libclient/qtwrapper/CMakeLists.txt
-+++ b/client-qt/src/libclient/qtwrapper/CMakeLists.txt
+--- a/src/libclient/qtwrapper/CMakeLists.txt
++++ b/src/libclient/qtwrapper/CMakeLists.txt
 @@ -46,7 +46,7 @@ else()
  endif()