summary refs log tree commit diff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorJelle Licht <jlicht@fsfe.org>2017-05-22 20:03:20 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-05-23 17:55:59 +0200
commit1fdb883082385ac8c9200b831630bea069f2945d (patch)
tree7621887b1975c9a380124324dc17a5963685e494 /gnu/packages/patches
parenta7a7186ce61d552ebbcb886f907a653cf67dc251 (diff)
downloadguix-1fdb883082385ac8c9200b831630bea069f2945d.tar.gz
gnu: node: Update to 7.10.0.
* gnu/packages/node.scm (node): Update to 7.10.0.
(node)[arguments]: Disabled more tests.
* gnu/packages/patches/node-9077.patch: Delete incompatible patch file.
Recreate patch file from node pull request 9077.

Signed-off-by: Marius Bakke <mbakke@fastmail.com>
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/node-9077.patch25
1 files changed, 13 insertions, 12 deletions
diff --git a/gnu/packages/patches/node-9077.patch b/gnu/packages/patches/node-9077.patch
index e57f5caac7..6b71d48c0e 100644
--- a/gnu/packages/patches/node-9077.patch
+++ b/gnu/packages/patches/node-9077.patch
@@ -12,19 +12,20 @@ zlib. Using a shared zlib results in build breakage:
                ^ ~~~~~~~~~~~~~~~~~
 1 error generated.
 ---
- node.gyp | 2 ++
- 1 file changed, 2 insertions(+)
+ node.gyp | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
 
 diff --git a/node.gyp b/node.gyp
-index fa98547..d799ba1 100644
+index 272dc98..667c260 100644
 --- a/node.gyp
 +++ b/node.gyp
-@@ -480,6 +480,8 @@
-         }],
-         [ 'node_shared_zlib=="false"', {
-           'dependencies': [ 'deps/zlib/zlib.gyp:zlib' ],
-+        }, {
-+          'defines': [ 'ZLIB_CONST' ],
-         }],
- 
-         [ 'node_shared_http_parser=="false"', {
+@@ -653,7 +653,8 @@
+             [ 'node_shared_zlib=="false"', {
+               'dependencies': [
+                 'deps/zlib/zlib.gyp:zlib',
+-              ]
++              ]}, {
++              'defines': [ 'ZLIB_CONST' ],
+             }],
+             [ 'node_shared_openssl=="false"', {
+               'dependencies': [