summary refs log tree commit diff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-10-25 21:50:59 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-10-25 21:50:59 +0300
commit6ff203663e696b74e711ab09d6f4b35c2c332f0f (patch)
tree4bf2c77c62fa60febba527a76b1ecffaa0a00a0d /gnu/packages/patches
parent408a4ed071c9c52de207d799a698781d49fa727d (diff)
parenta0751e3250dfea7e52468c8090e18c3118d93a60 (diff)
downloadguix-6ff203663e696b74e711ab09d6f4b35c2c332f0f.tar.gz
Merge remote-tracking branch 'origin/master' into staging
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/diffoscope-fix-llvm-test.patch11
-rw-r--r--gnu/packages/patches/giac-pari-gp-anyarg.patch28
-rw-r--r--gnu/packages/patches/rust-shell2batch-lint-fix.patch25
3 files changed, 6 insertions, 58 deletions
diff --git a/gnu/packages/patches/diffoscope-fix-llvm-test.patch b/gnu/packages/patches/diffoscope-fix-llvm-test.patch
index 45e496a128..1c1c344720 100644
--- a/gnu/packages/patches/diffoscope-fix-llvm-test.patch
+++ b/gnu/packages/patches/diffoscope-fix-llvm-test.patch
@@ -3,7 +3,7 @@ From: Tobias Geerinckx-Rice <me@tobias.gr>
 Date: Mon, 4 Oct 2021 21:03:43 +0200
 Subject: [PATCH] gnu: diffoscope: Fix test_item3_deflate_llvm_bitcode.
 
-Taken verbatim from Nixpkgs[0].
+Taken verbatim from Nixpkgs[0].  Later extended for diffoscope >= 224.
 
 [0]: https://github.com/NixOS/nixpkgs/blob/589e03f109092a3ba97781fd0533110bf78a3f97/pkgs/tools/misc/diffoscope/fix-tests.patch
 ---
@@ -11,18 +11,19 @@ Taken verbatim from Nixpkgs[0].
  1 file changed, 3 deletions(-)
 
 diff --git a/tests/comparators/test_rlib.py b/tests/comparators/test_rlib.py
-index 8d201ab..05960aa 100644
+index 8a20114d..64cea17f 100644
 --- a/tests/comparators/test_rlib.py
 +++ b/tests/comparators/test_rlib.py
-@@ -81,9 +81,6 @@ def rlib_dis_expected_diff():
+@@ -80,12 +80,6 @@ def rlib_dis_expected_diff():
      if actual_ver >= "7.0":
          diff_file = "rlib_llvm_dis_expected_diff_7"
  
 -    if actual_ver >= "10.0":
 -        diff_file = "rlib_llvm_dis_expected_diff_10"
 -
+-    if actual_ver >= "15.0":
+-        diff_file = "rlib_llvm_dis_expected_diff_15"
+-
      return get_data(diff_file)
  
  
---
-2.33.0
diff --git a/gnu/packages/patches/giac-pari-gp-anyarg.patch b/gnu/packages/patches/giac-pari-gp-anyarg.patch
deleted file mode 100644
index 0441f6bcf9..0000000000
--- a/gnu/packages/patches/giac-pari-gp-anyarg.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-From 041d16b521d8231e5b441015f08bb386f9d2a51c Mon Sep 17 00:00:00 2001
-From: Vincent Delecroix <20100.delecroix@gmail.com*>
-Date: Thu, 15 Sep 2022 12:11:01 +0200
-Subject: ANYARG giac patch
-
----
-diff --git a/src/pari.cc b/src/pari.cc
-index 76ce8e1..50d08ab 100644
---- a/src/pari.cc
-+++ b/src/pari.cc
-@@ -40,6 +40,13 @@ using namespace std;
- 
- #ifdef HAVE_LIBPARI
- 
-+// Anyarg disappeared from PARI 2.15.0
-+#ifdef __cplusplus
-+#  define ANYARG ...
-+#else
-+#  define ANYARG
-+#endif
-+
- #ifdef HAVE_PTHREAD_H
- #include <pthread.h>
- #endif
-
--- 
-cgit v1.0-1-gd88e
-
diff --git a/gnu/packages/patches/rust-shell2batch-lint-fix.patch b/gnu/packages/patches/rust-shell2batch-lint-fix.patch
deleted file mode 100644
index 7c160b6cca..0000000000
--- a/gnu/packages/patches/rust-shell2batch-lint-fix.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-Resolves the following error that was most likely introduced in new version of
-rust as this package is from 2019:
-
-error: unnecessary parentheses around type
-   --> src/converter.rs:108:61
-    |
-108 | fn add_arguments(arguments: &str, additional_arguments: Vec<(String)>, pre: bool) -> String {
-    |                                                             ^^^^^^^^ help: remove these parentheses
-
-Reported upstream at https://github.com/sagiegurari/shell2batch/issues/17.
-
-diff --git a/src/converter.rs b/src/converter.rs
-index fc87d68..af309d2 100644
---- a/src/converter.rs
-+++ b/src/converter.rs
-@@ -105,7 +105,7 @@ fn replace_vars(arguments: &str) -> String {
-     updated_arguments
- }
- 
--fn add_arguments(arguments: &str, additional_arguments: Vec<(String)>, pre: bool) -> String {
-+fn add_arguments(arguments: &str, additional_arguments: Vec<String>, pre: bool) -> String {
-     let mut windows_arguments = if pre {
-         "".to_string()
-     } else {
-