summary refs log tree commit diff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2015-04-20 13:45:43 +0800
committer宋文武 <iyzsong@gmail.com>2015-04-22 09:57:51 +0800
commitb837e658bdab9e68d17fc0b326ff4556ab623a6b (patch)
treeae18381a9cad8d81ebcbf5d1a39a133309244e2c /gnu/packages/patches
parent45ca81c20da134074718a8450f77b32e3f3491d0 (diff)
downloadguix-b837e658bdab9e68d17fc0b326ff4556ab623a6b.tar.gz
gnu: python-pycairo: Fix build with with python-3.4.3.
* gnu/packages/patches/pycairo-wscript.patch: New file.
* gnu-system.am (dist_patch_DATA): Add it.
* gnu/packages/gtk.scm (python-pycairo)[source]: Use it.
  [build-system]: Use waf-build-system.
  [native-inputs]: Add python-waf.
  [arguments]<#:phases>: Use 'modify-phases'.  Add 'patch-waf phase.
* gnu/packages/gtk.scm (python2-pycairo): Adjust accordingly.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/pycairo-wscript.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/patches/pycairo-wscript.patch b/gnu/packages/patches/pycairo-wscript.patch
new file mode 100644
index 0000000000..c49f0afcb3
--- /dev/null
+++ b/gnu/packages/patches/pycairo-wscript.patch
@@ -0,0 +1,31 @@
+Update the wscript to work with waf-1.8.8.  Based on:
+http://cgit.freedesktop.org/pycairo/commit/?id=c57cd129407c904f8c2f752a59d0183df7b01a5e
+
+
+--- pycairo-1.10.0.orig/wscript	2011-04-18 15:42:29.000000000 +0800
++++ pycairo-1.10.0/wscript	2015-04-20 13:01:45.383756898 +0800
+@@ -13,18 +13,18 @@
+ 
+ def options(ctx):
+   print('  %s/options()' %d)
+-  ctx.tool_options('gnu_dirs')
+-  ctx.tool_options('compiler_cc')
+-  ctx.tool_options('python') # options for disabling pyc or pyo compilation
++  ctx.load('gnu_dirs')
++  ctx.load('compiler_c')
++  ctx.load('python') # options for disabling pyc or pyo compilation
+ 
+ 
+ def configure(ctx):
+   print('  %s/configure()' %d)
+ 
+   env = ctx.env
+-  ctx.check_tool('gnu_dirs')
+-  ctx.check_tool('compiler_cc')
+-  ctx.check_tool('python')
++  ctx.load('gnu_dirs')
++  ctx.load('compiler_c')
++  ctx.load('python')
+   ctx.check_python_version((3,1,0))
+   ctx.check_python_headers()
+   ctx.check_cfg(package='cairo', atleast_version=cairo_version_required,