summary refs log tree commit diff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-01-25 17:07:21 +0100
committerLudovic Courtès <ludo@gnu.org>2014-01-25 17:07:21 +0100
commit200a97e64f29dc904961e99bcbc0f20fef431dd2 (patch)
tree4b8d5c809925320e74efb8c9657037ee6f00d718 /gnu/packages/patches
parentfcaa7523d4f37d5b3c4bf459784e826f98252fe8 (diff)
parent1909431c5b6413c496eb93d3d74be3e3e936951b (diff)
downloadguix-200a97e64f29dc904961e99bcbc0f20fef431dd2.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/glib-tests-desktop.patch32
-rw-r--r--gnu/packages/patches/pspp-tests.patch13
2 files changed, 24 insertions, 21 deletions
diff --git a/gnu/packages/patches/glib-tests-desktop.patch b/gnu/packages/patches/glib-tests-desktop.patch
index 0824e68963..efa877c59e 100644
--- a/gnu/packages/patches/glib-tests-desktop.patch
+++ b/gnu/packages/patches/glib-tests-desktop.patch
@@ -38,12 +38,13 @@ database, the `update-desktop-database' program, which we don't provide.
    return g_test_run ();
  }
 
---- glib-2.37.1/gio/tests/desktop-app-info.c	2013-06-07 23:46:28.000000000 +0200
-+++ glib-2.37.1/gio/tests/desktop-app-info.c	2013-06-07 23:46:32.000000000 +0200
-@@ -385,6 +385,7 @@ main (int   argc,
+
+--- glib-2.39.1/gio/tests/desktop-app-info.c	2013-06-07 23:46:28.000000000 +0200
++++ glib-2.39.1/gio/tests/desktop-app-info.c	2013-06-07 23:46:32.000000000 +0200
+@@ -699,6 +699,7 @@ main (int   argc,
    g_setenv ("XDG_DATA_HOME", basedir, TRUE);
    cleanup_subdirs (basedir);
-   
+ 
 +  return 0;
    g_test_add_func ("/desktop-app-info/delete", test_delete);
    g_test_add_func ("/desktop-app-info/default", test_default);
@@ -54,9 +55,9 @@ database, the `update-desktop-database' program, which we don't provide.
 The hunk below removes tests that depend on `gdbus-testserver.py',
 because that script depends on python-gobject.
  
---- glib-2.38.0.orig/gio/tests/Makefile.in	2013-09-23 23:07:46.000000000 +0200
-+++ glib-2.38.0/gio/tests/Makefile.in	2013-09-30 21:55:35.000000000 +0200
-@@ -172,19 +172,12 @@
+--- glib-2.39.1/gio/tests/Makefile.in	2014-01-20 00:18:16.000000000 +0100
++++ glib-2.39.1/gio/tests/Makefile.in	2014-01-20 00:18:47.000000000 +0100
+@@ -171,20 +171,13 @@ check_PROGRAMS = $(am__EXEEXT_14)
  @HAVE_DBUS_DAEMON_TRUE@@OS_UNIX_TRUE@	gdbus-auth				\
  @HAVE_DBUS_DAEMON_TRUE@@OS_UNIX_TRUE@	gdbus-bz627724				\
  @HAVE_DBUS_DAEMON_TRUE@@OS_UNIX_TRUE@	gdbus-close-pending			\
@@ -72,10 +73,11 @@ because that script depends on python-gobject.
  @HAVE_DBUS_DAEMON_TRUE@@OS_UNIX_TRUE@	gdbus-proxy-threads			\
 -@HAVE_DBUS_DAEMON_TRUE@@OS_UNIX_TRUE@	gdbus-proxy-well-known-name		\
  @HAVE_DBUS_DAEMON_TRUE@@OS_UNIX_TRUE@	gdbus-test-codegen			\
+ @HAVE_DBUS_DAEMON_TRUE@@OS_UNIX_TRUE@	gdbus-test-codegen-old			\
 -@HAVE_DBUS_DAEMON_TRUE@@OS_UNIX_TRUE@	gdbus-threading				\
  @HAVE_DBUS_DAEMON_TRUE@@OS_UNIX_TRUE@	gmenumodel				\
  @HAVE_DBUS_DAEMON_TRUE@@OS_UNIX_TRUE@	$(NULL)
- 
+  
 
 The test below depends on the availability /etc/passwd to dbus-daemon.
 
@@ -105,3 +107,17 @@ The test dbus-appinfo is dropped as it hangs indefinitely since 2.37.5, see
  
    session_bus_up ();
 
+
+The test below fails for unknown reasons (!).
+
+--- glib-2.39.1/gio/tests/gsettings.c.orig	2014-01-20 00:45:04.000000000 +0100
++++ glib-2.39.1/gio/tests/gsettings.c	2014-01-20 00:45:10.000000000 +0100
+@@ -2489,7 +2489,6 @@ main (int argc, char *argv[])
+   g_test_add_func ("/gsettings/range/subprocess/high", test_range_high);
+   g_test_add_func ("/gsettings/range/subprocess/low", test_range_low);
+   g_test_add_func ("/gsettings/list-items", test_list_items);
+-  g_test_add_func ("/gsettings/list-schemas", test_list_schemas);
+   g_test_add_func ("/gsettings/mapped", test_get_mapped);
+   g_test_add_func ("/gsettings/get-range", test_get_range);
+   g_test_add_func ("/gsettings/schema-source", test_schema_source);
+
diff --git a/gnu/packages/patches/pspp-tests.patch b/gnu/packages/patches/pspp-tests.patch
deleted file mode 100644
index 3e61b68804..0000000000
--- a/gnu/packages/patches/pspp-tests.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/tests/output/render-test.c b/tests/output/render-test.c
-index 5f4c1da..e9df96c 100644
---- a/tests/output/render-test.c
-+++ b/tests/output/render-test.c
-@@ -142,7 +142,7 @@ configure_drivers (int width, int length)
-   string_map_insert (&options, "left-margin", "0");
-   string_map_insert (&options, "right-margin", "0");
-   string_map_insert_nocopy (&options, xstrdup ("paper-size"),
--                            xasprintf ("%dx%dpt", width * 5, length * 8));
-+                            xasprintf ("%dx%dpt", width * 5, length * 16));
-   driver = output_driver_create (&options);
-   if (driver == NULL)
-     exit (EXIT_FAILURE);