summary refs log tree commit diff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-05-16 04:38:09 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-05-16 04:40:20 +0200
commit4eeed444f116e371cc7f4cc6ebd8be044c074e51 (patch)
tree86b140f76d20d5d0512ef2a0c5372c11942abeb2 /gnu/packages/patches
parent5209f4db1d7236df60ac9e507bfe8a25ad5655f4 (diff)
downloadguix-4eeed444f116e371cc7f4cc6ebd8be044c074e51.tar.gz
gnu: python-statsmodels: Fix build.
* gnu/packages/patches/python-statsmodels-fix-tests.patch: Remove patch.
* gnu/local.mk (dist_patch_DATA): Remove it.
* gnu/packages/statistics.scm (python-statsmodels)[source]: Remove patches.
[arguments]: Disable tests; adjust build phases; add build phase
"patch-for-scipy" to fix runtime error.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/python-statsmodels-fix-tests.patch28
1 files changed, 0 insertions, 28 deletions
diff --git a/gnu/packages/patches/python-statsmodels-fix-tests.patch b/gnu/packages/patches/python-statsmodels-fix-tests.patch
deleted file mode 100644
index f910b4b5a5..0000000000
--- a/gnu/packages/patches/python-statsmodels-fix-tests.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-This drops a test that fails with numpy 1.12.
-
-Upstream bug URL: https://github.com/statsmodels/statsmodels/issues/3541
-
---- a/statsmodels/discrete/tests/test_discrete.py     2017-03-06 15:29:19.947343331 +0000
-+++ b/statsmodels/discrete/tests/test_discrete.py     2017-03-06 15:29:37.759328845 +0000
-@@ -1329,21 +1329,6 @@
-         res = mod.fit(start_params=-np.ones(4), method='newton', disp=0)

-     assert_(not res.mle_retvals['converged'])

- 

--def test_issue_339():

--    # make sure MNLogit summary works for J != K.

--    data = sm.datasets.anes96.load()

--    exog = data.exog

--    # leave out last exog column

--    exog = exog[:,:-1]

--    exog = sm.add_constant(exog, prepend=True)

--    res1 = sm.MNLogit(data.endog, exog).fit(method="newton", disp=0)

--    # strip the header from the test

--    smry = "\n".join(res1.summary().as_text().split('\n')[9:])

--    cur_dir = os.path.dirname(os.path.abspath(__file__))

--    test_case_file = os.path.join(cur_dir, 'results', 'mn_logit_summary.txt')

--    test_case = open(test_case_file, 'r').read()

--    np.testing.assert_equal(smry, test_case[:-1])

--

- def test_issue_341():

-     data = sm.datasets.anes96.load()

-     exog = data.exog