summary refs log tree commit diff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorCyril Roelandt <tipecaml@gmail.com>2013-04-06 00:28:39 +0200
committerLudovic Courtès <ludo@gnu.org>2013-04-12 21:58:46 +0200
commit3fdc99da1933e07985b6ca04d3b9412d5df05ade (patch)
treee587e3fce8649bdf0ab9481b7299ddb114279c93 /gnu/packages/patches
parentf0cd71f21e41d5a638b69ecee0fa3939f27a4502 (diff)
downloadguix-3fdc99da1933e07985b6ca04d3b9412d5df05ade.tar.gz
gnu: Python: fix the compilation of some modules from the standard library.
This commit enables the bz2, dbm, readline, ssl and zlib modules.

* gnu/packages/gdbm.scm: Enable the compatibility mode.
* gnu/packages/python.scm: Enable a few modules from the standard library.
* gnu/packages/patches/python-fix-dbm.patch: New file.
* Makefile.am: Add it.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/python-fix-dbm.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/patches/python-fix-dbm.patch b/gnu/packages/patches/python-fix-dbm.patch
new file mode 100644
index 0000000000..29e4521f3f
--- /dev/null
+++ b/gnu/packages/patches/python-fix-dbm.patch
@@ -0,0 +1,20 @@
+This patch allows the dbm module to be built using the compatibility mode of
+gdbm. It will not be needed any more with Python 2.7.4.
+--- setup.py	2013-04-06 00:53:37.000000000 +0200
++++ setup.py.new	2013-04-06 19:55:05.000000000 +0200
+@@ -1158,10 +1158,14 @@
+             for cand in dbm_order:
+                 if cand == "ndbm":
+                     if find_file("ndbm.h", inc_dirs, []) is not None:
+-                        # Some systems have -lndbm, others don't
++                        # Some systems have -lndbm, some have -lgdbm_compat,
++                        # others have no particular linker flags.
+                         if self.compiler.find_library_file(lib_dirs,
+                                                                'ndbm'):
+                             ndbm_libs = ['ndbm']
++                        elif self.compiler.find_library_file(lib_dirs,
++                                                             'gdbm_compat'):
++                            ndbm_libs = ['gdbm_compat']
+                         else:
+                             ndbm_libs = []
+                         print "building dbm using ndbm"