summary refs log tree commit diff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2018-05-28 18:23:07 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-05-29 14:05:11 +0200
commit2206c7ad9369d35ec69a93e8a5aac07a954c6a3e (patch)
treecb4e88ffd151f5354fee9d8f84c4bb3970e066e3 /gnu/packages/patches
parent6fe165770539a4551b303dc5cd52db6c51c7604a (diff)
downloadguix-2206c7ad9369d35ec69a93e8a5aac07a954c6a3e.tar.gz
gnu: emacs: Update to 26.1.
* gnu/packages/emacs.scm (emacs): Update to 26.1,
[arguments]: disable tests as they do not exist in release.
* gnu/packages/patches/emacs-fix-scheme-indent-function.patch: Update patch
indentation and line numbers.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/emacs-fix-scheme-indent-function.patch14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/patches/emacs-fix-scheme-indent-function.patch b/gnu/packages/patches/emacs-fix-scheme-indent-function.patch
index c5a426802c..4b7904ea3b 100644
--- a/gnu/packages/patches/emacs-fix-scheme-indent-function.patch
+++ b/gnu/packages/patches/emacs-fix-scheme-indent-function.patch
@@ -14,16 +14,16 @@ The fix is made by Mark H Weaver <mhw@netris.org>:
 
 --- a/lisp/progmodes/scheme.el
 +++ b/lisp/progmodes/scheme.el
-@@ -482,6 +482,12 @@
- 			(> (length function) 3)
- 			(string-match "\\`def" function)))
- 	       (lisp-indent-defform state indent-point))
+@@ -494,6 +494,12 @@ indentation."
+                         (> (length function) 3)
+                         (string-match "\\`def" function)))
+                (lisp-indent-defform state indent-point))
 +              ((and (null method)
 +                    (> (length function) 1)
 +                    ;; The '#' in '#:' seems to get lost, not sure why
 +                    (string-match "\\`:" function))
 +               (let ((lisp-body-indent 1))
 +                 (lisp-indent-defform state indent-point)))
- 	      ((integerp method)
- 	       (lisp-indent-specform method state
- 				     indent-point normal-indent))
+               ((integerp method)
+                (lisp-indent-specform method state
+                                      indent-point normal-indent))