summary refs log tree commit diff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-04-01 00:03:36 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-04-01 01:32:33 +0200
commit3eed550072d6f71eff20de269d313fc1dfe3e332 (patch)
treebb4be7b8f983c28d17df54a475dc3eb3263af678 /gnu/packages/patches
parent571fb008a576378883c053be186d2c620290ea39 (diff)
downloadguix-3eed550072d6f71eff20de269d313fc1dfe3e332.tar.gz
gnu: Remove gtk+/fixed.
The merge preceding this commit ignored the replacement part of commit
bc91562939ee002e84c95d13c907482b6d1e9339.  This commit removes the remaining
bits, as the patch is already included in GTK3 since version 3.24.3.

* gnu/packages/patches/gtk3-fix-deprecation-macro-use.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Remove it.
* gnu/packages/gtk.scm (gtk+/fixed): Remove variable.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/gtk3-fix-deprecation-macro-use.patch28
1 files changed, 0 insertions, 28 deletions
diff --git a/gnu/packages/patches/gtk3-fix-deprecation-macro-use.patch b/gnu/packages/patches/gtk3-fix-deprecation-macro-use.patch
deleted file mode 100644
index e933555ffb..0000000000
--- a/gnu/packages/patches/gtk3-fix-deprecation-macro-use.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-Copied from <https://gitlab.gnome.org/GNOME/gtk/commit/e3a1593a>.
-Fixes upstream bugs <https://gitlab.gnome.org/GNOME/gtk/issues/1523>
-and <https://gitlab.gnome.org/GNOME/gtk/issues/1280>.
-
-diff --git a/gdk/x11/gdkwindow-x11.c b/gdk/x11/gdkwindow-x11.c
-index 97ada6d73919fba3dfe192dd66929e90bc7677bb..764e39495f7edb0c3efe41cca25b8bee4778887d 100644
---- a/gdk/x11/gdkwindow-x11.c
-+++ b/gdk/x11/gdkwindow-x11.c
-@@ -2985,6 +2985,7 @@ gdk_window_x11_set_background (GdkWindow      *window,
-   double r, g, b, a;
-   cairo_surface_t *surface;
-   cairo_matrix_t matrix;
-+  cairo_pattern_t *parent_relative_pattern;
- 
-   if (GDK_WINDOW_DESTROYED (window))
-     return;
-@@ -2997,8 +2998,10 @@ gdk_window_x11_set_background (GdkWindow      *window,
-     }
- 
- G_GNUC_BEGIN_IGNORE_DEPRECATIONS
--  if (pattern == gdk_x11_get_parent_relative_pattern ())
-+  parent_relative_pattern = gdk_x11_get_parent_relative_pattern ();
- G_GNUC_END_IGNORE_DEPRECATIONS
-+
-+  if (pattern == parent_relative_pattern)
-     {
-       GdkWindow *parent;
-