summary refs log tree commit diff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-03-29 21:44:31 +0100
committerLudovic Courtès <ludo@gnu.org>2013-03-29 21:44:31 +0100
commit4928e50033615e1d130dd84f131eff4cbc702ccf (patch)
tree320ff9bae85de20b0293119653b07b1197eaaa82 /gnu/packages/patches
parent14a3a67364f46b24d7e39d64ac92879c3eb7f8eb (diff)
parent3f5a932eeaa8111b841de64b742b1cc408f2419a (diff)
downloadguix-4928e50033615e1d130dd84f131eff4cbc702ccf.tar.gz
Merge branch 'master' into core-updates
Conflicts:
	Makefile.am
	gnu/packages/base.scm
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/cmake-fix-tests.patch45
-rw-r--r--gnu/packages/patches/emacs-configure-sh.patch11
-rw-r--r--gnu/packages/patches/glib-tests-prlimit.patch14
-rw-r--r--gnu/packages/patches/w3m-fix-compile.patch15
4 files changed, 79 insertions, 6 deletions
diff --git a/gnu/packages/patches/cmake-fix-tests.patch b/gnu/packages/patches/cmake-fix-tests.patch
new file mode 100644
index 0000000000..ae28ca336b
--- /dev/null
+++ b/gnu/packages/patches/cmake-fix-tests.patch
@@ -0,0 +1,45 @@
+--- Tests/CMakeLists.txt	2013-03-20 22:57:13.000000000 +0100
++++ Tests/CMakeLists.txt	2013-03-20 22:58:02.000000000 +0100
+@@ -1706,16 +1706,17 @@
+     PASS_REGULAR_EXPRESSION "Could not find executable"
+     FAIL_REGULAR_EXPRESSION "SegFault")
+ 
+-  configure_file(
+-    "${CMake_SOURCE_DIR}/Tests/CTestTestUpload/test.cmake.in"
+-    "${CMake_BINARY_DIR}/Tests/CTestTestUpload/test.cmake"
+-    @ONLY ESCAPE_QUOTES)
+-  add_test(CTestTestUpload ${CMAKE_CTEST_COMMAND}
+-    -S "${CMake_BINARY_DIR}/Tests/CTestTestUpload/test.cmake" -V
+-    --output-log "${CMake_BINARY_DIR}/Tests/CTestTestUpload/testOut.log"
+-    )
+-  set_tests_properties(CTestTestUpload PROPERTIES
+-    PASS_REGULAR_EXPRESSION "Upload\\.xml")
++# This test requires network connectivity: skip it.
++#  configure_file(
++#    "${CMake_SOURCE_DIR}/Tests/CTestTestUpload/test.cmake.in"
++#    "${CMake_BINARY_DIR}/Tests/CTestTestUpload/test.cmake"
++#    @ONLY ESCAPE_QUOTES)
++#  add_test(CTestTestUpload ${CMAKE_CTEST_COMMAND}
++#    -S "${CMake_BINARY_DIR}/Tests/CTestTestUpload/test.cmake" -V
++#    --output-log "${CMake_BINARY_DIR}/Tests/CTestTestUpload/testOut.log"
++#    )
++#  set_tests_properties(CTestTestUpload PROPERTIES
++#    PASS_REGULAR_EXPRESSION "Upload\\.xml")
+ 
+   configure_file(
+     "${CMake_SOURCE_DIR}/Tests/CTestTestConfigFileInBuildDir/test1.cmake.in"
+--- Utilities/cmcurl/CMakeLists.txt	2013-03-20 22:57:13.000000000 +0100
++++ Utilities/cmcurl/CMakeLists.txt	2013-03-20 23:08:41.000000000 +0100
+@@ -729,8 +729,9 @@
+ ADD_EXECUTABLE(LIBCURL Testing/curltest.c)
+ TARGET_LINK_LIBRARIES(LIBCURL cmcurl ${CMAKE_DL_LIBS})
+ 
+-IF(CMAKE_CURL_TEST_URL)
+-  ADD_TEST(curl LIBCURL ${CMAKE_CURL_TEST_URL})
+-ENDIF(CMAKE_CURL_TEST_URL)
++# This test requires network connectivity: skip it.
++#IF(CMAKE_CURL_TEST_URL)
++#  ADD_TEST(curl LIBCURL ${CMAKE_CURL_TEST_URL})
++#ENDIF(CMAKE_CURL_TEST_URL)
+ 
+ INSTALL(FILES COPYING DESTINATION ${CMake_DOC_DEST}/cmcurl)
diff --git a/gnu/packages/patches/emacs-configure-sh.patch b/gnu/packages/patches/emacs-configure-sh.patch
index fd34d06ced..6f5f3fe93a 100644
--- a/gnu/packages/patches/emacs-configure-sh.patch
+++ b/gnu/packages/patches/emacs-configure-sh.patch
@@ -1,14 +1,13 @@
 Make sure the right shell is used when creating src/epaths.h.
 
---- emacs-24.2/configure	2013-01-13 17:01:53.000000000 +0100
-+++ emacs-24.2/configure	2013-01-13 17:01:57.000000000 +0100
-@@ -24135,7 +24135,7 @@ done
+--- emacs-24.3/configure	2013-03-14 17:42:26.000000000 +0100
++++ emacs-24.3/configure	2013-03-14 17:42:58.000000000 +0100
+@@ -26463,7 +26463,7 @@ done
   ;;
      "epaths":C)
  echo creating src/epaths.h
--${MAKE-make} epaths-force
-+${MAKE-make} epaths-force SHELL="$CONFIG_SHELL"
+-${MAKE-make} MAKEFILE_NAME=do-not-make-Makefile epaths-force
++${MAKE-make} MAKEFILE_NAME=do-not-make-Makefile epaths-force SHELL="$CONFIG_SHELL"
   ;;
      "gdbinit":C)
  if test ! -f src/.gdbinit && test -f $srcdir/src/.gdbinit; then
-
diff --git a/gnu/packages/patches/glib-tests-prlimit.patch b/gnu/packages/patches/glib-tests-prlimit.patch
new file mode 100644
index 0000000000..f2b2a61bee
--- /dev/null
+++ b/gnu/packages/patches/glib-tests-prlimit.patch
@@ -0,0 +1,14 @@
+prlimit(2) returns ENOSYS on Linux 2.6.32-5-xen-amd64 as found on
+hydra.gnu.org, and strace(1) doesn't recognize it.
+
+--- glib-2.34.3/glib/tests/thread.c	2012-11-20 15:27:12.000000000 +0100
++++ glib-2.34.3/glib/tests/thread.c	2013-03-27 14:48:31.000000000 +0100
+@@ -130,7 +130,7 @@ test_thread3 (void)
+ static void
+ test_thread4 (void)
+ {
+-#ifdef HAVE_PRLIMIT
++#if 0
+   struct rlimit ol, nl;
+   GThread *thread;
+   GError *error;
diff --git a/gnu/packages/patches/w3m-fix-compile.patch b/gnu/packages/patches/w3m-fix-compile.patch
new file mode 100644
index 0000000000..5604052f67
--- /dev/null
+++ b/gnu/packages/patches/w3m-fix-compile.patch
@@ -0,0 +1,15 @@
+https://bugs.archlinux.org/task/33397
+
+diff -aur old/main.c new/main.c
+--- main.c	2013-01-14 18:16:14.216210053 -0600
++++ main.c	2013-01-14 18:17:28.816220559 -0600
+@@ -833,7 +833,8 @@
+     mySignal(SIGPIPE, SigPipe);
+ #endif
+
+-    orig_GC_warn_proc = GC_set_warn_proc(wrap_GC_warn_proc);
++    orig_GC_warn_proc = GC_get_warn_proc();
++    GC_set_warn_proc(wrap_GC_warn_proc);
+     err_msg = Strnew();
+     if (load_argc == 0) {
+	/* no URL specified */