summary refs log tree commit diff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2016-01-05 16:09:27 -0600
committerLudovic Courtès <ludo@gnu.org>2016-01-12 21:07:53 +0100
commitc91d3fb7f4f754b56b540d8556d6a3ce6085ef37 (patch)
tree89c7d1ff32dcf730de4c26033b8ea1786395129e /gnu/packages/patches
parent3abe8136fddf5bed75219bcb8a552004f078560a (diff)
downloadguix-c91d3fb7f4f754b56b540d8556d6a3ce6085ef37.tar.gz
gnu: boost: Update to 1.60.0.
* gnu/packages/boost.scm (boost): Update to 1.60.0.
  [source]: Remove patch.
* gnu/packages/patches/boost-mips-avoid-m32.patch: Delete patch
* gnu-system.am (dist_patch_DATA): Remove patch.

Also fix dependent packages:

* gnu/packages/patches/csound-header-ordering.patch: New patch.
* gnu/packages/audio.scm (csound)[source]: Use it.
  [arguments]: Add 'set-flags phase.
* gnu/packages/patches/libcmis-fix-test-onedrive.patch: New patch.
* gnu/packages/libreoffice.scm (libcmis)[source]: Use it.
  (libreoffice)[arguments]: Add LDFLAGS to #:configure-flags.
  (librevenge)[inputs]: Move boost from here...
  [propogated-inputs]: to here.
  [arguments]: Add LDFLAGS to #:configure-flags.
* gnu/packages/patches/openimageio-boost-1.60.patch: New patch.
* gnu/packages/graphics.scm (openimageio): Use it.
* gnu-system.am (dist_patch_DATA): Add patches.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/boost-mips-avoid-m32.patch15
-rw-r--r--gnu/packages/patches/csound-header-ordering.patch20
-rw-r--r--gnu/packages/patches/libcmis-fix-test-onedrive.patch35
-rw-r--r--gnu/packages/patches/openimageio-boost-1.60.patch47
4 files changed, 102 insertions, 15 deletions
diff --git a/gnu/packages/patches/boost-mips-avoid-m32.patch b/gnu/packages/patches/boost-mips-avoid-m32.patch
deleted file mode 100644
index 811c9fb3aa..0000000000
--- a/gnu/packages/patches/boost-mips-avoid-m32.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-The following patch prevents the use of the -m32 flag on mips, where it
-is not understood by gcc, as well as other non-x86 architectures.
-
-diff -u -r boost_1_58_0.orig/tools/build/src/tools/gcc.jam boost_1_58_0/tools/build/src/tools/gcc.jam
---- boost_1_58_0.orig/tools/build/src/tools/gcc.jam	2015-04-04 19:25:07.000000000 +0200
-+++ boost_1_58_0/tools/build/src/tools/gcc.jam	2015-07-10 01:08:19.822733823 +0200
-@@ -451,7 +451,7 @@
-         else
-         {
-             local arch = [ feature.get-values architecture : $(properties) ] ;
--            if $(arch) != arm
-+            if $(arch) = x86
-             {
-                 if $(model) = 32
-                 {
diff --git a/gnu/packages/patches/csound-header-ordering.patch b/gnu/packages/patches/csound-header-ordering.patch
new file mode 100644
index 0000000000..3640d123dd
--- /dev/null
+++ b/gnu/packages/patches/csound-header-ordering.patch
@@ -0,0 +1,20 @@
+Prevent compilation issues with boost-1.60.0.
+
+Reported upstream at https://github.com/csound/csound/issues/570
+
+--- Csound6.05/Opcodes/chua/ChuaOscillator.cpp	2015-04-25 14:06:22.995646234 -0500
++++ Csound6.05/Opcodes/chua/ChuaOscillator.cpp	2015-12-21 10:31:58.182362640 -0600
+@@ -117,11 +117,12 @@
+ //     d = sys_variables(12);
+ //     gnor = a*(x.^3) + b*(x.^2) + c*x + d;
+ 
+-#include <OpcodeBase.hpp>
+ #include <boost/numeric/ublas/vector.hpp>
+ using namespace boost::numeric;
+ #include <cmath>
+ 
++#include <OpcodeBase.hpp>
++
+ #undef CS_KSMPS
+ #define CS_KSMPS     (opds.insdshead->ksmps)
+ 
diff --git a/gnu/packages/patches/libcmis-fix-test-onedrive.patch b/gnu/packages/patches/libcmis-fix-test-onedrive.patch
new file mode 100644
index 0000000000..adf2e0b8e5
--- /dev/null
+++ b/gnu/packages/patches/libcmis-fix-test-onedrive.patch
@@ -0,0 +1,35 @@
+Patch from resolution of http://sourceforge.net/p/libcmis/tickets/13/
+
+From 814c7845d53688b35a747cf193c2ff99e40a8652 Mon Sep 17 00:00:00 2001
+From: Jonathan Wakely <jwakely@redhat.com>
+Date: Wed, 2 Sep 2015 16:35:45 +0100
+Subject: [PATCH 5/5] Remove invalid comments from test JSON file.
+
+---
+ qa/libcmis/data/onedrive/search-result.json | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/qa/libcmis/data/onedrive/search-result.json b/qa/libcmis/data/onedrive/search-result.json
+index 61d250a..2482429 100644
+--- a/qa/libcmis/data/onedrive/search-result.json
++++ b/qa/libcmis/data/onedrive/search-result.json
+@@ -8,7 +8,7 @@
+       },
+       "name":"OneDriveFile",
+       "description":"",
+-      "parent_id":"folderA", // path: /A/Wrong File 
++      "parent_id":"folderA",
+       "size":18047,
+       "upload_location":"https://apis.live.net/v5.0/wrongFileId/content/",
+       "comments_count":0,
+@@ -32,7 +32,7 @@
+       },
+       "name":"OneDriveFile",
+       "description":"",
+-      "parent_id":"folderC", // path: /A/B/C/Right File
++      "parent_id":"folderC",
+       "size":4,
+       "upload_location":"https://apis.live.net/v5.0/rightFileId/content/",
+       "comments_count":0,
+-- 
+2.4.3
\ No newline at end of file
diff --git a/gnu/packages/patches/openimageio-boost-1.60.patch b/gnu/packages/patches/openimageio-boost-1.60.patch
new file mode 100644
index 0000000000..92fc3237bb
--- /dev/null
+++ b/gnu/packages/patches/openimageio-boost-1.60.patch
@@ -0,0 +1,47 @@
+From 875fbbd92695397bfc83d1cd5fdd4094e1d50199 Mon Sep 17 00:00:00 2001
+From: Larry Gritz <lg@larrygritz.com>
+Date: Mon, 28 Dec 2015 11:46:07 -0800
+Subject: [PATCH] Python ImageCache binding fixes -- disable broken calls
+
+Some of these calls (thankfully undocumented and presumably unused)
+are horribly broken. They compiled before, but with new Boost 1.60
+they don't even compile properly. So just comment them out on this
+obsolete branch. They are fully fixed in RB-1.6 and beyond.
+
+--- a/src/python/py_imagecache.cpp
++++ b/src/python/py_imagecache.cpp
+@@ -199,23 +199,24 @@ void declare_imagecache()
+         .def("destroy", &ImageCacheWrap::destroy)
+         .staticmethod("destroy")
+         .def("clear", &ImageCacheWrap::clear)
+-        .def("attribute", &ImageCacheWrap::attribute)
++        // .def("attribute", &ImageCacheWrap::attribute)
+         .def("attribute", &ImageCacheWrap::attribute_int)
+         .def("attribute", &ImageCacheWrap::attribute_float)
+-        .def("attribute", &ImageCacheWrap::attribute_double)
+-        .def("attribute", &ImageCacheWrap::attribute_char)
++        // .def("attribute", &ImageCacheWrap::attribute_double)
++        // .def("attribute", &ImageCacheWrap::attribute_char)
+         .def("attribute", &ImageCacheWrap::attribute_string)
+-        .def("getattribute", &ImageCacheWrap::attribute)
++        // .def("getattribute", &ImageCacheWrap::attribute)
+         .def("getattribute", &ImageCacheWrap::getattribute_int)
+         .def("getattribute", &ImageCacheWrap::getattribute_float)
+-        .def("getattribute", &ImageCacheWrap::getattribute_double)
+-        .def("getattribute", &ImageCacheWrap::getattribute_char)
++        // .def("getattribute", &ImageCacheWrap::getattribute_double)
++        // .def("getattribute", &ImageCacheWrap::getattribute_char)
+         .def("getattribute", &ImageCacheWrap::getattribute_string)
+-        .def("resolve_filename", &ImageCacheWrap::resolve_filename)
+-        .def("get_image_info", &ImageCacheWrap::get_image_info)
+-        .def("get_image_info", &ImageCacheWrap::get_image_info_old)
++        // .def("get_image_info", &ImageCacheWrap::get_image_info)
++        // .def("get_image_info", &ImageCacheWrap::get_image_info_old)
+         .def("get_imagespec", &ImageCacheWrap::get_imagespec)
+-        .def("get_pixels", &ImageCacheWrap::get_pixels)
++        // .def("get_pixels", &ImageCacheWrap::get_pixels)
++        .def("resolve_filename", &ImageCacheWrap::resolve_filename)
++
+ //      .def("get_tile", &ImageCacheWrap::get_tile)
+ //      .def("release_tile", &ImageCacheWrap::release_tile)
+ //      .def("tile_pixels", &ImageCacheWrap::tile_pixels)