summary refs log tree commit diff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2023-04-19 23:21:46 +0200
committerLudovic Courtès <ludo@gnu.org>2023-04-19 23:21:46 +0200
commit0e2e7c7554ca5dc6b4f547e61d97e2d5b07f7799 (patch)
tree5ac56b81e420aa61751ea47f430ba0bba81eb390 /gnu/packages/patches
parent3d1b93db65423eb51e37c81d4bcc1243251ce3ae (diff)
downloadguix-0e2e7c7554ca5dc6b4f547e61d97e2d5b07f7799.tar.gz
gnu: python-shiboken-2: Fix compilation with Python 3.10.
* gnu/packages/patches/python-shiboken-2-compat.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/qt.scm (python-shiboken-2): Use it.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/python-shiboken-2-compat.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/patches/python-shiboken-2-compat.patch b/gnu/packages/patches/python-shiboken-2-compat.patch
new file mode 100644
index 0000000000..0c7de64395
--- /dev/null
+++ b/gnu/packages/patches/python-shiboken-2-compat.patch
@@ -0,0 +1,16 @@
+Provide a declaration that's missing in Python 3.10.
+
+--- pyside-setup-opensource-src-5.15.8/sources/shiboken2/libshiboken/sbkpython.h	2023-04-19 23:14:11.415337435 +0200
++++ pyside-setup-opensource-src-5.15.8/sources/shiboken2/libshiboken/sbkpython.h	2023-04-19 23:18:09.055605606 +0200
+@@ -108,6 +108,11 @@ extern "C" {
+ #if PY_MAJOR_VERSION >= 3
+     #define IS_PY3K
+ 
++extern "C" {
++  /* In Python 3.10 this declaration is not provided by <Python.h>.  */
++  extern PyObject* _Py_Mangle(PyObject *p, PyObject *name);
++}
++
+     #define PyInt_Type PyLong_Type
+     #define PyInt_Check PyLong_Check
+     #define PyInt_CheckExact PyLong_CheckExact