summary refs log tree commit diff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorManolis Ragkousis <manolis837@gmail.com>2015-05-21 16:47:26 +0300
committerManolis Ragkousis <manolis837@gmail.com>2015-05-23 22:24:25 +0300
commit94d915d0b0f33a453d902bbffbbb62c241dbab99 (patch)
tree85e084381cd0a339a14e1b39c62ecb0fc0e838d0 /gnu/packages/patches
parentdedaf76f662eedfe34a3753666c536bfe876bb29 (diff)
downloadguix-94d915d0b0f33a453d902bbffbbb62c241dbab99.tar.gz
gnu: base: Fix a bug that occurs in non-Linux systems.
* gnu/packages/base.scm (tar): Apply patch.
* gnu/packages/patches/tar-d_ino_in_dirent-fix.patch: New file.
* gnu-system.am (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/tar-d_ino_in_dirent-fix.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/patches/tar-d_ino_in_dirent-fix.patch b/gnu/packages/patches/tar-d_ino_in_dirent-fix.patch
new file mode 100644
index 0000000000..39d8e2b20a
--- /dev/null
+++ b/gnu/packages/patches/tar-d_ino_in_dirent-fix.patch
@@ -0,0 +1,33 @@
+commit e9ddc08da0982f36581ae5a8c7763453ff41cfe8
+Author: Sergey Poznyakoff <gray@gnu.org>
+Date:   Thu Sep 25 00:22:16 2014 +0300
+
+    Bugfixes.
+    
+    * doc/tar.1: Fix typo in font spec.
+    * src/tar.c (sort_mode_arg, sort_mode_flag): Protect "inode"
+    (SAVEDIR_SORT_INODE) with D_INO_IN_DIRENT
+
+diff --git a/src/tar.c b/src/tar.c
+index 225c624..f8102e0 100644
+--- a/src/tar.c
++++ b/src/tar.c
+@@ -1341,14 +1341,18 @@ static char filename_terminator;
+ static char const *const sort_mode_arg[] = {
+   "none",
+   "name",
++#if D_INO_IN_DIRENT
+   "inode",
++#endif
+   NULL
+ };
+ 
+ static int sort_mode_flag[] = {
+     SAVEDIR_SORT_NONE,
+     SAVEDIR_SORT_NAME,
++#if D_INO_IN_DIRENT
+     SAVEDIR_SORT_INODE
++#endif
+ };
+ 
+ ARGMATCH_VERIFY (sort_mode_arg, sort_mode_flag);
\ No newline at end of file