summary refs log tree commit diff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-24 21:25:08 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-28 20:16:59 -0400
commite41d313cc1ab9433dccc15aab9854012bcae4309 (patch)
tree278e5b1213fc5621e308174130d82a7adc77237f /gnu/packages/patches
parent846c615e15b6848c1e4c7d18146d6b40d417cf9f (diff)
downloadguix-e41d313cc1ab9433dccc15aab9854012bcae4309.tar.gz
gnu: jami: Update to 20230323.0.
* gnu/packages/jami.scm (jami): Update to 20230323.0.
(%ffmpeg-default-configure-flags): Update flags.
(pjproject-jami): Update commit.
(ffmpeg-jami) [version, source, outputs]: : Delete fields.
[arguments]: Delete disable-problematic-tests phase.
* gnu/packages/patches/jami-libjami-headers-search.patch: Rebase patch.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/jami-libjami-headers-search.patch45
1 files changed, 12 insertions, 33 deletions
diff --git a/gnu/packages/patches/jami-libjami-headers-search.patch b/gnu/packages/patches/jami-libjami-headers-search.patch
index b3384ba563..92cc92a4a6 100644
--- a/gnu/packages/patches/jami-libjami-headers-search.patch
+++ b/gnu/packages/patches/jami-libjami-headers-search.patch
@@ -1,30 +1,10 @@
-From 1168aba6181e30ee4c322e5f437bde22bece5698 Mon Sep 17 00:00:00 2001
-From: Maxim Cournoyer <maxim.cournoyer@savoirfairelinux.com>
-Date: Sat, 5 Nov 2022 23:18:13 -0400
-Subject: [PATCH 1/3] cmake: Simplify lookup logic for libjami headers.
-
-* extras/build/cmake/modules/FindLibJami.cmake: Rename
-LIBJAMI_INCLUDE_DIRS to LIBJAMI_INCLUDE_DIR.  Use find_path to search
-for jami.h directory.
-* CMakeLists.txt: Adjust accordingly.
-* src/libclient/CMakeLists.txt: Likewise.
-* src/libclient/qtwrapper/CMakeLists.txt: Likewise.
-
-Change-Id: I494358f9bfafb41f000daeec4196747b2c184401
----
-Upstream status: https://review.jami.net/c/jami-client-qt/+/22973
-
- CMakeLists.txt                               |  2 +-
- extras/build/cmake/modules/FindLibJami.cmake | 21 ++++++--------------
- src/libclient/CMakeLists.txt                 |  2 +-
- src/libclient/qtwrapper/CMakeLists.txt       |  2 +-
- 4 files changed, 9 insertions(+), 18 deletions(-)
+Upstream status: https://review.jami.net/c/jami-client-qt/+/24273.
 
 diff --git a/CMakeLists.txt b/CMakeLists.txt
-index d0a8fd70..94ac6074 100644
+index 8d71b84b..36729698 100644
 --- a/CMakeLists.txt
 +++ b/CMakeLists.txt
-@@ -118,7 +118,7 @@ set(CMAKE_MODULE_PATH
+@@ -136,7 +136,7 @@ set(CMAKE_MODULE_PATH
    ${CMAKE_MODULE_PATH} "${EXTRAS_DIR}/build/cmake/modules")
  find_package(LibJami REQUIRED)
  if(LIBJAMI_FOUND)
@@ -34,15 +14,15 @@ index d0a8fd70..94ac6074 100644
  
  include(FindPython3)
 diff --git a/extras/build/cmake/modules/FindLibJami.cmake b/extras/build/cmake/modules/FindLibJami.cmake
-index ddb05319..9ad20d2b 100644
+index 5cce45fc..11746cd8 100644
 --- a/extras/build/cmake/modules/FindLibJami.cmake
 +++ b/extras/build/cmake/modules/FindLibJami.cmake
-@@ -20,28 +20,19 @@
+@@ -20,30 +20,19 @@
  
  # Once done, this find module will set:
  #
 -#   LIBJAMI_INCLUDE_DIRS - libjami include directories
-+#   LIBJAMI_INCLUDE_DIR - libjami include directories
++#   LIBJAMI_INCLUDE_DIR - libjami include directory
  #   LIBJAMI_FOUND - whether it was able to find the include directories
  #   LIBJAMI_LIB - path to libjami or libring library
  
@@ -62,16 +42,18 @@ index ddb05319..9ad20d2b 100644
 -    set(LIBJAMI_INCLUDE_DIRS ${RING_BUILD_DIR}/jami)
 -  elseif(EXISTS ${CMAKE_INSTALL_PREFIX}/include/jami/jami.h)
 -    set(LIBJAMI_INCLUDE_DIRS ${CMAKE_INSTALL_PREFIX}/include/jami)
+-  elseif(EXISTS ${CMAKE_INSTALL_PREFIX}/daemon/include/jami/jami.h)
+-    set(LIBJAMI_INCLUDE_DIRS ${CMAKE_INSTALL_PREFIX}/daemon/include/jami)
 -  else()
 +  find_path(LIBJAMI_INCLUDE_DIR jami.h PATH_SUFFIXES jami)
 +  if(NOT LIBJAMI_INCLUDE_DIR)
      message(STATUS "Jami daemon headers not found!
 -Set -DLIBJAMI_BUILD_DIR or -DCMAKE_INSTALL_PREFIX")
-+Set -DCMAKE_INSTALL_PREFIX or use -DWITH_DAEMON_SUBMODULE")
++To build using the daemon git submodule, set -DWITH_DAEMON_SUBMODULE")
      set(LIBJAMI_FOUND false)
    endif()
  endif()
-@@ -102,5 +93,5 @@ endif()
+@@ -115,5 +104,5 @@ endif()
  # Restore the original value of CMAKE_FIND_LIBRARY_SUFFIXES.
  set(CMAKE_FIND_LIBRARY_SUFFIXES ${CMAKE_FIND_LIBRARY_SUFFIXES_orig})
  
@@ -79,7 +61,7 @@ index ddb05319..9ad20d2b 100644
 +message(STATUS "Jami daemon headers are in " ${LIBJAMI_INCLUDE_DIR})
  message(STATUS "Jami daemon library is at " ${LIBJAMI_LIB})
 diff --git a/src/libclient/CMakeLists.txt b/src/libclient/CMakeLists.txt
-index 2676c9c4..ac58ea2b 100644
+index 144efaf5..cb87fc2a 100644
 --- a/src/libclient/CMakeLists.txt
 +++ b/src/libclient/CMakeLists.txt
 @@ -62,7 +62,7 @@ set(CMAKE_MODULE_PATH
@@ -92,7 +74,7 @@ index 2676c9c4..ac58ea2b 100644
  
  string(SUBSTRING ${CMAKE_GENERATOR} 0 14 CMAKE_GENERATOR_SHORT)
 diff --git a/src/libclient/qtwrapper/CMakeLists.txt b/src/libclient/qtwrapper/CMakeLists.txt
-index acee0d0c..ba68aac4 100644
+index 46887051..a20658ad 100644
 --- a/src/libclient/qtwrapper/CMakeLists.txt
 +++ b/src/libclient/qtwrapper/CMakeLists.txt
 @@ -46,7 +46,7 @@ else()
@@ -104,6 +86,3 @@ index acee0d0c..ba68aac4 100644
  include_directories(${CMAKE_CURRENT_SOURCE_DIR}/../)
  include_directories(${CMAKE_CURRENT_SOURCE_DIR}/../dbus)
  
--- 
-2.37.3
-