summary refs log tree commit diff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-29 23:50:26 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:53:42 -0400
commitedac21bfc78ffea85f4dac7206e5e7cd621bba19 (patch)
tree6985981ed25a3a9807c59a1b5b040d76feaeb0a7 /gnu/packages/patches
parentbbbfe095fb167cb56b1fd9a20bf50bf53a0cdaf5 (diff)
downloadguix-edac21bfc78ffea85f4dac7206e5e7cd621bba19.tar.gz
gnu: Remove wicd.
The last release is from 2017, stuck on Python 2.

* gnu/packages/wicd.scm: Delete file.
* gnu/packages/patches/wicd-bitrate-none-fix.patch: Delete file.
* gnu/packages/patches/wicd-get-selected-profile-fix.patch: Likewise.
* gnu/packages/patches/wicd-urwid-1.3.patch: Likewise.
* gnu/packages/patches/wicd-wpa2-ttls.patch: Likewise.
* gnu/local.mk: De-register them.
* gnu/services/networking.scm: Remove wicd service...
* doc/guix.texi: ... and its documentation.
* gnu/system/linux-container.scm (containerized-operating-system)
<services-to-drop>: Remove wicd-service-type.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/wicd-bitrate-none-fix.patch24
-rw-r--r--gnu/packages/patches/wicd-get-selected-profile-fix.patch16
-rw-r--r--gnu/packages/patches/wicd-urwid-1.3.patch18
-rw-r--r--gnu/packages/patches/wicd-wpa2-ttls.patch38
4 files changed, 0 insertions, 96 deletions
diff --git a/gnu/packages/patches/wicd-bitrate-none-fix.patch b/gnu/packages/patches/wicd-bitrate-none-fix.patch
deleted file mode 100644
index 1809b7217d..0000000000
--- a/gnu/packages/patches/wicd-bitrate-none-fix.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-Fix copied from https://bugs.launchpad.net/wicd/+bug/1432423/comments/1
-
---- wicd-1.7.3/curses/netentry_curses.py	1969-12-31 19:00:00.000000000 -0500
-+++ wicd-1.7.3/curses/netentry_curses.py	2015-08-11 23:26:19.999999649 -0400
-@@ -538,11 +538,16 @@
-         self.bitrates = wireless.GetAvailableBitrates()
-         self.bitrates.append('auto')
-         self.bitrate_combo.set_list(self.bitrates)
-+
-+        # bitrate property is sometimes None
-+        chosen_bitrate = wireless.GetWirelessProperty(networkID, 'bitrate')
-+        if chosen_bitrate not in self.bitrates:
-+            chosen_bitrate = 'auto'
-+
-         self.bitrate_combo.set_focus(
--            self.bitrates.index(
--                wireless.GetWirelessProperty(networkID, 'bitrate')
--            )
-+            self.bitrates.index(chosen_bitrate)
-         )
-+
-         self.allow_lower_bitrates_chkbox.set_state(
-             to_bool(self.format_entry(networkID, 'allow_lower_bitrates'))
-         )
diff --git a/gnu/packages/patches/wicd-get-selected-profile-fix.patch b/gnu/packages/patches/wicd-get-selected-profile-fix.patch
deleted file mode 100644
index 3042a87308..0000000000
--- a/gnu/packages/patches/wicd-get-selected-profile-fix.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-Fix copied from https://bugs.launchpad.net/wicd/+bug/1421918/comments/2
-
---- wicd-1.7.3/curses/wicd-curses.py	2014-12-21 16:57:33 +0000
-+++ wicd-1.7.3/curses/wicd-curses.py	2015-02-24 23:41:01 +0000
-@@ -532,7 +532,10 @@
-     def get_selected_profile(self):
-         """Get the selected wired profile"""
-         loc = self.get_focus()[1]
--        return self.theList[loc]
-+        if len(self.theList) > loc:
-+            return self.theList[loc]
-+        else:
-+            return self.theList[-1]
- 
- 
- class AdHocDialog(Dialog2):
diff --git a/gnu/packages/patches/wicd-urwid-1.3.patch b/gnu/packages/patches/wicd-urwid-1.3.patch
deleted file mode 100644
index 1dc47f869b..0000000000
--- a/gnu/packages/patches/wicd-urwid-1.3.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-Update the wicd-curses client to work with urwid-1.3.  Based on a patch from:
-http://technik.blogbasis.net/wicd-curses-fix-fuer-attributeerror-screen-object-no-attribute-get_input_nonblocking-04-12-2014
-
---- wicd-1.7.3/curses/wicd-curses.py.orig	2014-12-21 14:40:46.000000000 -0500
-+++ wicd-1.7.3/curses/wicd-curses.py	2015-02-05 23:41:17.530901204 -0500
-@@ -1153,9 +1153,10 @@
-         if not ui._started:
-             return False
- 
--        input_data = ui.get_input_nonblocking()
-+        ui.set_input_timeouts(max_wait=0)
-+        input_data = ui.get_input()
-         # Resolve any "alarms" in the waiting
--        self.handle_keys(input_data[1])
-+        self.handle_keys(input_data)
- 
-         # Update the screen
-         canvas = self.frame.render((self.size), True)
diff --git a/gnu/packages/patches/wicd-wpa2-ttls.patch b/gnu/packages/patches/wicd-wpa2-ttls.patch
deleted file mode 100644
index 9d80ee7ed2..0000000000
--- a/gnu/packages/patches/wicd-wpa2-ttls.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-Add a template for WPA2-TTLS, which is notably used by Eduroam.
-
---- a/encryption/templates/active
-+++ b/encryption/templates/active
-@@ -4,6 +4,7 @@ wpa-psk
- wpa-psk-hex
- wpa2-leap
- wpa2-peap
-+wpa2-ttls
- wep-hex
- wep-passphrase
- wep-shared
-diff --git a/encryption/templates/wpa2-ttls b/encryption/templates/wpa2-ttls
-new file mode 100644
-index 0000000..4f66a1e
---- /dev/null
-+++ b/encryption/templates/wpa2-ttls
-@@ -0,0 +1,20 @@
-+name = WPA2-TTLS (used notably by Eduroam)
-+author = various contributors
-+version = 1
-+require identity *Identity anonymous_identity *Anonymous_identity password *Password ca_cert *Path_to_CA_Cert
-+protected password *Password
-+-----
-+ctrl_interface=/var/run/wpa_supplicant
-+network={
-+        ssid="$_ESSID"
-+        scan_ssid=$_SCAN
-+        proto=WPA2
-+        key_mgmt=WPA-EAP
-+        group=CCMP TKIP
-+        eap=TTLS
-+        identity="$_IDENTITY"
-+        password="$_PASSWORD"
-+        anonymous_identity="$_ANONYMOUS_IDENTITY"
-+        ca_cert="$_CA_CERT"
-+        phase2="auth=PAP"
-+}