summary refs log tree commit diff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorVagrant Cascadian <vagrant@debian.org>2020-01-08 17:44:48 -0800
committerVagrant Cascadian <vagrant@debian.org>2020-01-08 22:24:20 -0800
commit634b0e28de019be2c142f1690e8d67fd00616ff3 (patch)
tree286f31adc404e12a76367630d39acdd6d6dad6df /gnu/packages/patches
parenta1fd8c5dee3238c8360592904c3b33989cbf88cd (diff)
downloadguix-634b0e28de019be2c142f1690e8d67fd00616ff3.tar.gz
gnu: u-boot: Update to 2020.01.
* gnu/packages/bootloaders (u-boot): Update to 2020.01.
  [source]: Remove patch u-boot-fix-mkimage-header-verification.
  [native-inputs]: Update to use python 3 and add perl.
  (u-boot-tools)[configure]: Use tools-only_defconfig.
  [arguments]: Update phase updating python-coverage to work with python 3.
  Drop obsolete substitution for test_ofplatdata.
  Disable code coverage tests and binman tests.
* gnu/packages/patches/u-boot-fix-mkimage-header-verification.patch: Remove file.
* gnu/local.mk [dist_patch_DATA]: Update accordingly.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/u-boot-fix-mkimage-header-verification.patch57
1 files changed, 0 insertions, 57 deletions
diff --git a/gnu/packages/patches/u-boot-fix-mkimage-header-verification.patch b/gnu/packages/patches/u-boot-fix-mkimage-header-verification.patch
deleted file mode 100644
index 063677db4a..0000000000
--- a/gnu/packages/patches/u-boot-fix-mkimage-header-verification.patch
+++ /dev/null
@@ -1,57 +0,0 @@
-From 48b52117235928cfd7ef1ec5c3f2cff5d7b03862 Mon Sep 17 00:00:00 2001
-From: Jordan Hand <jordanhand22@gmail.com>
-Date: Wed, 10 Apr 2019 09:46:32 -0700
-Subject: [PATCH,v2] fdt: Fix mkimage list to try every header type
-Origin: https://patchwork.ozlabs.org/patch/1083495/
-
-Image type is not supplied to `mkimage -l`. For this reason, we cannot
-use imagetool_verify_print_header_by_type. Instead, this patch uses
-imagetool_verify_print_header to look through all header types to find
-one where image validation succeeds.
-
-This patch fixes failures in test/image/test-imagetools.sh
-
-Signed-off-by: Jordan Hand <jorhand@microsoft.com>
-Tested-by: Alex Kiernan <alex.kiernan@gmail.com>
-Tested-by: Vagrant Cascadian <vagrant@debian.org>
----
- tools/mkimage.c | 23 +++++++++++++++--------
- 1 file changed, 15 insertions(+), 8 deletions(-)
-
-diff --git a/tools/mkimage.c b/tools/mkimage.c
-index 2899adff81..76c3406d37 100644
---- a/tools/mkimage.c
-+++ b/tools/mkimage.c
-@@ -403,14 +403,21 @@ int main(int argc, char **argv)
- 			exit (EXIT_FAILURE);
- 		}
- 
--		/*
--		 * scan through mkimage registry for all supported image types
--		 * and verify the input image file header for match
--		 * Print the image information for matched image type
--		 * Returns the error code if not matched
--		 */
--		retval = imagetool_verify_print_header_by_type(ptr, &sbuf,
--				tparams, &params);
-+		if (params.fflag) {
-+			/*
-+			 * Verifies the header format based on the expected header for
-+			 * image type in tparams
-+			 */
-+			retval = imagetool_verify_print_header_by_type(ptr, &sbuf,
-+					tparams, &params);
-+		} else {
-+			/**
-+			 * When listing the image, we are not given the image type. Simply check all
-+			 * image types to find one that matches our header
-+			 */
-+			retval = imagetool_verify_print_header(ptr, &sbuf,
-+					tparams, &params);
-+		}
- 
- 		(void) munmap((void *)ptr, sbuf.st_size);
- 		(void) close (ifd);
--- 
-2.20.1
-