summary refs log tree commit diff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-05-02 13:48:11 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-05-04 16:53:48 +0200
commitc9c63edbde6aaf774d263036d4f14da25c88ed53 (patch)
tree261c98e3f8c7e3e9a9a5d6da728a298e4da36798 /gnu/packages/patches
parent46c39e1e47f158c338ac9c4bd4c62e72fe9bf2d2 (diff)
downloadguix-c9c63edbde6aaf774d263036d4f14da25c88ed53.tar.gz
gnu: gstreamer: Update to 1.16.0.
* gnu/packages/gstreamer.scm (gstreamer, gst-plugins-base, gst-plugins-bad,
gst-plugins-ugly, python-gst): Update to 1.16.0.
(gst-plugins-good): Likewise.
[source](patches): Remove.
[arguments]: Remove #:make-flags.
(gst-libav): Update to 1.16.0.
[inputs]: Change FFMPEG-3.4 to FFMPEG.
* gnu/packages/patches/gst-plugins-good-libvpx-compat.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/gst-plugins-good-libvpx-compat.patch58
1 files changed, 0 insertions, 58 deletions
diff --git a/gnu/packages/patches/gst-plugins-good-libvpx-compat.patch b/gnu/packages/patches/gst-plugins-good-libvpx-compat.patch
deleted file mode 100644
index 8306c79e56..0000000000
--- a/gnu/packages/patches/gst-plugins-good-libvpx-compat.patch
+++ /dev/null
@@ -1,58 +0,0 @@
-Fix build with libvpx 1.8.
-
-Taken from this upstream commit:
-https://gitlab.freedesktop.org/gstreamer/gst-plugins-good/commit/b6e6f1ae73375ef66a5748069843aaed1a83e6a6
-
-Note: Remove the HAVE_VPX_1_8 build flag with this patch.  It was added
-to avoid re-creating the configure script.
-
-diff --git a/configure.ac b/configure.ac
-index 5e4cff126..8c20e5081 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -1054,6 +1054,10 @@ AG_GST_CHECK_FEATURE(VPX, [VPX decoder], vpx, [
-       AC_DEFINE(HAVE_VPX_1_4, 1, [Defined if the VPX library version is 1.4 or bigger])
-     ], [true])
- 
-+    PKG_CHECK_MODULES(VPX_180, vpx >= 1.8.0, [
-+      AC_DEFINE(HAVE_VPX_1_8, 1, [Defined if the VPX library version is 1.8 or bigger])
-+    ], [true])
-+
-     LIBS="$OLD_LIBS"
-     CFLAGS="$OLD_CFLAGS"
-   fi
-diff --git a/ext/vpx/gstvpxdec.c b/ext/vpx/gstvpxdec.c
-index c3f0f625f..da4322513 100644
---- a/ext/vpx/gstvpxdec.c
-+++ b/ext/vpx/gstvpxdec.c
-@@ -62,6 +62,7 @@ gst_vpx_dec_post_processing_flags_get_type (void)
-     {C_FLAGS (VP8_DEBLOCK), "Deblock", "deblock"},
-     {C_FLAGS (VP8_DEMACROBLOCK), "Demacroblock", "demacroblock"},
-     {C_FLAGS (VP8_ADDNOISE), "Add noise", "addnoise"},
-+#ifndef HAVE_VPX_1_8
-     {C_FLAGS (VP8_DEBUG_TXT_FRAME_INFO),
-           "Print frame information",
-         "visualize-frame-info"},
-@@ -74,6 +75,7 @@ gst_vpx_dec_post_processing_flags_get_type (void)
-     {C_FLAGS (VP8_DEBUG_TXT_RATE_INFO),
-           "Print video rate info",
-         "visualize-rate-info"},
-+#endif
-     {C_FLAGS (VP8_MFQE), "Multi-frame quality enhancement", "mfqe"},
-     {0, NULL, NULL}
-   };
-diff --git a/ext/vpx/meson.build b/ext/vpx/meson.build
-index 6ed440728..0d2340b32 100644
---- a/ext/vpx/meson.build
-+++ b/ext/vpx/meson.build
-@@ -48,6 +48,10 @@ if vpx_dep.found()
-     vpx_args += '-DHAVE_VPX_1_4'
-   endif
- 
-+  if dependency('vpx', version : '>=1.8.0', required : false).found()
-+    vpx_args += '-DHAVE_VPX_1_8'
-+  endif
-+
-   gstvpx = library('gstvpx',
-     vpx_sources,
-     c_args : gst_plugins_good_args + vpx_args,