summary refs log tree commit diff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-09-27 21:14:27 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-09-27 21:14:27 +0200
commit9f1d112d1282216f16b2f673c8213d2839e39b7a (patch)
tree890d036d75ae0d38ebff39a4be000959e71409ec /gnu/packages/patches
parent859620e51db0b7ffb666cd47146eca4fd4d6ba63 (diff)
parentcb1e0cfc2f32e6811da588231497d896491ceabb (diff)
downloadguix-9f1d112d1282216f16b2f673c8213d2839e39b7a.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/e2fsprogs-32bit-quota-warnings.patch46
-rw-r--r--gnu/packages/patches/fontforge-svg-modtime.patch35
-rw-r--r--gnu/packages/patches/libunwind-CVE-2015-3239.patch17
-rw-r--r--gnu/packages/patches/python-acme-dont-use-openssl-rand.patch28
4 files changed, 0 insertions, 126 deletions
diff --git a/gnu/packages/patches/e2fsprogs-32bit-quota-warnings.patch b/gnu/packages/patches/e2fsprogs-32bit-quota-warnings.patch
deleted file mode 100644
index e7a96a2ac0..0000000000
--- a/gnu/packages/patches/e2fsprogs-32bit-quota-warnings.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-Fix a test failure on 32-bit platforms.
-
-Patch copied from upstream source repository:
-
-https://git.kernel.org/pub/scm/fs/ext2/e2fsprogs.git/commit/?id=9e31a5696c4b699bf000a07b86601c1fb91c0493
-
-diff --git a/lib/support/mkquota.c b/lib/support/mkquota.c
-index 00f3a40..931a839 100644
---- a/lib/support/mkquota.c
-+++ b/lib/support/mkquota.c
-@@ -50,11 +50,13 @@ static void print_dquot(const char *desc, struct dquot *dq)
- {
- 	if (desc)
- 		fprintf(stderr, "%s: ", desc);
--	fprintf(stderr, "%u %ld:%ld:%ld %ld:%ld:%ld\n",
--		dq->dq_id, dq->dq_dqb.dqb_curspace,
--		dq->dq_dqb.dqb_bsoftlimit, dq->dq_dqb.dqb_bhardlimit,
--		dq->dq_dqb.dqb_curinodes,
--		dq->dq_dqb.dqb_isoftlimit, dq->dq_dqb.dqb_ihardlimit);
-+	fprintf(stderr, "%u %lld:%lld:%lld %lld:%lld:%lld\n",
-+		dq->dq_id, (long long) dq->dq_dqb.dqb_curspace,
-+		(long long) dq->dq_dqb.dqb_bsoftlimit,
-+		(long long) dq->dq_dqb.dqb_bhardlimit,
-+		(long long) dq->dq_dqb.dqb_curinodes,
-+		(long long) dq->dq_dqb.dqb_isoftlimit,
-+		(long long) dq->dq_dqb.dqb_ihardlimit);
- }
- #else
- static void print_dquot(const char *desc EXT2FS_ATTR((unused)),
-@@ -524,11 +526,11 @@ static int scan_dquots_callback(struct dquot *dquot, void *cb_data)
- 	    dq->dq_dqb.dqb_curinodes != dquot->dq_dqb.dqb_curinodes) {
- 		scan_data->usage_is_inconsistent = 1;
- 		fprintf(stderr, "[QUOTA WARNING] Usage inconsistent for ID %u:"
--			"actual (%ld, %ld) != expected (%ld, %ld)\n",
--			dq->dq_id, dq->dq_dqb.dqb_curspace,
--			dq->dq_dqb.dqb_curinodes,
--			dquot->dq_dqb.dqb_curspace,
--			dquot->dq_dqb.dqb_curinodes);
-+			"actual (%lld, %lld) != expected (%lld, %lld)\n",
-+			dq->dq_id, (long long) dq->dq_dqb.dqb_curspace,
-+			(long long) dq->dq_dqb.dqb_curinodes,
-+			(long long) dquot->dq_dqb.dqb_curspace,
-+			(long long) dquot->dq_dqb.dqb_curinodes);
- 	}
- 
- 	if (scan_data->update_limits) {
diff --git a/gnu/packages/patches/fontforge-svg-modtime.patch b/gnu/packages/patches/fontforge-svg-modtime.patch
deleted file mode 100644
index fd960ae610..0000000000
--- a/gnu/packages/patches/fontforge-svg-modtime.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-Propagate source font modification time to svg during conversion.  Similar to
-what upstream commit 95a470e941d9a20fbdaca51334e8b6b9d93cfae4 did for TTF
-files.
-
-Submitted upstream at http://github.com/fontforge/fontforge/pull/2696
-
---- a/fontforge/svg.c
-+++ b/fontforge/svg.c
-@@ -27,7 +27,6 @@
- #include "fontforgevw.h"
- #include <unistd.h>
- #include <math.h>
--#include <time.h>
- #include <locale.h>
- #include <utype.h>
- #include <chardata.h>
-@@ -62,7 +61,6 @@ static int svg_outfontheader(FILE *file, SplineFont *sf,int layer) {
-     BlueData bd;
-     char *hash, *hasv, ch;
-     int minu, maxu, i;
--    time_t now;
-     const char *author = GetAuthor();
- 
-     memset(&info,0,sizeof(info));
-@@ -78,9 +76,8 @@ static int svg_outfontheader(FILE *file, SplineFont *sf,int layer) {
- 	fprintf( file, "\n-->\n" );
-     }
-     fprintf( file, "<svg xmlns=\"http://www.w3.org/2000/svg\" xmlns:xlink=\"http://www.w3.org/1999/xlink\" version=\"1.1\">\n" );
--    time(&now);
-     fprintf( file, "<metadata>\nCreated by FontForge %d at %s",
--	    FONTFORGE_VERSIONDATE_RAW, ctime(&now) );
-+	    FONTFORGE_VERSIONDATE_RAW, ctime((time_t*)&sf->modificationtime) );
-     if ( author!=NULL )
- 	fprintf(file," By %s\n", author);
-     else
diff --git a/gnu/packages/patches/libunwind-CVE-2015-3239.patch b/gnu/packages/patches/libunwind-CVE-2015-3239.patch
deleted file mode 100644
index 3f11ac7337..0000000000
--- a/gnu/packages/patches/libunwind-CVE-2015-3239.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-Copied from Fedora.
-
-https://bugzilla.redhat.com/show_bug.cgi?id=1232265
-http://pkgs.fedoraproject.org/cgit/libunwind.git/tree/libunwind-1.1-fix-CVE-2015-3239.patch
-
-diff -up libunwind-1.1/include/dwarf_i.h.CVE20153239 libunwind-1.1/include/dwarf_i.h
---- libunwind-1.1/include/dwarf_i.h.CVE20153239	2015-07-10 13:38:36.404996748 -0400
-+++ libunwind-1.1/include/dwarf_i.h	2015-07-10 13:39:25.050707613 -0400
-@@ -20,7 +20,7 @@
- extern const uint8_t dwarf_to_unw_regnum_map[DWARF_REGNUM_MAP_LENGTH];
- /* REG is evaluated multiple times; it better be side-effects free!  */
- # define dwarf_to_unw_regnum(reg)					  \
--  (((reg) <= DWARF_REGNUM_MAP_LENGTH) ? dwarf_to_unw_regnum_map[reg] : 0)
-+  (((reg) < DWARF_REGNUM_MAP_LENGTH) ? dwarf_to_unw_regnum_map[reg] : 0)
- #endif
- 
- #ifdef UNW_LOCAL_ONLY
diff --git a/gnu/packages/patches/python-acme-dont-use-openssl-rand.patch b/gnu/packages/patches/python-acme-dont-use-openssl-rand.patch
deleted file mode 100644
index 78920629c0..0000000000
--- a/gnu/packages/patches/python-acme-dont-use-openssl-rand.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-Fix build with PyOpenSSL > 17.2.0.
-
-See <https://github.com/certbot/certbot/issues/5111>.
-
-Patch copied from upstream source repository:
-https://github.com/certbot/certbot/commit/f6be07da74c664b57ac8c053585f919c79f9af44
-
-diff --git a/acme/crypto_util.py b/acme/crypto_util.py
-index de15284c03..b8fba03488 100644
---- a/acme/crypto_util.py
-+++ b/acme/crypto_util.py
-@@ -2,6 +2,7 @@
- import binascii
- import contextlib
- import logging
-+import os
- import re
- import socket
- import sys
-@@ -243,7 +244,7 @@ def gen_ss_cert(key, domains, not_before=None,
-     """
-     assert domains, "Must provide one or more hostnames for the cert."
-     cert = OpenSSL.crypto.X509()
--    cert.set_serial_number(int(binascii.hexlify(OpenSSL.rand.bytes(16)), 16))
-+    cert.set_serial_number(int(binascii.hexlify(os.urandom(16)), 16))
-     cert.set_version(2)
- 
-     extensions = [