summary refs log tree commit diff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2018-07-16 23:48:24 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2018-07-16 23:51:38 +0200
commita545090ce5e6b9da1f473f558dabda69f317e461 (patch)
tree9a6c3afa04304d5536613179dab894196fc72734 /gnu/packages/patches
parent8e632a6435bb8ea408127833030f7764b78768a9 (diff)
downloadguix-a545090ce5e6b9da1f473f558dabda69f317e461.tar.gz
gnu: python-cairocffi: Fix loading of shared libraries.
Fixes <https://bugs.gnu.org/32170>.

* gnu/packages/patches/python-cairocffi-dlopen-path.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/python.scm (python-cairocffi)[inputs]: Add glib, gtk+, pango.
[native-inputs]: Add python-pytest.
[arguments]: Enable tests.
[arguments]<#:phases>[patch-paths]: New phase.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/python-cairocffi-dlopen-path.patch10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/patches/python-cairocffi-dlopen-path.patch b/gnu/packages/patches/python-cairocffi-dlopen-path.patch
new file mode 100644
index 0000000000..e7a7fe3737
--- /dev/null
+++ b/gnu/packages/patches/python-cairocffi-dlopen-path.patch
@@ -0,0 +1,10 @@
+--- cairocffi-0.8.0/cairocffi/__init__.py.orig	2018-07-16 11:00:59.075664158 +0200
++++ cairocffi-0.8.0/cairocffi/__init__.py	2018-07-16 17:09:42.471958015 +0200
+@@ -35,6 +35,7 @@
+                         return lib
+             except OSError:
+                 pass
++        return ffi.dlopen(name)
+     raise OSError("dlopen() failed to load a library: %s" % ' / '.join(names))
+ 
+