summary refs log tree commit diff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorBen Sturmfels <ben@sturm.com.au>2017-04-19 02:24:57 +1000
committerMarius Bakke <mbakke@fastmail.com>2017-04-18 19:16:45 +0200
commit1b5b24c92d5176083ad749ba5d28f6ac31a3a0f7 (patch)
treefa145cf564aa0f2c276accd803892d3ebef2d6a1 /gnu/packages/patches
parent16fe516e78287166d720bff783acbe3661878102 (diff)
downloadguix-1b5b24c92d5176083ad749ba5d28f6ac31a3a0f7.tar.gz
gnu: fabric: Enable tests.
* gnu/packages/patches/fabric-tests.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/admin.scm (fabric)[source]: Use it.
[native-inputs]: Add PYTHON2-FUDGE, PYTHON2-JINJA2 and PYTHON2-NOSE.
[arguments]<#:tests>: Remove.

Signed-off-by: Marius Bakke <mbakke@fastmail.com>
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/fabric-tests.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/gnu/packages/patches/fabric-tests.patch b/gnu/packages/patches/fabric-tests.patch
new file mode 100644
index 0000000000..4a0ca9f8f1
--- /dev/null
+++ b/gnu/packages/patches/fabric-tests.patch
@@ -0,0 +1,15 @@
+The `fab` excecutable doesn't exist during the test phase as it is created
+dynamically during installation. Refer to the equivalent Python module
+directly.
+
+--- a/tests/test_utils.py
++++ b/tests/test_utils.py
+@@ -93,7 +93,7 @@
+     # perform when they are allowed to bubble all the way to the top. So, we
+     # invoke a subprocess and look at its stderr instead.
+     with quiet():
+-        result = local("fab -f tests/support/aborts.py kaboom", capture=True)
++        result = local("python -m fabric -f tests/support/aborts.py kaboom", capture=True)
+     # When error in #1318 is present, this has an extra "It burns!" at end of
+     # stderr string.
+     eq_(result.stderr, "Fatal error: It burns!\n\nAborting.")
\ No newline at end of file