summary refs log tree commit diff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-07-19 20:44:27 +0200
committerMarius Bakke <marius@gnu.org>2021-07-23 17:26:45 +0200
commit2fa26446a186664c6364de0536380e43113dc95f (patch)
tree8c1df47980c29544c7cb1b221c115dc150a8c22d /gnu/packages/patches
parente045fd7ce22fb0c098db8317e4e06b68c543ba60 (diff)
downloadguix-2fa26446a186664c6364de0536380e43113dc95f.tar.gz
gnu: binutils: Update to 2.37.
* gnu/packages/patches/binutils-loongson-workaround.patch: Adjust for upstream
changes.
* gnu/packages/patches/binutils-libiberty-endianness-bug.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/base.scm (binutils): Update to 2.37.
[source](patches): Remove obsolete patch.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/binutils-libiberty-endianness-bug.patch36
-rw-r--r--gnu/packages/patches/binutils-loongson-workaround.patch14
2 files changed, 7 insertions, 43 deletions
diff --git a/gnu/packages/patches/binutils-libiberty-endianness-bug.patch b/gnu/packages/patches/binutils-libiberty-endianness-bug.patch
deleted file mode 100644
index e6c82f704e..0000000000
--- a/gnu/packages/patches/binutils-libiberty-endianness-bug.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-This patch fixes a bug exposed when running the libiberty test suite on
-big-endian machines.
-
-Original bug report:
-https://sourceware.org/bugzilla/show_bug.cgi?id=27751
-Follow-ups:
-https://gcc.gnu.org/bugzilla/show_bug.cgi?id=100177
-https://gcc.gnu.org/pipermail/gcc-patches/2021-April/568314.html
-
----
- libiberty/rust-demangle.c | 9 ++++++---
- 1 file changed, 6 insertions(+), 3 deletions(-)
-
-diff --git a/libiberty/rust-demangle.c b/libiberty/rust-demangle.c
-index 6fd8f6a4db0..848563fa3c3 100644
---- a/libiberty/rust-demangle.c
-+++ b/libiberty/rust-demangle.c
-@@ -1253,9 +1253,12 @@ demangle_const_char (struct rust_demangler *rdm)
-   else if (value == '\n')
-     PRINT ("\\n");
-   else if (value > ' ' && value < '~')
--    /* Rust also considers many non-ASCII codepoints to be printable, but
--       that logic is not easily ported to C. */
--    print_str (rdm, (char *) &value, 1);
-+    {
-+      /* Rust also considers many non-ASCII codepoints to be printable, but
-+      that logic is not easily ported to C. */
-+      char c = value;
-+      print_str (rdm, &c, 1);
-+    }
-   else
-     {
-       PRINT ("\\u{");
--- 
-2.31.1
-
diff --git a/gnu/packages/patches/binutils-loongson-workaround.patch b/gnu/packages/patches/binutils-loongson-workaround.patch
index f43572a53d..68ab47de91 100644
--- a/gnu/packages/patches/binutils-loongson-workaround.patch
+++ b/gnu/packages/patches/binutils-loongson-workaround.patch
@@ -4,22 +4,22 @@ Patch by Mark H Weaver <mhw@netris.org>.
 
 --- binutils/gas/config/tc-mips.c.orig	2012-09-04 10:21:03.000000000 -0400
 +++ binutils/gas/config/tc-mips.c	2013-10-06 02:23:21.651983768 -0400
-@@ -910,10 +910,10 @@
+@@ -934,10 +934,10 @@ enum fix_vr4120_class
  };
  
  /* ...likewise -mfix-loongson2f-jump.  */
--static bfd_boolean mips_fix_loongson2f_jump;
-+static bfd_boolean mips_fix_loongson2f_jump = FALSE;
+-static bool mips_fix_loongson2f_jump;
++static bool mips_fix_loongson2f_jump = FALSE;
  
  /* ...likewise -mfix-loongson2f-nop.  */
--static bfd_boolean mips_fix_loongson2f_nop;
-+static bfd_boolean mips_fix_loongson2f_nop = TRUE;
+-static bool mips_fix_loongson2f_nop;
++static bool mips_fix_loongson2f_nop = FALSE;
  
  /* True if -mfix-loongson2f-nop or -mfix-loongson2f-jump passed.  */
- static bfd_boolean mips_fix_loongson2f;
+ static bool mips_fix_loongson2f;
 --- binutils/gas/testsuite/gas/mips/mips.exp.orig	2012-09-04 10:17:13.000000000 -0400
 +++ binutils/gas/testsuite/gas/mips/mips.exp	2013-10-06 02:23:21.663983768 -0400
-@@ -91,6 +91,12 @@
+@@ -110,6 +110,12 @@ proc mips_arch_init {} {
  
      # Catch because the variable won't be set the first time through.
      catch {unset mips_arches}