summary refs log tree commit diff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-07-27 00:17:47 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-07-28 14:54:18 +0200
commitcb8f7d6d2f87282bb0169c3136ccf3f44bc33105 (patch)
treeb7b4be11a04e756825c83b7525239c6260dffc98 /gnu/packages/patches
parent94eb59fb4ac3dfa501e9cac42454c030506ab7f1 (diff)
downloadguix-cb8f7d6d2f87282bb0169c3136ccf3f44bc33105.tar.gz
gnu: meson: Update to 0.47.1.
* gnu/packages/build-tools.scm (meson): Update to 0.47.1.
* gnu/packages/patches/meson-for-build-rpath.patch: Adjust to file rename and
indendation change.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/meson-for-build-rpath.patch33
1 files changed, 17 insertions, 16 deletions
diff --git a/gnu/packages/patches/meson-for-build-rpath.patch b/gnu/packages/patches/meson-for-build-rpath.patch
index 2151d53565..59249e294d 100644
--- a/gnu/packages/patches/meson-for-build-rpath.patch
+++ b/gnu/packages/patches/meson-for-build-rpath.patch
@@ -4,20 +4,21 @@ meson-build-system.
 
 Patch by Peter Mikkelsen <petermikkelsen10@gmail.com>
 
---- meson-0.42.0/mesonbuild/scripts/meson_install.py.orig	2017-09-09 01:49:39.147374148 +0200
-+++ meson-0.42.0/mesonbuild/scripts/meson_install.py	2017-09-09 01:51:01.209134717 +0200
-@@ -391,14 +391,6 @@
-                     print("Symlink creation does not work on this platform. "
-                           "Skipping all symlinking.")
-                     printed_symlink_error = True
--        if os.path.isfile(outname):
--            try:
--                depfixer.fix_rpath(outname, install_rpath, False)
--            except SystemExit as e:
--                if isinstance(e.code, int) and e.code == 0:
--                    pass
--                else:
--                    raise
-
+--- meson-0.42.0/mesonbuild/minstall.py.orig	2017-09-09 01:49:39.147374148 +0200
++++ meson-0.42.0/mesonbuild/minstall.py	2017-09-09 01:51:01.209134717 +0200
+@@ -436,15 +436,6 @@
+                         print("Symlink creation does not work on this platform. "
+                               "Skipping all symlinking.")
+                         printed_symlink_error = True
+-            if os.path.isfile(outname):
+-                try:
+-                    depfixer.fix_rpath(outname, install_rpath, final_path,
+-                                       install_name_mappings, verbose=False)
+-                except SystemExit as e:
+-                    if isinstance(e.code, int) and e.code == 0:
+-                        pass
+-                    else:
+-                        raise
+ 
  def run(args):
-     global install_log_file
+     parser = buildparser()