summary refs log tree commit diff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorAndy Patterson <ajpatter@uwaterloo.ca>2016-10-02 22:41:36 -0400
committer宋文武 <iyzsong@gmail.com>2016-10-08 21:20:35 +0800
commit4b51b21ccfa9b6368f4e4c4150928ba20b4b5369 (patch)
tree45fa782a09ca34c4190a721791cd50067705612a /gnu/packages/patches
parent5aa608a7e81649724b363d6c292d86334eb18a9e (diff)
downloadguix-4b51b21ccfa9b6368f4e4c4150928ba20b4b5369.tar.gz
gnu: Add cl-clx.
* gnu/packages/lisp.scm (cl-clx, sbcl-clx, ecl-clx): New variables.
* gnu/packages/patches/clx-remove-demo.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.

Signed-off-by: 宋文武 <iyzsong@gmail.com>
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/clx-remove-demo.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/patches/clx-remove-demo.patch b/gnu/packages/patches/clx-remove-demo.patch
new file mode 100644
index 0000000000..c5fffea0d0
--- /dev/null
+++ b/gnu/packages/patches/clx-remove-demo.patch
@@ -0,0 +1,27 @@
+--- a/clx.asd	2016-02-16 00:06:48.161596976 -0500
++++ b/clx.asd	2016-02-16 00:06:54.793774658 -0500
+@@ -79,24 +79,6 @@
+                (:file "xtest")
+                (:file "screensaver")
+                (:file "xinerama")))
+-     (:module demo
+-	      :default-component-class example-source-file
+-	      :components
+-	      ((:file "bezier")
+-	       ;; KLUDGE: this requires "bezier" for proper operation,
+-	       ;; but we don't declare that dependency here, because
+-	       ;; asdf doesn't load example files anyway.
+-	       (:file "beziertest")
+-	       (:file "clclock")
+-               (:file "clipboard")
+-	       (:file "clx-demos")
+-	       (:file "gl-test")
+-	       ;; FIXME: compiling this generates 30-odd spurious code
+-	       ;; deletion notes.  Find out why, and either fix or
+-	       ;; workaround the problem.
+-	       (:file "mandel")
+-	       (:file "menu")
+-	       (:file "zoid")))
+      (:module test
+ 	      :default-component-class example-source-file
+ 	      :components