summary refs log tree commit diff
path: root/gnu/packages/patchutils.scm
diff options
context:
space:
mode:
authorTomáš Čech <sleep_walker@gnu.org>2015-03-18 00:01:48 +0100
committerTomáš Čech <sleep_walker@gnu.org>2015-03-19 14:50:07 +0100
commit285d8f0dca62d2b2865dfa4787baca406c70671f (patch)
treef6daa4d73a425221cc3b3108ce8fd98b7f7733b8 /gnu/packages/patchutils.scm
parent2a31e1dadefc522d13b47c671254f706fb5ea3a6 (diff)
downloadguix-285d8f0dca62d2b2865dfa4787baca406c70671f.tar.gz
gnu: Add colordiff.
* gnu/packages/patchutils.scm (colordiff): New variable.
Diffstat (limited to 'gnu/packages/patchutils.scm')
-rw-r--r--gnu/packages/patchutils.scm32
1 files changed, 31 insertions, 1 deletions
diff --git a/gnu/packages/patchutils.scm b/gnu/packages/patchutils.scm
index 48f4d29584..cf8a6e494b 100644
--- a/gnu/packages/patchutils.scm
+++ b/gnu/packages/patchutils.scm
@@ -28,7 +28,8 @@
   #:use-module (gnu packages file)
   #:use-module (gnu packages gawk)
   #:use-module (gnu packages less)
-  #:use-module (gnu packages perl))
+  #:use-module (gnu packages perl)
+  #:use-module (gnu packages xml))
 
 (define-public patchutils
   (package
@@ -140,3 +141,32 @@ listing the files modified by a patch.")
 track of the changes each patch makes.  Patches can be applied, un-applied,
 refreshed, and more.")
     (license gpl2)))
+
+(define-public colordiff
+  (package
+    (name "colordiff")
+    (version "1.0.13")
+    (source
+     (origin
+      (method url-fetch)
+      (uri (string-append "http://www.colordiff.org/colordiff-"
+                          version ".tar.gz"))
+      (sha256
+       (base32 "0akcz1p3klsjnhwcqdfq4grs6paljc5c0jzr3mqla5f862hhaa6f"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:tests? #f
+       #:make-flags (list (string-append "DESTDIR=" (assoc-ref %outputs "out"))
+                          "INSTALL_DIR=/bin" "MAN_DIR=/share/man/man1")
+       #:phases
+       (alist-delete 'configure
+                     (alist-delete 'build %standard-phases))))
+    (inputs
+     `(("perl" ,perl)
+       ("xmlto" ,xmlto)))
+    (home-page "http://www.colordiff.org")
+    (synopsis "Display diff output with colors")
+    (description
+     "Colordiff is Perl script wrapper on top of diff command which provides
+'syntax highlighting' for various patch formats.")
+    (license gpl2+)))