summary refs log tree commit diff
path: root/gnu/packages/patchutils.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-09-01 00:20:28 +0200
committerMarius Bakke <marius@gnu.org>2020-09-22 18:41:52 +0200
commitac3103e8f32005e694701f57fe75ea39df8765b7 (patch)
treef5325dea481c3b98c3efb556c2cc9402c4fd8bc7 /gnu/packages/patchutils.scm
parentb2eafc7d8d5fe9b6e0b6c18f670a53bd68314fa4 (diff)
downloadguix-ac3103e8f32005e694701f57fe75ea39df8765b7.tar.gz
gnu: python-django: Update to 3.1.1.
* gnu/packages/django.scm (python-django): Update to 3.1.1.
[arguments]: Remove #:modules.  Rename set-tzdir phase to pre-check, and
disable one test.  Adjust PYTHONPATH patching to preserve all entries.  Ensure
the test suite runs sequentially.
[propagated-inputs]: Add PYTHON-ASGIREF.
(python-django-2.2): New public variable.
* gnu/packages/mail.scm (python-hyperkitty)[propagated-inptus]: Change from
PYTHON-DJANGO to PYTHON-DJANGO-2.2.
* gnu/packages/patchutils.scm (patchwork)[propagated-inputs]: Likewise.
Diffstat (limited to 'gnu/packages/patchutils.scm')
-rw-r--r--gnu/packages/patchutils.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/patchutils.scm b/gnu/packages/patchutils.scm
index c26977be1f..335d251e74 100644
--- a/gnu/packages/patchutils.scm
+++ b/gnu/packages/patchutils.scm
@@ -467,7 +467,7 @@ if __name__ == \"__main__\":
     (inputs
      `(("python-wrapper" ,python-wrapper)))
     (propagated-inputs
-     `(("python-django" ,python-django)
+     `(("python-django" ,python-django-2.2)
        ;; TODO: Make this configurable
        ("python-psycopg2" ,python-psycopg2)
        ("python-mysqlclient" ,python-mysqlclient)