summary refs log tree commit diff
path: root/gnu/packages/patchutils.scm
diff options
context:
space:
mode:
authorLeo Prikler <leo.prikler@student.tugraz.at>2019-10-25 11:17:26 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2019-10-27 10:50:36 +0100
commitb901a56615deebfb8fffe5b13286abc6da91dee2 (patch)
treea2fc2e045f416cef7833331d6585fd38fd755d36 /gnu/packages/patchutils.scm
parent2a19c0deb1da3a9afa8960367a5b84321386ceae (diff)
downloadguix-b901a56615deebfb8fffe5b13286abc6da91dee2.tar.gz
gnu: meld: Fix startup.
* /gnu/packages/patchutils.scm: (meld)[inputs]: Replace gtksourceview with
gtksourceview-3.
[arguments]<#:phases>[wrap-typelib]: New phase.

Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu/packages/patchutils.scm')
-rw-r--r--gnu/packages/patchutils.scm11
1 files changed, 9 insertions, 2 deletions
diff --git a/gnu/packages/patchutils.scm b/gnu/packages/patchutils.scm
index a63d889cff..4cd6bbbf48 100644
--- a/gnu/packages/patchutils.scm
+++ b/gnu/packages/patchutils.scm
@@ -265,7 +265,7 @@ GiB).")
     (inputs
      `(("python-cairo" ,python-pycairo)
        ("python-gobject" ,python-pygobject)
-       ("gtksourceview" ,gtksourceview)))
+       ("gtksourceview" ,gtksourceview-3)))
     (propagated-inputs
      `(("dconf" ,dconf)))
     (arguments
@@ -292,7 +292,14 @@ GiB).")
              (setenv "HOME" "/tmp")
              (invoke "py.test" "-v" "-k"
                      ;; TODO: Those tests fail, why?
-                     "not test_classify_change_actions"))))))
+                     "not test_classify_change_actions")))
+         (add-after 'wrap 'wrap-typelib
+           (lambda* (#:key inputs outputs #:allow-other-keys)
+             (let ((out (assoc-ref outputs "out")))
+               (wrap-program (string-append out "/bin/meld")
+                 `("GI_TYPELIB_PATH" prefix
+                   ,(search-path-as-string->list (getenv "GI_TYPELIB_PATH"))))
+               #t))))))
     (home-page "https://meldmerge.org/")
     (synopsis "Compare files, directories and working copies")
     (description "Meld is a visual diff and merge tool targeted at