summary refs log tree commit diff
path: root/gnu/packages/patchutils.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-03-25 10:52:52 +0100
committerLudovic Courtès <ludo@gnu.org>2015-03-25 10:52:52 +0100
commit25d5b708a636ecf779035f75ad110574fc0262b9 (patch)
tree7d8429a59b7523d79790c5f4cdb5b96fabe8494e /gnu/packages/patchutils.scm
parent17287d7d47567aa1649250182e0f7ab11d5d55d1 (diff)
parent614c2188420a266ec512c9c04af3bb2ea46c4dc4 (diff)
downloadguix-25d5b708a636ecf779035f75ad110574fc0262b9.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/patchutils.scm')
-rw-r--r--gnu/packages/patchutils.scm32
1 files changed, 31 insertions, 1 deletions
diff --git a/gnu/packages/patchutils.scm b/gnu/packages/patchutils.scm
index 48f4d29584..cf8a6e494b 100644
--- a/gnu/packages/patchutils.scm
+++ b/gnu/packages/patchutils.scm
@@ -28,7 +28,8 @@
   #:use-module (gnu packages file)
   #:use-module (gnu packages gawk)
   #:use-module (gnu packages less)
-  #:use-module (gnu packages perl))
+  #:use-module (gnu packages perl)
+  #:use-module (gnu packages xml))
 
 (define-public patchutils
   (package
@@ -140,3 +141,32 @@ listing the files modified by a patch.")
 track of the changes each patch makes.  Patches can be applied, un-applied,
 refreshed, and more.")
     (license gpl2)))
+
+(define-public colordiff
+  (package
+    (name "colordiff")
+    (version "1.0.13")
+    (source
+     (origin
+      (method url-fetch)
+      (uri (string-append "http://www.colordiff.org/colordiff-"
+                          version ".tar.gz"))
+      (sha256
+       (base32 "0akcz1p3klsjnhwcqdfq4grs6paljc5c0jzr3mqla5f862hhaa6f"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:tests? #f
+       #:make-flags (list (string-append "DESTDIR=" (assoc-ref %outputs "out"))
+                          "INSTALL_DIR=/bin" "MAN_DIR=/share/man/man1")
+       #:phases
+       (alist-delete 'configure
+                     (alist-delete 'build %standard-phases))))
+    (inputs
+     `(("perl" ,perl)
+       ("xmlto" ,xmlto)))
+    (home-page "http://www.colordiff.org")
+    (synopsis "Display diff output with colors")
+    (description
+     "Colordiff is Perl script wrapper on top of diff command which provides
+'syntax highlighting' for various patch formats.")
+    (license gpl2+)))