summary refs log tree commit diff
path: root/gnu/packages/pciutils.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-07-10 10:37:48 +0200
committerLudovic Courtès <ludo@gnu.org>2017-07-10 10:37:48 +0200
commit841e06af71d264b5fbec56f96aec8aa933fbeab2 (patch)
treec09fa71337e5cd9afd8fdc743e8618006248a3d8 /gnu/packages/pciutils.scm
parent539a68f938d734cc48c365a2f91521f4c4a4c1f0 (diff)
downloadguix-841e06af71d264b5fbec56f96aec8aa933fbeab2.tar.gz
gnu: pciutils: Move 'pci.ids.gz' to 'share/hwdata'.
* gnu/packages/pciutils.scm (pciutils)[arguments] <configure>: Set
'IDSDIR' such that 'pci.ids.gz' goes to share/hwdata.
Diffstat (limited to 'gnu/packages/pciutils.scm')
-rw-r--r--gnu/packages/pciutils.scm12
1 files changed, 9 insertions, 3 deletions
diff --git a/gnu/packages/pciutils.scm b/gnu/packages/pciutils.scm
index a3d85e8386..51962d2739 100644
--- a/gnu/packages/pciutils.scm
+++ b/gnu/packages/pciutils.scm
@@ -1,5 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2014, 2015 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2014, 2015, 2017 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
 ;;;
 ;;; This file is part of GNU Guix.
@@ -56,12 +56,18 @@
                  ;; $prefix/share/man, and wrongly so.
                 (string-append "MANDIR := " (assoc-ref outputs "out")
                                "/share/man\n"))
+
                (("^SHARED=.*$")
                 ;; Build libpciutils.so.
                 "SHARED := yes\n")
                (("^ZLIB=.*$")
-                ;; Ask for zlib support.
-                "ZLIB := yes\n"))))
+                ;; Ask for zlib support, for 'pci.ids.gz' decompression.
+                "ZLIB := yes\n")
+
+               (("^IDSDIR=.*$")
+                ;; Installation directory of 'pci.ids.gz'.
+                "IDSDIR = $(SHAREDIR)/hwdata\n"))
+             #t))
          (replace 'install
            (lambda* (#:key outputs #:allow-other-keys)
              ;; Install the commands, library, and .pc files.